Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-29-03, 12:09 AM   #1
ahenders
Registered User
 
Join Date: Jan 2003
Posts: 3
Unhappy Blank screen of death - nvidia and Redhat 8

I running Redhat 8 with kernel 2.4.18-19, and installed a nvidia driver by source. The card is a RIVA TNT2 M64.

Now X starts up just fine, and I assume that the hardware accel and openGL are working as the "gears" demo runs very nicely but when I try to run other openGL apps the screen goes completely blank. It almost sounds like it has switched to a different screen mode - the click and hiss of static?

At this stage the screen res <ctl><alt><+> or <-> does not help, nor does switching apps or windows. There is simply nothing left to do but reset the machine.
ahenders is offline   Reply With Quote
Old 01-29-03, 08:37 AM   #2
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default

Have you tried the ctrl-alt-Fx approch??

Switch to the screen, where you started X, and press ctrl-C.

Then restart X.
Wolfman [TWP] is offline   Reply With Quote
Old 01-29-03, 05:45 PM   #3
ahenders
Registered User
 
Join Date: Jan 2003
Posts: 3
Default

Thanx Wolfman I hadn't tried the old fn key approach. When I switch back to the original screen that x was started from I now find the xserver has aborted - caught signal 11. This at least explains why my screen was going blank.

The XFree86.0.log file doesn't really show the last thing the server tried to do - the two GetModeLine lines were there before the crash - see attached.
Attached Files
File Type: txt xfree86.0.log.txt (19.8 KB, 154 views)
ahenders is offline   Reply With Quote
Old 01-30-03, 06:11 AM   #4
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default

After looking at your XFree86.0.log.txt file. I noticed that you are also running a HW frame buffer. Try running X with the fbdevhw module in your XF86Config file disabled. And see how that goes. I've read on the forums that alot of people seem to have problems with that. (I checked mine and it was enabled too, so I removed it, without any change).. But then my system uses an AMD chipset, and the fbdevhw module reacts differently, from chipset to chipset...
Wolfman [TWP] is offline   Reply With Quote
Old 01-31-03, 01:46 AM   #5
ahenders
Registered User
 
Join Date: Jan 2003
Posts: 3
Lightbulb

Thanks Wolfman but unfortunately the x-server still crashes. I have more or less worked my way through all the FAQs. I did notice one thing I have two different versions of the openGL header files:-

ll /usr/share/doc/NVIDIA_GLX-1.0/include/GL/
-r--r--r-- 1 root root 148924 Jan 29 10:13 gl.h
-r--r--r-- 1 root root 9827 Jan 29 10:13 glx.h
-r--r--r-- 1 root root 10978 Jan 29 10:13 glxtokens.h

and also

-r--r--r-- 1 root root 77761 Sep 6 13:28
/usr/include/GL/gl.h
-r--r--r-- 1 root root 15916 Sep 6 13:28
/usr/include/GL/glx.h
-r--r--r-- 1 root root 8370 Sep 6 13:28
/usr/include/GL/glxtokens.h

Could this be part of the problem?
ahenders is offline   Reply With Quote
Old 01-31-03, 07:42 AM   #6
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default

I don't think that will be a problem, as I have the same type of files in the same directories.

The only thing different being the creation dates.

This is a list of my files in the:
/usr/share/doc/NVIDIA_GLX-1.0/include/GL/ directory.

-r--r--r-- 1 root root 148924 Dec 9 10:26 gl.h
-r--r--r-- 1 root root 9827 Dec 9 10:26 glx.h
-r--r--r-- 1 root root 10978 Dec 9 10:26 glxtokens.h

I believe that the others are for the MESA driver, which is not used.
Wolfman [TWP] is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
NVidia Drivers HowTo for RedHat 8.0 needed eduardp NVIDIA Linux 10 10-04-02 03:59 AM
Redhat 7.3 + Nvidia drivers 3123 = troubles e-r-a-n NVIDIA Linux 4 09-17-02 12:26 PM
RedHAT didn't like nVidia GeForce 4 MX 440 alfa2k1 NVIDIA Linux 13 08-09-02 05:06 PM
Working RedHat 7.3 with Nvidia?? Be'Lal NVIDIA Linux 3 08-03-02 05:16 PM

All times are GMT -5. The time now is 11:39 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.