Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-15-05, 10:56 AM   #1
ethan
Registered User
 
Join Date: Aug 2005
Posts: 1
Default Getting SUSe to work with Nvidia.

Hi. I am a newbie to LInux land and am ahaving some troubles getting my Quadro 3400 card to configure under SUSE 9.3.

After instaling the drivers in init 3 I see the right card shows up in SAX 2 but there is no 3d acceleration and no opportunity to use use two monitors at 1200 x 3200 rez ( single screen stretching across two monitors ). If anybody out there has something like this configured already in their x86 or Xorg please I would love to see how you did it.

Best
-ethan
ethan is offline   Reply With Quote
Old 08-15-05, 07:02 PM   #2
Thoreau
Registered User
 
Join Date: Dec 2002
Posts: 95
Default Re: Getting SUSe to work with Nvidia.

Get you monitors hoziontal and vertical sync ranges(30-86/50-160 for 17"). Get your monitors horizontal and vertical physical viewable size.(310X230 for a 17"). Read it off the online tech spec manual.

Login as root
Type:

init 3
yast
yast online update
next,next,next,install
reboot, rinse, repeat if necessary

uname -a
ls /usr/src/*
Are your kernels the same? I hope so, cause if not- you're screwed.

login as root
init 3
cd /usr/src/linux
make clone-config
make prepare-all
./NVIDIA*.run -q --kernel-source-path=/usr/src/linux
yes,yes,install
modprobe nvidia
sax2 -m 0=nvidia
choose the proper monitor type, then resolution, then physical viewable size- and enable 3D. Know your hardware details before you do this.
Save settings.
/sbin/ldconfig

less /etc/X11/XF86Config
Make sure Driver = nvidia, line like so:
Section "Device"
BoardName "GeForce FX 5950 Ultra"
BusID "3:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
VendorName "NVidia"
EndSection

If it does have it, good. If it has nv, change it to nvidia.

Reboot, and you are done.
Thoreau is offline   Reply With Quote
Old 08-16-05, 10:14 AM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Getting SUSe to work with Nvidia.

ethan,
To add to the previous suggestions, sax2 knows virtually nothing about the nvidia driver, and will typically not indicate whether 3D acceleration is activated, or provide any assistance in setting up any fancy configurations. As long as you specify the glx X module and it is successfully loaded (check your X log), you will have 3D acceleration.

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 12:54 AM
Suse 8.1 and Nvidia drivers tombraider500 NVIDIA Linux 4 10-06-02 11:19 AM
Trouble with SuSE 8 & NVIDIA latest driver bughill NVIDIA Linux 3 08-20-02 12:31 PM

All times are GMT -5. The time now is 10:01 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.