Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-23-05, 08:58 PM   #1
anvilak
Registered User
 
Join Date: Aug 2005
Posts: 4
Default Can't get GeForce 6600 to run in X

Hi, I just bought an Asus GeForce N6600 AGP card today. I can't seem to get Linux to recognize it.

I'm running:
Debian Sarge stable/unstable with a custom built 2.6.12.5 kernel
XFree86 4.3.0.1
NVIDIA drivers 1.0-7676

When I run lspci, I get the following at the end:
0000:03:00.0 VGA compatible controller: nVidia Corporation: Unknown device 00f2 (rev a2)

So the kernel seems to know my card is there, but it registers as an "Unknown device".

The nvidia kernel module seems to load successfully.

I get the following wierd line when I try to look at the nvidia driver line in /dev

# ls -ld nvidia*
ls: nvidia0: Input/output error
crw-rw-rw- 1 root root 195, 255 Aug 21 19:41 nvidiactl

It won't even list the nvidia0 driver in a directory listing!

I am able to use the card successfully in Windows, but not in Linux. I am able to run X in a degraded mode if I used the "vesa" driver, instead of the "nv" driver, but it's painful.

Following is the output of my XFree86 log file when I try to start it. I find it curious that the GeForce 6600 is not in the list of supported chipsets listed by the driver (I've tried to snip some of the non-interesting parts to make this post fit).

Any help is appreciated!

XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-14 20050601051219 fabbione@fabbione.net)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.29-pre2 i686 [ELF]
Build Date: 01 June 2005

This version of XFree86 has been extensively modified by the Debian
Project, and is not supported by the XFree86 Project, Inc., in any
way. Bugs should be reported to the Debian Bug Tracking System; see
<URL: http://www.debian.org/Bugs/Reporting >.

We strongly encourage the use of the "reportbug" package and command
to ensure that bug reports contain as much useful information as
possible.

Before filing a bug report, you may want to consult the Debian X FAQ:
XHTML version: file:///usr/share/doc/xfree86-common/FAQ.xhtml
plain text version: file:///usr/share/doc/xfree86-common/FAQ.gz

Module Loader present
OS Kernel: Linux version 2.6.12.5 (root@dunlikus) (gcc version 4.0.1 (Debian 4.0.1-2)) #1 Sun Aug 21 11:13:01 EDT 2005 T
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Tue Aug 23 21:38:20 2005
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "NEC Monitor"
(**) | |-->Device "nvidia0"
(**) |-->Input Device "Generic Keyboard"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc105"
(**) XKB: model: "pc105"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "LMPCM"
(WW) The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/CID" does not exist.
Entry deleted from font path.
(**) FontPath set to "unix/:7100,/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/100dpi/:unscaled,/usr/lib/X11/fonts/75dpi/:unscaled,/usr/lib/X11/fonts/Type1,/usr/lib/X11/fonts/Speedo,/usr/lib/X11/fonts/100dpi,/usr/lib/X11/fonts/75dpi"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(WW) Open APM failed (/dev/apm_bios) (No such device)
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6
XFree86 XInput driver : 0.4
XFree86 Server Extension : 0.2
XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
..
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 10de,01e0 card 1043,80ac rev c1 class 06,00,00 hdr 80
..
(II) PCI: 03:00:0: chip 10de,00f2 card 1043,81b1 rev a2 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,3), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:1:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:8:0), (0,1,1), BCTRL: 0x0002 (VGA_EN is cleared)
(II) Bus 1 I/O range:
[0] -1 0 0x0000a000 - 0x0000bfff (0x2000) IX[b]
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xe6000000 - 0xe7ffffff (0x2000000) MX[b]
(II) PCI-to-PCI bridge:
(II) Bus 3: bridge is at (0:30:0), (0,3,3), BCTRL: 0x000a (VGA_EN is set)
(II) Bus 3 non-prefetchable memory range:
[0] -1 0 0xe3000000 - 0xe5ffffff (0x3000000) MX[b]
(II) Bus 3 prefetchable memory range:
[0] -1 0 0xd0000000 - 0xdfffffff (0x10000000) MX[b]
(--) PCI:*(3:0:0) nVidia Corporation unknown chipset (0x00f2) rev 162, Mem @ 0xe3000000/24, 0xd0000000/28, 0xe4000000/24
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) OS-reported resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
(II) PCI Memory resource overlap reduced 0xe0000000 from 0xe1ffffff to 0xdfffffff
(II) Active PCI resource ranges:
[0] -1 0 0xe7004000 - 0xe70041ff (0x200) MX[b]
[1] -1 0 0xe7000000 - 0xe7003fff (0x4000) MX[b]
[2] -1 0 0xe8085000 - 0xe808503f (0x40) MX[b]
[3] -1 0 0xe8084000 - 0xe80847ff (0x800) MX[b]
[4] -1 0 0xe8080000 - 0xe8080fff (0x1000) MX[b]
[5] -1 0 0xe8000000 - 0xe807ffff (0x80000) MX[b]
[6] -1 0 0xe8086000 - 0xe8086fff (0x1000) MX[b]
[7] -1 0 0xe8083000 - 0xe80830ff (0x100) MX[b]
[8] -1 0 0xe8082000 - 0xe8082fff (0x1000) MX[b]
[9] -1 0 0xe8087000 - 0xe8087fff (0x1000) MX[b]
[10] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[b]O
[11] -1 0 0xe4000000 - 0xe4ffffff (0x1000000) MX[b](B)
[12] -1 0 0xd0000000 - 0xdfffffff (0x10000000) MX[b](B)
[13] -1 0 0xe3000000 - 0xe3ffffff (0x1000000) MX[b](B)
[14] -1 0 0x0000b400 - 0x0000b40f (0x10) IX[b]
[15] -1 0 0x0000b000 - 0x0000b003 (0x4) IX[b]
[16] -1 0 0x0000ac00 - 0x0000ac07 (0x8) IX[b]
[17] -1 0 0x0000a800 - 0x0000a803 (0x4) IX[b]
[18] -1 0 0x0000a400 - 0x0000a407 (0x8) IX[b]
[19] -1 0 0x0000a000 - 0x0000a0ff (0x100) IX[b]
[20] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[b]
[21] -1 0 0x0000d400 - 0x0000d47f (0x80) IX[b]
[22] -1 0 0x0000d000 - 0x0000d0ff (0x100) IX[b]
[23] -1 0 0x0000e400 - 0x0000e407 (0x8) IX[b]
[24] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[b]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xe7004000 - 0xe70041ff (0x200) MX[b]
[1] -1 0 0xe7000000 - 0xe7003fff (0x4000) MX[b]
[2] -1 0 0xe8085000 - 0xe808503f (0x40) MX[b]
[3] -1 0 0xe8084000 - 0xe80847ff (0x800) MX[b]
[4] -1 0 0xe8080000 - 0xe8080fff (0x1000) MX[b]
[5] -1 0 0xe8000000 - 0xe807ffff (0x80000) MX[b]
[6] -1 0 0xe8086000 - 0xe8086fff (0x1000) MX[b]
[7] -1 0 0xe8083000 - 0xe80830ff (0x100) MX[b]
[8] -1 0 0xe8082000 - 0xe8082fff (0x1000) MX[b]
[9] -1 0 0xe8087000 - 0xe8087fff (0x1000) MX[b]
[10] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[b]O
[11] -1 0 0xe4000000 - 0xe4ffffff (0x1000000) MX[b](B)
[12] -1 0 0xd0000000 - 0xdfffffff (0x10000000) MX[b](B)
[13] -1 0 0xe3000000 - 0xe3ffffff (0x1000000) MX[b](B)
[14] -1 0 0x0000b400 - 0x0000b40f (0x10) IX[b]
[15] -1 0 0x0000b000 - 0x0000b003 (0x4) IX[b]
[16] -1 0 0x0000ac00 - 0x0000ac07 (0x8) IX[b]
[17] -1 0 0x0000a800 - 0x0000a803 (0x4) IX[b]
[18] -1 0 0x0000a400 - 0x0000a407 (0x8) IX[b]
[19] -1 0 0x0000a000 - 0x0000a0ff (0x100) IX[b]
[20] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[b]
[21] -1 0 0x0000d400 - 0x0000d47f (0x80) IX[b]
[22] -1 0 0x0000d000 - 0x0000d0ff (0x100) IX[b]
[23] -1 0 0x0000e400 - 0x0000e407 (0x8) IX[b]
[24] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[b]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
(II) All system resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0xe7004000 - 0xe70041ff (0x200) MX[b]
[6] -1 0 0xe7000000 - 0xe7003fff (0x4000) MX[b]
[7] -1 0 0xe8085000 - 0xe808503f (0x40) MX[b]
[8] -1 0 0xe8084000 - 0xe80847ff (0x800) MX[b]
[9] -1 0 0xe8080000 - 0xe8080fff (0x1000) MX[b]
[10] -1 0 0xe8000000 - 0xe807ffff (0x80000) MX[b]
[11] -1 0 0xe8086000 - 0xe8086fff (0x1000) MX[b]
[12] -1 0 0xe8083000 - 0xe80830ff (0x100) MX[b]
[13] -1 0 0xe8082000 - 0xe8082fff (0x1000) MX[b]
[14] -1 0 0xe8087000 - 0xe8087fff (0x1000) MX[b]
[15] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[b]O
[16] -1 0 0xe4000000 - 0xe4ffffff (0x1000000) MX[b](B)
[17] -1 0 0xd0000000 - 0xdfffffff (0x10000000) MX[b](B)
[18] -1 0 0xe3000000 - 0xe3ffffff (0x1000000) MX[b](B)
[19] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[20] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[21] -1 0 0x0000b400 - 0x0000b40f (0x10) IX[b]
[22] -1 0 0x0000b000 - 0x0000b003 (0x4) IX[b]
[23] -1 0 0x0000ac00 - 0x0000ac07 (0x8) IX[b]
[24] -1 0 0x0000a800 - 0x0000a803 (0x4) IX[b]
[25] -1 0 0x0000a400 - 0x0000a407 (0x8) IX[b]
[26] -1 0 0x0000a000 - 0x0000a0ff (0x100) IX[b]
[27] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[b]
[28] -1 0 0x0000d400 - 0x0000d47f (0x80) IX[b]
[29] -1 0 0x0000d000 - 0x0000d0ff (0x100) IX[b]
[30] -1 0 0x0000e400 - 0x0000e407 (0x8) IX[b]
[31] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[b]
(II) LoadModule: "bitmap"
..
(II) LoadModule: "dbe"
..
(II) LoadModule: "ddc"
..
(II) LoadModule: "extmod"
..
(II) LoadModule: "freetype"
..
(II) LoadModule: "int10"
..
(II) LoadModule: "record"
..
(II) LoadModule: "speedo"
..
(II) LoadModule: "type1"
..
(II) LoadModule: "vbe"
..
(II) LoadModule: "nv"
(II) Loading /usr/X11R6/lib/modules/drivers/nv_drv.o
(II) Module nv: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.1
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
Unknown TNT2, Vanta, RIVA TNT2 Ultra, RIVA TNT2 Model 64,
Aladdin TNT2, GeForce 256, GeForce DDR, Quadro, GeForce2 MX/MX 400,
GeForce2 MX 100/200, GeForce2 Go, Quadro2 MXR/EX/Go,
GeForce2 Integrated GPU, GeForce2 GTS, GeForce2 Ti, GeForce2 Ultra,
Quadro2 Pro, GeForce4 MX 460, GeForce4 MX 440, GeForce4 MX 420,
GeForce4 MX 440-SE, GeForce4 440 Go, GeForce4 420 Go,
GeForce4 420 Go 32M, GeForce4 460 Go, GeForce4 440 Go 64M,
GeForce4 410 Go 16M, Quadro4 500 GoGL, Quadro4 550 XGL, Quadro4 NVS,
GeForce4 MX 440 with AGP8X, GeForce4 MX 440SE with AGP8X,
GeForce4 MX 420 with AGP8X, GeForce4 448 Go, GeForce4 488 Go,
Quadro4 580 XGL, Quadro4 280 NVS, Quadro4 380 XGL,
GeForce4 MX Integrated GPU, GeForce3, GeForce3 Ti 200,
GeForce3 Ti 500, Quadro DCC, GeForce4 Ti 4600, GeForce4 Ti 4400,
0x0252, GeForce4 Ti 4200, Quadro4 900 XGL, Quadro4 750 XGL,
Quadro4 700 XGL, GeForce4 Ti 4800, GeForce4 Ti 4200 with AGP8X,
GeForce4 Ti 4800 SE, GeForce4 4200 Go, Quadro4 700 GoGL,
Quadro4 980 XGL, Quadro4 780 XGL, GeForce FX 5800 Ultra,
GeForce FX 5800, Quadro FX 2000, Quadro FX 1000,
GeForce FX 5600 Ultra, GeForce FX 5600, 0x0313, GeForce FX 5600SE,
0x0316, 0x0317, GeForce FX Go5600, GeForce FX Go5650,
Quadro FX Go700, 0x031D, 0x031E, 0x031F, GeForce FX 5200,
GeForce FX 5200 Ultra, GeForce FX 5200, GeForce FX 5200SE,
GeForce FX Go5200, GeForce FX Go5250, GeForce FX Go5200 32M/64M,
0x0329, Quadro NVS 280 PCI, Quadro FX 500, GeForce FX Go5300,
GeForce FX Go5100, 0x032F, GeForce FX 5900 Ultra, GeForce FX 5900,
GeForce FX 5900XT, GeForce FX 5950 Ultra, 0x0334, Quadro FX 3000,
GeForce FX 5700 Ultra, GeForce FX 5700, GeForce FX 5700LE,
GeForce FX 5700VE, 0x0345, GeForce FX Go5700, GeForce FX Go5700,
0x0349, 0x034B, Quadro FX Go1000, Quadro FX 1100, 0x034F
(II) Primary Device is: PCI 03:00:0
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to submit@bugs.debian.org.
anvilak is offline   Reply With Quote
Old 08-23-05, 09:03 PM   #2
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: Can't get GeForce 6600 to run in X

change in /etc/X11/XF86Config-4

Driver "nv" to "nvidia" and try again...
if it doesn't work, run nvidia-bug-report.sh and attach the created log!
chunkey is offline   Reply With Quote
Old 08-23-05, 09:05 PM   #3
JaXXoN
Registered User
 
Join Date: Jul 2005
Location: Munich
Posts: 910
Default Re: Can't get GeForce 6600 to run in X

Quote:
Originally Posted by anvilak
I get the following wierd line when I try to look at the nvidia driver line in /dev

# ls -ld nvidia*
ls: nvidia0: Input/output error
crw-rw-rw- 1 root root 195, 255 Aug 21 19:41 nvidiactl
Looks like you are having problems accessing the hard drive. Maybe "just"
the filesystem is corrupt. Are there any hints in "dmesg". Please attach the
full nvidia-bug-report. What happens if you try to move the nvidia* files
to i.e. /tmp and back to /dev ?

regards

Bernhard
JaXXoN is offline   Reply With Quote
Old 08-23-05, 09:58 PM   #4
anvilak
Registered User
 
Join Date: Aug 2005
Posts: 4
Default Re: Can't get GeForce 6600 to run in X

Thanks for the rapid responses guys.

I tried changing my driver to "nvidia", but that doesn't help. I've attached a bug report in the file nvidia-bug-report.log.1.zip with this attempt.

I tried moving the nvidia0 file, but that doesn't work, I can't even stat the file:

# mv nvidia0 /tmp
mv: cannot stat `nvidia0': Input/output error

--
Rob
Attached Files
File Type: zip nvidia-bug-report.log.1.zip (16.4 KB, 122 views)
anvilak is offline   Reply With Quote
Old 08-23-05, 10:51 PM   #5
JaXXoN
Registered User
 
Join Date: Jul 2005
Location: Munich
Posts: 910
Default Re: Can't get GeForce 6600 to run in X

Quote:
Originally Posted by anvilak
# mv nvidia0 /tmp
mv: cannot stat `nvidia0': Input/output error
Rob
Again, what does "dmesg" say after trying to move the file?

I couldn't see anything suspicious in the bug report, but maybe you generated
that log before trying to move the file?

Seems like it is just an incident that the nvidia device files are affected.

regards

Bernhard
JaXXoN is offline   Reply With Quote
Old 08-24-05, 06:32 AM   #6
anvilak
Registered User
 
Join Date: Aug 2005
Posts: 4
Default Re: Can't get GeForce 6600 to run in X

dmesg doesn't say anything different before or after trying to move those two device files. I can't do anything with /dev/nvidia0. I can't ls it, or mv it, or rm it. I guess the inode for that file must be toast.
anvilak is offline   Reply With Quote
Old 08-24-05, 06:51 AM   #7
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Can't get GeForce 6600 to run in X

We really need dmesg as very likely the nvidia driver failed to initialize your videocard for some reason. That's the reason X failes too. Further /dev/nvidia0 is a very important file, it is used to reach the GPU.
Thunderbird is offline   Reply With Quote
Old 08-24-05, 06:57 AM   #8
anvilak
Registered User
 
Join Date: Aug 2005
Posts: 4
Default Re: Can't get GeForce 6600 to run in X

Thanks all! The problem was indeed file system corruption. After fsck'ing that partition, I found that a number of inodes were corrupted, including the one for /dev/nvidia0. I deleted it, and recreated it (mknod /dev/nvidia0 c 195 0), and everything seemed to work correctly after that.

--
Rob
anvilak is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
What You Can Expect From GeForce GRID News Archived News Items 0 06-04-12 04:20 PM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 12:24 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.