Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-23-05, 12:38 PM   #1
McCloud
Registered User
 
Join Date: Apr 2005
Posts: 5
Default TV-Out with 7676 (Geforce 3 Ti500)

Hello,

I know for sure that at one moment in time I had this working, tv-out on Debian Sarge with the nVidia drivers (I was using XFree at that time).

I have been busy all day, trying to get my tv-out working again with the new drivers (I also tried the old driver 7167) and Xorg, but I can't get it to work. I have tried numerous tutorials, I've used my old XFree86 config as a reference, changed every option I could think of in my xorg.conf, but it just doesn't work. My screen stays completely black.

I know that tv-out is working in Windows (booted to Windows, haven't been there a long time, to check if nothing was wrong with the cables or ideo-card).

So, is there someone who is experiencing the same problems?? Or is there someone who got this thing to work using a Leadtek Geforce 3???

Here is a part of my current xorg.conf:

Section "Device"
Identifier "nvidia_tv_out"
Driver "nvidia"
VendorName "Leadtek"
BoardName "nVidia GeForce 3 Ti500"
# TV Out Setup
Option "TVOverScan" "0.6"
Option "NvAGP" "1" #"4"
Option "DPMS" "on"
Option "NoLogo" "on"
Option "RenderAccel" "on"
Option "TVStandard" "PAL-B"
Option "TVOutFormat" "COMPOSITE"
Option "ConnectedMonitor" "TV"
Option "NoDDC" "True"
EndSection

Section "Monitor"
HorizSync 30-50
VertRefresh 60
Identifier "tv"
EndSection

Section "Screen"
Identifier "Screen_tv"
Device "nvidia_tv_out"
Monitor "tv"
DefaultDepth 16
SubSection "Display"
Depth 16
# Modes "768x576"
Modes "1024x768" "800x600"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "tv"
Screen 0 "Screen_tv" 0 0
InputDevice "USB Mouse" "CorePointer"
InputDevice "Generic Keyboard" "CoreKeyboard"
EndSection
McCloud is offline   Reply With Quote
Old 08-23-05, 01:30 PM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: TV-Out with 7676 (Geforce 3 Ti500)

Try removing the 1024x768, not all tvout encoders support and second 800x600 (768x576 actually) is the most optimal resolution for PAL without some form of scaling.
Thunderbird is offline   Reply With Quote
Old 08-23-05, 02:20 PM   #3
McCloud
Registered User
 
Join Date: Apr 2005
Posts: 5
Default Re: TV-Out with 7676 (Geforce 3 Ti500)

I removed the "1024x768" line. So it is now 800x600. But still nothing on my tv. However, I noticed this output when I issue the command: "X :1 -layout tv":

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/McCloud:1
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 6.8.2 (Debian 6.8.2.dfsg.1-5 20050810052028 david@squee.verizon.net)
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.12-1-686 i686 [ELF]
Current Operating System: Linux McCloud 2.6.12-versie-2 #1 Fri Aug 19 22:21:32 CEST 2005 i686
Build Date: 10 August 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.12-versie-2 (root@McCloud) (gcc version 4.0.2 20050816 (prerelease) (Debian 4.0.1-5)) #1 Fri Aug 19 22:21:32 CEST 2005 T
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Tue Aug 23 20:15:15 2005
(==) Using config file: "/etc/X11/xorg.conf"
Skipping "/usr/X11R6/lib/modules/libfb.a:fbmmx.o": No symbols found
Warning: font renderer for ".pcf" already registered at priority 0
Warning: font renderer for ".pcf.Z" already registered at priority 0
Warning: font renderer for ".pcf.gz" already registered at priority 0
Warning: font renderer for ".snf" already registered at priority 0
Warning: font renderer for ".snf.Z" already registered at priority 0
Warning: font renderer for ".snf.gz" already registered at priority 0
Warning: font renderer for ".bdf" already registered at priority 0
Warning: font renderer for ".bdf.Z" already registered at priority 0
Warning: font renderer for ".bdf.gz" already registered at priority 0
Warning: font renderer for ".pmf" already registered at priority 0
Could not init font path element /usr/lib/X11/fonts/Speedo, removing from list!


Could it be that that inet6 error is giving me problems??? If so, how can I resolve this (I can compile my own kernels, so having to compile a new one isn't a problem if that is necessary).

Thanks
McCloud is offline   Reply With Quote
Old 08-24-05, 07:29 AM   #4
McCloud
Registered User
 
Join Date: Apr 2005
Posts: 5
Default Re: TV-Out with 7676 (Geforce 3 Ti500)

Well, I messed around with my system some more and discovered the following things.

When I use the 7676 driver and remove the "1024x768" from the screen section of my tv-out, and then start an "X :1 -layout tv", my whole system crashes. I can't get into it using SSH, I can't ping it. Looks like a complete Kernel Panic.

My normal desktop (so my CTR) is 1024x768. So the system has to switch from 1024x768 (CRT) to 800x600 (TV) and then the system crashes.

When I put the "1024x768" back in the screen section, the system doesn't freeze, but my TV is still blank.

When I startup without the CRT connected, the boot process is displayed on my tv, but when X starts I can't see a thing. I don't get any error messages though. This is with an without the 1024x768 option in the screen setting (so the system doesn't freeze with only the 800x600 option when the CRT is not connected, it just doesn't display my x session).

When I use the 7167 drivers, the "1024x768" lockup doesn't occur. However, when I tried to start the tv out, the tv was still blank. I then disconnected the CRT again, the boot-process came up on my tv and ...... I got an X-session on my tv

I then rebooted with the CRT connected and suddenly I could switch to my tv and it showed the X-session (so I started the TV session manually). It looks like it has problems to recognize the tv from cold boot, but when ony the tv is connected on the cold boot, it works like it should.

I don't know what is going on, but there are definately some strange things going on with these drivers. I hope someone at nVidia can fix this.
McCloud is offline   Reply With Quote
Old 08-24-05, 07:34 AM   #5
McCloud
Registered User
 
Join Date: Apr 2005
Posts: 5
Default Re: TV-Out with 7676 (Geforce 3 Ti500)

I forgot to mention my system specs:
AMD Athlon XP1800+
Gigabyte 7-VTXH motherboard
1 GB of DDR RAM
Leadtek Winfast Geforce 3 Ti500 (Brooktree 871 TV Encoder)

Linux: Debian GNU/Linux Unstable (SID)
Drivers: nVidia 7167 and 7676
Kernel: 2.6.12 (compiled myself from the Debian Kernel Source 'linux-source-2.6.12.deb'
Xorg 6.8.2 (from the Debian Unstable repository)

If I need to specify more information, please let me know. I'd love to watch some movies on my TV again, but this just doesn't work.
McCloud is offline   Reply With Quote
Old 08-24-05, 03:01 PM   #6
smallmj
Registered User
 
Join Date: Aug 2005
Posts: 1
Default Re: TV-Out with 7676 (Geforce 3 Ti500)

See what happens if you disable GLX.

I had a similar problem with a MX440. It works fine with VGA out, but X crashes on startup with SVideo out unless I comment out the GLX module. I am also running Debian Sarge.

Mark
smallmj is offline   Reply With Quote
Old 08-25-05, 02:31 PM   #7
mo_x
Registered User
 
Join Date: Jul 2005
Posts: 77
Default Re: TV-Out with 7676 (Geforce 3 Ti500)

I don't see Option "TwinView" In your xorg.conf. Read the README from nvidia.
mo_x is offline   Reply With Quote
Old 08-25-05, 03:05 PM   #8
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: TV-Out with 7676 (Geforce 3 Ti500)

Twinview isn't required for tvout. If you only want tvout this should work. Further there's no twinview support on the geforce3, twinview requries a geforce2mx or else atleast a geforce4ti/mx.
Thunderbird is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
What You Can Expect From GeForce GRID News Archived News Items 0 06-04-12 05:20 PM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 07:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 02:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 10:28 AM

All times are GMT -5. The time now is 01:51 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.