Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-02-05, 10:47 PM   #1
danly
Registered User
 
Join Date: Oct 2004
Posts: 2
Default Segmentation fault on app exit

I'm sure this'll be an easy to answer question as I have a feeling it's due to a faulty install. (I installed over a previous version, then attempted removing everything and reinstalling when this problem started occuring).

I have an FX5600 and on exit every GL application segfaults. I ran xscreensaver-demo through gdb and got this:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1084133568 (LWP 16479)]
0x40493c43 in gdk_screen_get_display () from /usr/lib/libgdk-x11-2.0.so.0

Aside:
My onboard video is incredibly unstable. It seems to lock up at random intervals. I've been reading through this forum and tried just about every recommended fix for various kernel/bios/xf86config combination but to no avail. It's an nforce2 (biostar ideq 200n).

Any thoughts?

Thanks,
-Dan
Attached Files
File Type: zip nvidia-bug-report.zip (18.3 KB, 131 views)
danly is offline   Reply With Quote
Old 08-03-05, 11:28 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Segmentation fault on app exit

Dan,
Can you try adding the following nvidia device option to your X configuration:
Option "NvAGP" "1"

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 08-03-05, 12:07 PM   #3
danly
Registered User
 
Join Date: Oct 2004
Posts: 2
Default Re: Segmentation fault on app exit

Tried that... As AGPGART was already being loaded by the kernel I tried removing it as well, forcing it to use NvAGP. No avail, same problems. This was on kernel 2.6.8.

Thanks,
-Dan
danly is offline   Reply With Quote
Old 08-30-05, 08:06 AM   #4
rods
Registered User
 
Join Date: Aug 2005
Posts: 2
Default Re: Segmentation fault on app exit

Running a 2.6.9 kernel. When using XDMCP or vncviewer, (or tightvnc) KDE apps segfault on exit. The same apps (ie. kdevelop, kpoker, etc) work fine locally.

This does not happen on systems without Nvidia present.

Any thoughts?

Rod Swenson
[IMG]email:rodney.swenson@ccur.com[/IMG]
rods is offline   Reply With Quote
Old 08-30-05, 09:22 AM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Segmentation fault on app exit

rods,
Please post a bug report. When you say that the segfaults do not happen on systems without NVIDIA present, do you mean NVIDIA hardware, or the NVIDIA driver?

On how many systems are you seeing this behavior? Are all of the systems identical in terms of software & hardware?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 08-30-05, 10:36 AM   #6
rods
Registered User
 
Join Date: Aug 2005
Posts: 2
Default Re: Segmentation fault on app exit

Lonni,

When I remove the nvidia package, restoring the original libraries, the segfaults stop.

On a system where there is no nvidia card or driver there are no segfaults.

I will submit a bug report as you requested.

Best Regards,

Rod
rods is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Segmentation Fault on RH 7.3 Lawrence DeLeon NVIDIA Linux 4 09-16-02 11:42 AM

All times are GMT -5. The time now is 07:02 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.