Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-02-05, 09:13 AM   #1
czlowiek
Registered User
 
Join Date: Aug 2005
Posts: 4
Default Failed to initialize the NVIDIA graphics device

I've got some strange problem with nvidia driver 1.0-7174. Sometimes (but not always!) there is an error like this:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xD4000000
(--) NVIDIA(0): MMIO registers at 0xD6000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

I use NVIDA Riva TNT2, Mandriva 2005 LE, kernel 2.6.11-6mdk, Xorg 6.8.2.

Some people on this forum had similar problems, but their nvidia devices didn't work at all. My works pretty well and this problem occurs only sometimes. If I retype startx it works well again.
czlowiek is offline   Reply With Quote
Old 09-02-05, 11:49 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Failed to initialize the NVIDIA graphics device

czlowiek,
Can you please generate and attach an nvidia-bug-report.log for review? Also, what kind of motherboard are you using? How frequently are you experiencing this failure?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-05-05, 06:18 AM   #3
czlowiek
Registered User
 
Join Date: Aug 2005
Posts: 4
Default Re: Failed to initialize the NVIDIA graphics device

This is my bug-report and I get this error in ~50% of starts. My motherboard is via 686. I used to have Mandrake 9.2 and everything worked fine.
Attached Files
File Type: txt nvidia-bug-report.txt (57.2 KB, 228 views)
czlowiek is offline   Reply With Quote
Old 09-06-05, 12:26 AM   #4
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Failed to initialize the NVIDIA graphics device

Your TNT2 card might be too old for the driver version you are using. A manual install of an older driver could be required.
whig is offline   Reply With Quote
Old 09-06-05, 04:07 AM   #5
czlowiek
Registered User
 
Join Date: Aug 2005
Posts: 4
Default Re: Failed to initialize the NVIDIA graphics device

In the readme file there's a table with suported cards:
__________________________________________________ ________________________

(app-a) APPENDIX A: SUPPORTED NVIDIA GRAPHICS CHIPS
__________________________________________________ ________________________

NVIDIA CHIP NAME DEVICE PCI ID

RIVA TNT 0x0020
RIVA TNT2/TNT2 Pro 0x0028
RIVA TNT2 Ultra 0x0029
Vanta/Vanta LT 0x002C
RIVA TNT2 Model 64/Model 64 Pro 0x002D
GeForce 6800 Ultra 0x0040
etc...
I think it is not too old for driver 1.0-7174. Maybe I'm wrong ...
czlowiek is offline   Reply With Quote
Old 09-06-05, 11:45 PM   #6
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Failed to initialize the NVIDIA graphics device

This is the readme on my system:
Code:
Below are the legacy GPUs that are no longer supported in the unified driver.
These GPUs will continue to be maintained through the special legacy NVIDIA
GPU driver releases.


    NVIDIA chip name                   Device PCI ID
    -------------------------------    -------------------------------
    RIVA TNT                           0x0020
    RIVA TNT2/TNT2 Pro                 0x0028
    RIVA TNT2 Ultra                    0x0029
    Vanta/Vanta LT                     0x002C
    RIVA TNT2 Model 64/Model 64 Pro    0x002D
    Aladdin TNT2                       0x00A0
whig is offline   Reply With Quote
Old 09-09-05, 03:04 AM   #7
czlowiek
Registered User
 
Join Date: Aug 2005
Posts: 4
Default Re: Failed to initialize the NVIDIA graphics device

Are you sure, that you use 1.0-7174 driver? It seems that you have at least 1.0-7664. The 1.0-7174 is the last one that supports Riva TNT2. Read carefully beginning of your readme.

Quote:
Originally Posted by whig
This is the readme on my system:
Code:
Below are the legacy GPUs that are no longer supported in the unified driver.
These GPUs will continue to be maintained through the special legacy NVIDIA
GPU driver releases.


    NVIDIA chip name                   Device PCI ID
    -------------------------------    -------------------------------
    RIVA TNT                           0x0020
    RIVA TNT2/TNT2 Pro                 0x0028
    RIVA TNT2 Ultra                    0x0029
    Vanta/Vanta LT                     0x002C
    RIVA TNT2 Model 64/Model 64 Pro    0x002D
    Aladdin TNT2                       0x00A0
czlowiek is offline   Reply With Quote
Old 09-09-05, 10:48 AM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Failed to initialize the NVIDIA graphics device

The 1.0-7174 (legacy) driver supports the Riva TNT2.

czlowiek, the problem that you're reporting sounds more like a hardware or OS level issue. If you add the 'int10' X module to your X configuration, does that have any impact? Also, have you verified that you have the most recent SBIOS for your motherboard?

Thanks,
Lonni
netllama is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM

All times are GMT -5. The time now is 08:46 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.