Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-13-05, 08:35 PM   #1
DirkR
Registered User
 
Join Date: Jun 2003
Posts: 4
Question OpenGL Version/Extensions on 76.76 for QuadroFX 4400???

Hi everybody,

we updated some of our lab machines to 7676, and now the OpenGL version is set to 1.2 and a lot of the extensions are gone, including all the programmability extensions. That's a pretty serious problem (read: we're screwed... ).

Does anybody have an explanation for that, or a way around it? Googleing around it seems this doesn't happen to everybody, I've seen a fx5200 that showed normal behavior. But our QuadroFX 4400s seem to be severely dumbed down by the driver update, which is not what I would have expected.

I attached the glxinfo output, if that explains anything.

Any hint very welcome...

Dirk
Attached Files
File Type: txt mindy.txt (9.3 KB, 125 views)
DirkR is offline   Reply With Quote
Old 09-13-05, 09:34 PM   #2
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: OpenGL Version/Extensions on 76.76 for QuadroFX 4400???

Hi,

hm
>direct rendering: No

did you remove the old driver before updating?

How does the output of ldd /usr/bin/glxgears look?

(if you are using gentoo - did you did an opengl-update nvidia after the update?)
energyman76b is offline   Reply With Quote
Old 09-13-05, 11:33 PM   #3
DirkR
Registered User
 
Join Date: Jun 2003
Posts: 4
Default Re: OpenGL Version/Extensions on 76.76 for QuadroFX 4400???

Good catch, I had missed that one!

I didn't install the driver, so I don't know if the admin uninstalled the old one. Probably not.

ldd gives this:
libGL.so.1 => /usr/X11R6/lib/libGL.so.1 (0x00176000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x00a7f000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x007e7000)
libpthread.so.0 => /lib/tls/libpthread.so.0 (0x00abf000)
libm.so.6 => /lib/tls/libm.so.6 (0x00bcf000)
libc.so.6 => /lib/tls/libc.so.6 (0x00e69000)
libXxf86vm.so.1 => /usr/X11R6/lib/libXxf86vm.so.1 (0x009ef000)
libdl.so.2 => /lib/libdl.so.2 (0x009df000)
/lib/ld-linux.so.2 (0x00b0f000)

which looks ok.

I need to get back to the guy that complained to me about it and get some more info how he ran into the problem. Looking at the "direct rendering: no" it sounds like he has some DISPLAY trouble.

Nonetheless the behavior is somewhat surprising...

Thanks for the hint!
DirkR is offline   Reply With Quote
Old 09-14-05, 12:06 AM   #4
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: OpenGL Version/Extensions on 76.76 for QuadroFX 4400???

Hi,

emm no, your ldd output does not look fine - in fact, it looks like some libs are missing.
Here is mine:
linux-gate.so.1 => (0xffffe000)
libGL.so.1 => /usr/lib/opengl/nvidia/lib/libGL.so.1 (0xb7f32000)
libXext.so.6 => /usr/lib/libXext.so.6 (0xb7f22000)
libX11.so.6 => /usr/lib/libX11.so.6 (0xb7e55000)
libpthread.so.0 => /lib/tls/libpthread.so.0 (0xb7e43000)
libm.so.6 => /lib/tls/libm.so.6 (0xb7e20000)
libc.so.6 => /lib/tls/libc.so.6 (0xb7d09000)
libGLcore.so.1 => /usr/lib/opengl/nvidia/lib/libGLcore.so.1 (0xb75a0000)
libnvidia-tls.so.1 => /usr/lib/opengl/nvidia/lib/libnvidia-tls.so.1 (0xb759d000)
libdl.so.2 => /lib/libdl.so.2 (0xb7599000)
/lib/ld-linux.so.2 (0xb7fd5000)

You see the differences?

It seems the driver did not get installed correctly (or if it is gentoo opengl-update nvidia was forgotten)
energyman76b is offline   Reply With Quote
Old 09-14-05, 08:45 AM   #5
DirkR
Registered User
 
Join Date: Jun 2003
Posts: 4
Thumbs up Re: OpenGL Version/Extensions on 76.76 for QuadroFX 4400???

I can't remember how often I fixed that on my old SuSE installations. I thought Redhat was immune against it...

What do we learn? Don't try to fix problems when it's late and you're tired.

Thanks a bunch

Dirk
DirkR is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:08 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.