Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-05-03, 01:51 PM   #1
Pyroman[FO]
Registered User
 
Join Date: Feb 2003
Posts: 5
Default 0: NVRM: rm_init_adapter failed

I was previously using a successful Xinerama setup with two PCI TNT cards, with a Pentium III and i810 chipset, and the "nv" driver. This is on RH 8.0 with the updated kernel. So I install the Nvidia kernel module using srpm and the i386 GLX driver. It compiles and installs just fine, and the kernel module loads just fine. When I start X, one screen comes up fine, however the second screen fails with this in the XF86 error log

(**) NVIDIA(1): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(1): RGB weight 888
(==) NVIDIA(1): Default visual is TrueColor
(==) NVIDIA(1): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(1): Linear framebuffer at 0xF9000000
(--) NVIDIA(1): MMIO registers at 0xFD000000
(EE) NVIDIA(1): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(1): *** Aborting ***

This also shows up in dmesg

0: NVRM: rm_init_adapter failed

If I switch the second card back to the "nv" driver it works. Ive attached my XFconfig and XF error log. BTW, in the XFconfig file, Card2 is the disabled onboard i810.
Attached Files
File Type: txt xf86config_xfree86.0.log.txt (27.8 KB, 210 views)
Pyroman[FO] is offline   Reply With Quote
Old 02-06-03, 09:40 AM   #2
Pyroman[FO]
Registered User
 
Join Date: Feb 2003
Posts: 5
Default also

Also, removing the module "glx" doesn't work, I tried that. I got it to work on Debian that way before, but it doesn't work this time.
Pyroman[FO] is offline   Reply With Quote
Old 02-06-03, 12:59 PM   #3
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Did you use the TwinView info to do this? AFAIK, TwinView won't work quite right for this kind of thing.

I don't know what will, though...

Are you sure the BusID lines are set correctly?

According to that log file, you're still loading "dri" as well. Are you sure that's right?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-06-03, 01:25 PM   #4
Pyroman[FO]
Registered User
 
Join Date: Feb 2003
Posts: 5
Default Hmm

Im not using TwinView, just good old fasioned Xinerama. Also, I dont see any mention of dri in the current log file, so Ill upload that one. It looks the same from what I can tell, however, except for the dri bit.
Attached Files
File Type: txt xfree86.0.log.txt (21.8 KB, 173 views)
Pyroman[FO] is offline   Reply With Quote
Old 02-06-03, 06:14 PM   #5
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Yeah, it does. Hmm...

Did you see the post by exodist in this thread?

http://www.nvnews.net/vbulletin/show...&threadid=7191

It seems that there are problems with certain TNT2 cards and Xinerama, maybe it's worth a question there?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-07-03, 12:27 AM   #6
Pyroman[FO]
Registered User
 
Join Date: Feb 2003
Posts: 5
Default

Thanks for the thread, that helped some. However, I had this exact same hardware working in Xinerama with the Nvidia accelerated drivers under Debian. So It can't be the hardware.
Pyroman[FO] is offline   Reply With Quote
Old 02-07-03, 07:47 AM   #7
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Oh yeah. Rats.

I'm fresh out of ideas... switching the BusIDs around might work, but probably not.

It almost sounds like one of the kernel module or the X driver doesn't like driving two cards, but I don't know what to do about that to make it work...
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Screen freeze NVRM: Xid error ciancaroll NVIDIA Linux 0 06-05-12 01:05 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
kernel: NV0: isr request failed 0xfffffff0 Shark NVIDIA Linux 13 09-11-02 11:01 AM

All times are GMT -5. The time now is 01:46 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.