Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-08-03, 05:28 PM   #1
demiurg42
Registered User
 
Join Date: Feb 2003
Posts: 1
Default twinview bug ?

I've seen a couple of postings on the subj. but nobody suggesteda working solution so far.

It's interesting that I had twinview working - before upgrading to RH8 and installing latest
nvidia drivers.

The porblem : when I run X with option "Twinview" it freezes. If I run it on a second display (in parallel with my regular X session)
it reezes right away. If I boot into runlevel 3 (without X) and than run X -screen "Screen AGP TwinView" it starts and even seems to work but still freezes after I exit from X!

I thought about downgrading the driver, but it would force me to downgrade gcc since the older driver was compiled with gcc 2...


Any suggestions ?

My configuration :

nVidia Corporation NV11 [GeForce2 MX] (rev b2)
driver 1.0 revision 4191
2.4.20

XFree86-4 :



Section "Device"
Identifier "NV AGP TwinView"
VendorName "nvidia"
Driver "nvidia"
# update this with the PCI id of your card. Consult the output
# of the 'lspci' command.
BusID "PCI:1:0:0"

# sample twinview setup
Option "TwinView"
# be sure to replace the HorizSync and VertRefresh with correct values
# for your monitor!
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
Option "TwinViewOrientation" "Clone"
# Option "MetaModes" "800x600,800x600;"
Option "MetaModes" "800x600,800x600 @800x600;"
# Option "MetaModes" "640x480, 640X480;"
Option "ConnectedMonitor" "crt,tv"
EndSection

Section "Screen"
Identifier "Screen AGP TwinView"
Device "NV AGP TwinView"
Monitor "MyMonitor"
DefaultColorDepth 24
Option "TVStandard" "PAL-B"
# Option "TVStandard" "NTSC-M"
Option "TVOutFormat" "COMPOSITE"
# Subsection "Display"
# Depth 8
# Virtual 800 600
# Modes "800x600" "640x400"
# EndSubsection
# Subsection "Display"
# Depth 16
# Virtual 800 600
# Modes "800x600" "640x480"
# EndSubsection
Subsection "Display"
Depth 24
Virtual 800 600
Modes "800x600" "640x480"
EndSubsection
demiurg42 is offline   Reply With Quote
Old 02-08-03, 07:27 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default Re: twinview bug ?

Quote:
Originally posted by demiurg42
I thought about downgrading the driver, but it would force me to downgrade gcc since the older driver was compiled with gcc 2...
Wrongo. In fact, 3123 is the only release that will work for me with gcc 3.2. If I try any other version, libGLcore.so can't find __divdi3 (a compiler-internal function that should be statically linked into it).

Code:
[bilbo@beta fceu]$ gcc -dumpversion
3.2
[bilbo@beta fceu]$ cat /proc/driver/nvidia/version 
NVRM version: NVIDIA Linux x86 NVdriver Kernel Module  1.0-3123  Tue Aug 27 15:56:48 PDT 2002
GCC version:  gcc version 3.2
[bilbo@beta fceu]$
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse Linux 8.0 - Geforce 4 TwinView TA00 NVIDIA Linux 8 08-30-02 04:24 AM
Twinview with TV-out karlaugust NVIDIA Linux 10 08-28-02 05:20 PM
Antialiasing bug in 31.00 drivers? Mark_fox NVIDIA Windows Graphics Drivers 7 08-26-02 03:48 PM
TwinView & Console bug topman NVIDIA Linux 3 08-16-02 10:32 AM
How do I configure TwinView on Dell Inspiron rutgerclaes NVIDIA Linux 6 08-01-02 04:20 AM

All times are GMT -5. The time now is 04:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.