Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-10-03, 12:09 AM   #1
Tricron
Registered User
 
Join Date: Feb 2003
Posts: 2
Default problem: hardware only working for glxgears and glxinfo - nothing else.

I've got the strangest problem: My graphics card (Riva TNT2 pci - 32mb) works for glxgears and glxinfo however games still use software rendering and so do all the mesa demos. This has happened since I installed the lastest drivers, and it still is happening to me even though I've removed those and gone to an older version.

At this point I have no idea at all where the problem could be (although I learned a lot trying to solve it...)

I'm not going to include any log data (since there were no errors in them) unless someone requests something - really all I'd like is a clue, has anyone heard of something like this before and can direct me to a suspect file? This linux box is quite literally my play thing and I'm more than willing to attempt hazardous solutions.
Tricron is offline   Reply With Quote
Old 02-10-03, 09:10 AM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

What does tuxracer do? Is it extremely slow?

If so, you probably have old OpenGL libraries floating around. Do an ldd $(which tuxracer) to find out which libGL it's linking against, and post what you get.

The Mesa demos may very well explicitly link against the MesaGL library, I don't know.

Which games are using software rendering? You may be able to run ldd on their executable too, and possibly find something.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-10-03, 11:53 PM   #3
Tricron
Registered User
 
Join Date: Feb 2003
Posts: 2
Default

Very weird, the problem seems to have completely fixed itself. I have no idea how. The game I was testing it with was gltron (very cool) and somehow thats become fixed... it might have something to do with loading tuxracer first however I doubt it ... Lets just hope it stays fixed.

As for the mesa demos, there still slow and don't really want to use anything but mesa drivers so there probably explicitly linked as you said.

Well thanks for the help anyway =)
Tricron is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:03 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.