Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-06-05, 06:37 AM   #1
uxxx
Registered User
 
uxxx's Avatar
 
Join Date: Nov 2004
Posts: 19
Angry Composite extension crashes

Still the same...Activating the composite extension make the x.org crashes!!!
I've been waiting so long for the fixing of this bug...
At this point I think about switching to the nv driver and using exa (when it will be ready).
__________________
[font=Arial][size=7][color=RoyalBlue]Get tomorrow's tech today...GET LINUX!!!
uxxx is offline   Reply With Quote
Old 12-06-05, 01:12 PM   #2
kmare
Registered User
 
Join Date: Jul 2003
Location: greece
Posts: 180
Send a message via ICQ to kmare
Default Re: Composite extension crashes

which version of xorg are you using? maybe upgrading to 6.9/7.0 might help.. i'm waiting for the release in two weeks..
kmare is offline   Reply With Quote
Old 12-06-05, 01:30 PM   #3
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Composite extension crashes

I found a bug in X recently that can lead to random crashes when Composite is enabled and windows are redirected (e.g. if you're running xcompmgr or have GTK 1.x windows open). The bug isn't going to get fixed in X, but a workaround for it will go into a future NVIDIA driver release. I still need to do more testing, but I'm hoping this workaround will solve most of the "Composite randomly crashes" issues people have been reporting.
AaronP is offline   Reply With Quote
Old 12-06-05, 02:07 PM   #4
kmare
Registered User
 
Join Date: Jul 2003
Location: greece
Posts: 180
Send a message via ICQ to kmare
Default Re: Composite extension crashes

could you please point out where is the problem in X? of course a patch for X would be even better it'd be applied on gentoo for sure and help testing it.. in any way thanx for the great driver as it looks like it's working like a charm!
kmare is offline   Reply With Quote
Old 12-06-05, 02:12 PM   #5
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Composite extension crashes

kmare,

https://bugs.freedesktop.org/show_bug.cgi?id=5120
AaronP is offline   Reply With Quote
Old 12-06-05, 06:17 PM   #6
d4rk74m4
Registered User
 
Join Date: Aug 2004
Posts: 72
Default Re: Composite extension crashes

Hmm, that's interesting. Is this in any way related to the crashes I gave stack traces for in the " nvidia drivers 1-8xxx" thread? Also, since installing 1.0-8174 the crashes no longer occur every time I run a GL app. I'm not sure if this is related to 1.0-8174, or some other update I did recently.

BTW, instead of supplying on a workaround in Nvidia's driver, why not supply a patch on fd.o #5120 and fix the problem at the source?
d4rk74m4 is offline   Reply With Quote
Old 12-06-05, 06:33 PM   #7
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Composite extension crashes

Quote:
Originally Posted by d4rk74m4
BTW, instead of supplying on a workaround in Nvidia's driver, why not supply a patch on fd.o #5120 and fix the problem at the source?
I went over this with the X maintainers and we decided that the workaround in the driver is better than trying to fix X.

As for stack traces, if X crashes in the driver while handling a drawing request (such as ProcPolySegment or ProcCopyArea), then there's a good chance a missing GC validation is responsible. While I haven't seen this happen when starting OpenGL applications, it's certainly possible.
AaronP is offline   Reply With Quote
Old 12-07-05, 06:59 AM   #8
uxxx
Registered User
 
uxxx's Avatar
 
Join Date: Nov 2004
Posts: 19
Default Re: Composite extension crashes

If I enable the composite ext I get a x.org seg fault,and the x nerver starts!!!
__________________
[font=Arial][size=7][color=RoyalBlue]Get tomorrow's tech today...GET LINUX!!!
uxxx is offline   Reply With Quote

Old 12-07-05, 08:57 AM   #9
d4rk74m4
Registered User
 
Join Date: Aug 2004
Posts: 72
Default Re: Composite extension crashes

Quote:
Originally Posted by uxxx
If I enable the composite ext I get a x.org seg fault,and the x nerver starts!!!
Interesting. Have you enabled AllowGLXWithComposite? I had issues with <1.0-8xxx where X would crash and burn on startup if GLX wasn't initialised.

Though, I'm fairly sure this doesn't occur with 8xxx as when I first started it GLX didn't work (my fault, forgot to modprobe -r the old module then modprobe the new one).
d4rk74m4 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 02:44 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 07:45 AM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 09:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM
RH7.3 and nForce - can't find the module dmw400 NVIDIA Linux 4 08-05-02 01:14 PM

All times are GMT -5. The time now is 04:57 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.