Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-08-05, 06:17 PM   #1
neuschnee
Registered User
 
Join Date: Dec 2005
Posts: 8
Default 8174 + xorg + renderaccel + antialiasing = crashes

Xorg 6.8.2 will crash with 8174 drivers when RenderAccel and anti-aliasing is on:

Code:
chango:~$ cat .gconf/desktop/gnome/font_rendering/%gconf.xml 
<?xml version="1.0"?>
<gconf>
        <entry name="rgba_order" mtime="1126942146" type="string">
                <stringvalue>rgb</stringvalue>
        </entry>
        <entry name="dpi" mtime="1128598162" type="float" value="96">
        </entry>
        <entry name="hinting" mtime="1134082937" type="string">
                <stringvalue>full</stringvalue>
        </entry>
        <entry name="antialiasing" mtime="1134082937" type="string">
                <stringvalue>grayscale</stringvalue>
        </entry>
</gconf>
It is reproduceable by loading a specific page in Firefox (which I can't link to because it's a private site), and has happened elsewhere for me too but since I didn't know what was causing it at a the time, I can't remember how to reproduce it in other ways.

It will not crash with anti-aliasing on and renderaccel off, nor will it crash with anti-aliasing off and renderaccel on... so I think this is pretty obviously related to how RenderAccel accerates font rendering when anti-aliased/autohinted.

This bug also occurs in 7176, and with multiple kernels (2.6.13~2.6.15-rcX vanilla, -ck, -mm, etc).

To make the attached log I had to edit my /etc/acpi/powerbtn.sh and add nvidia-bug-report.sh to it, because when it crashes my console is dead and keyboard input is ignored (whether or not I'm using fbconsole).
Attached Files
File Type: zip nvidia-bug-report.log.txt.zip (21.7 KB, 155 views)
neuschnee is offline   Reply With Quote
Old 12-08-05, 06:54 PM   #2
snader
Registered User
 
Join Date: Dec 2005
Posts: 4
Default Re: 8174 + xorg + renderaccel + antialiasing = crashes

Your /proc/driver/nvidia/agp/status says Disabled. I'm not sure what this means, I only know I had this as well until I installed the agpgart driver for my Athlon64 (amd64_agp). Now it says Enabled and I haven't had any crashes since. I'm not running a 64-bit system by the way.
snader is offline   Reply With Quote
Old 12-08-05, 07:00 PM   #3
neuschnee
Registered User
 
Join Date: Dec 2005
Posts: 8
Default Re: 8174 + xorg + renderaccel + antialiasing = crashes

Quote:
Originally Posted by snader
Your /proc/driver/nvidia/agp/status says Disabled. I'm not sure what this means, I only know I had this as well until I installed the agpgart driver for my Athlon64 (amd64_agp). Now it says Enabled and I haven't had any crashes since. I'm not running a 64-bit system by the way.
Yes, this is because I ran nvidia-bug-report.sh when Xorg was not running (since it crashed). I use NVIDIA's internal AGP driver (Option "NvAGP" "1").

When X is running:

Code:
cat /proc/driver/nvidia/agp/status
Status:          Enabled
Driver:          NVIDIA
AGP Rate:        8x
Fast Writes:     Disabled
SBA:
I will build a kernel with AGPGART and try it instead of NVIDIA's driver... though I doubt it will change anything.

Update: I built a kernel with AGPGART and changed NvAGP to 3. Still crashing.
neuschnee is offline   Reply With Quote
Old 12-09-05, 12:23 AM   #4
savagerunner
Registered User
 
Join Date: Aug 2004
Posts: 2
Default Re: 8174 + xorg + renderaccel + antialiasing = crashes

I'm having font problems too, but a more special case. No crashes, but if I have RenderAccel enabled on 8174 and xorg 6.8.2, then I get font corruption in Firefox 1.5 and Gaim.

At first I thought it was limited to GTK apps, but Thunderbird and the Gimp seem to be fine.

I've attached a screenshot of the corruption. If I highlight the corrupted text, it'll "pop back" and render properly, only to go back to craziness a few moments later.

I'll just disable RenderAccel for now, but any ideas?
Attached Thumbnails
Click image for larger version

Name:	snapshot.png
Views:	180
Size:	85.5 KB
ID:	14905  
savagerunner is offline   Reply With Quote
Old 12-09-05, 01:50 AM   #5
pzgren
Registered User
 
pzgren's Avatar
 
Join Date: Jan 2004
Posts: 107
Default Re: 8174 + xorg + renderaccel + antialiasing = crashes

Hi,

and if you deactivate RenderAccel it is stable,right?

Marcus
__________________
Fedora Core 6
Notebook: DELL Inspiron 9400 - Core Duo T2400 - 17" WUXGA 7800 Go 256MB - 2 GB DDR2 667 MHz -
PC: AMD64 3200 - 1 GB Infi. PC400 - MSI K8N Neo Platinum NForce3 250GB - 80GB SATA Samsung - SB Live! 5.1 - GF 6600GT AGP
pzgren is offline   Reply With Quote
Old 12-09-05, 07:55 AM   #6
savagerunner
Registered User
 
Join Date: Aug 2004
Posts: 2
Default Re: 8174 + xorg + renderaccel + antialiasing = crashes

Quote:
Originally Posted by pzgren
Hi,

and if you deactivate RenderAccel it is stable,right?

Marcus
Yep, that's right. KDE/Qt apps don't seem to be affected -- only GTK apps, and only certain ones at that. Disabling antialiasing or hinting in the gnome-font-properties dialog doesn't make a difference.
savagerunner is offline   Reply With Quote
Old 12-11-05, 02:41 PM   #7
neuschnee
Registered User
 
Join Date: Dec 2005
Posts: 8
Default Re: 8174 + xorg + renderaccel + antialiasing = crashes

Does NVIDIA have anything to say about this problem? Is it known? Are you working on it?
neuschnee is offline   Reply With Quote
Old 12-11-05, 03:10 PM   #8
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 8174 + xorg + renderaccel + antialiasing = crashes

As stated in the README, the RenderAccel option enables an experimental feature and is not currently supported. We're actively working on several RENDER and COMPOSITE related problems, though.
zander is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 02:24 AM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 10:11 AM

All times are GMT -5. The time now is 03:21 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.