Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-27-05, 05:09 AM   #1
mrmailer
Registered User
 
Join Date: Dec 2005
Posts: 37
Default problems with xvmc w/7676 and above on twinview

fc4 machine, geforce 6200.

7676 and above on twinview has xvmc issues. athlon xp 2ghz.
here is mplayer trying to play

mplayer -vo xvmc -vc ffmpeg12mc CodeBreakers.mpg
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale

MPlayer 1.0pre7-4.0.2 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0

Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
Playing CodeBreakers.mpg.
MPEG-PS file format detected.
VIDEO: MPEG2 720x480 (aspect 2) 29.970 fps 0.0 kbps ( 0.0 kbyte/s)
================================================== ========================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
================================================== ========================
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
vo_xvmc: X-Video extension 2.2
vo_xvmc: X-Video MotionCompensation Extension version 1.0
================================================== ========================
Forced video codec: ffmpeg12mc
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
vd_ffmpeg: XVMC accelerated codec
Selected video codec: [ffmpeg12mc] vfm:ffmpeg (FFmpeg MPEG-1/2 (XvMC))
================================================== ========================
Checking audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
AF_pre: 48000Hz/2ch/s16le
AO: [oss] 48000Hz 2ch s16le (2 bps)
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
Starting playback...
vd_ffmpeg: XVMC accelerated MPEG2
trying pixfmt=0
VDec: vo config request - 720 x 480 (preferred csp: MPEG1/2 Motion Compensation and IDCT)
VDec: using MPEG1/2 Motion Compensation and IDCT as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xvmc] 720x480 => 720x540 MPEG1/2 Motion Compensation and IDCT
vo_xvmc: Port 270 grabed
vo_xvmc: Found matching surface with id=54434449 on 270 port at 0 adapter
X11 error: BadRequest (invalid request code or no such operation)


MPlayer interrupted by signal 6 in module: decode_video
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.
mrmailer is offline   Reply With Quote
Old 12-27-05, 08:26 AM   #2
mrmailer
Registered User
 
Join Date: Dec 2005
Posts: 37
Default Re: problems with xvmc w/7676 and above on twinview

ok, updated to cvs mplayer, and a window opens to start playing the mpg, you hear a bit of sound, then nothing...


Starting playback...
vd_ffmpeg: XVMC accelerated MPEG2
trying pixfmt=0
VDec: vo config request - 720 x 480 (preferred colorspace: MPEG1/2 Motion Compensation and IDCT)
VDec: using MPEG1/2 Motion Compensation and IDCT as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xvmc] 720x480 => 720x540 MPEG1/2 Motion Compensation and IDCT
vo_xvmc: Port 270 grabed
vo_xvmc: Found matching surface with id=54434449 on 270 port at 0 adapter
vo_xvmc: Allocated Direct Context
vo_xvmc: data_blocks allocated
vo_xvmc: mv_blocks allocated
vo_xvmc: Motion Compensation context allocated - 8 surfaces
vo_xvmc: idct=1 unsigned_intra=0
vo_xvmc: looking for OSD support
Subpicture id 0x34344149
vo_xvmc: OSD support by additional frontend rendering
A: 0.7 V: 0.0 A-V: 0.700 ct: 0.000 1/ 1 ??% ??% ??,?% 0 0




help?
mrmailer is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:57 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.