Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-28-05, 07:44 PM   #1
lavacano
Registered User
 
Join Date: Dec 2005
Posts: 10
Default nvidia settings

http://bugs.gentoo.org/show_bug.cgi?id=114649

i686-pc-linux-gnu-gcc -c -O2 -march=pentium4 -fforce-addr -fomit-frame-pointer
-pipe -O -I /usr/X11R6/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include
-I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I doc -I src -I
src/image_data -I src/xpm_data -I src/gtk+-2.x -I src/libXNVCtrl -I
src/libXNVCtrlAttributes src/libXNVCtrlAttributes/NvCtrlAttributesGlx.c -o
.objs/NvCtrlAttributesGlx.o
make: *** No rule to make target `src/libXNVCtrl/libXNVCtrl.a', needed by
`nvidia-settings'. Stop.

seems nvidia settings has a problem with xorg 7 imake. See:
Quote:
I'm running x86 with modular Xorg and xorg-cf-files-0.99.3 and noticed
that /usr/lib/X11/config/host.def is empty. After copying a host.def file from
a Xorg 6.8.2-r6 installation, xmkmf -a generated a working Makefile that would
allow libXNVCtrl.a to be built. I haven't looked at why an empty host.def is
being made though or why it would be causing a broken Makefile.
any help is appreciated. thanks.
lavacano is offline   Reply With Quote
Old 12-28-05, 08:41 PM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: nvidia settings

Do you have this problem with the official .tar.gz package (ftp://download.nvidia.com/XFree86/nv...ngs-1.0.tar.gz) or Gentoo's ebuild? The file src/libXNVCtrl/libXNVCtrl.a is shipped with the `nvidia-settings` source package.
zander is offline   Reply With Quote
Old 12-28-05, 11:16 PM   #3
lavacano
Registered User
 
Join Date: Dec 2005
Posts: 10
Default Re: nvidia settings

weird I know I did at one point but it failed with the same message, but after compiling the official tarball it works. thanks!
lavacano is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Found Simpsons in NVIDIA registry settings! ShVen NVIDIA GeForce 7, 8, And 9 Series 6 10-06-02 09:26 PM
rh7.3 and nvidia vcrispo NVIDIA Linux 11 07-31-02 08:57 PM

All times are GMT -5. The time now is 09:52 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.