Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-05-06, 07:54 AM   #1
lagitus
Registered User
 
Join Date: Jan 2006
Posts: 2
Default 8178 doesn't obey xorg.conf refresh settings

I have a Viewsonic VP171s TFT that can do 1280x1024@75Hz. For some reason it always shows small shimmering red dots when used in 75Hz mode so I've put the following line into my Section "Monitor" in xorg.conf:
VertRefresh 42-70

After updating the driver from the 7xxx series to 8178 the monitor is always set to 75Hz instead of 60Hz when X is started. Rather oddly, starting nvidia-settings immediately switches the monitor back to 60Hz.
lagitus is offline   Reply With Quote
Old 01-05-06, 08:14 AM   #2
debian_penguin
Linux Addicted
 
debian_penguin's Avatar
 
Join Date: Aug 2005
Posts: 61
Default Re: 8178 doesn't obey xorg.conf refresh settings

Hi lagitus.

You can try using the nvidia-settings --load-config-only command in any shell while in X to see wether it sets the vrefresh rate correctly without starting the actual nvidia-settings applet. If this works, you can then add this command to your X startup scripts.

Hope this helps

Best,

d_p
__________________
Laptop HP Pavilion zv5000: AMD Athlon 3000+ (32 bit); Nvidia GeForce4 440 Go! 64 Mb, 8774 driver revision; 768 MB PCI2700; nForce3 mobo chipset and audiocard, other uninteresting stuff... Debian unstable-experimental, custom 2.6.17 kernel debian-patched
Any sufficiently advanced bug is indistinguishable from a feature.
debian_penguin is offline   Reply With Quote
Old 01-05-06, 08:21 AM   #3
debian_penguin
Linux Addicted
 
debian_penguin's Avatar
 
Join Date: Aug 2005
Posts: 61
Default Re: 8178 doesn't obey xorg.conf refresh settings

The fact that your Xorg.conf is ignored could be related to the Xserver reading the vrefresh frequency from your monitor's EDIDs ones. Try adding the line:

Option "UseEdidFreqs" "false"

in your device section in Xorg.conf. This could help, and would be a solution, rather than a workaround.

Best,

d_p
__________________
Laptop HP Pavilion zv5000: AMD Athlon 3000+ (32 bit); Nvidia GeForce4 440 Go! 64 Mb, 8774 driver revision; 768 MB PCI2700; nForce3 mobo chipset and audiocard, other uninteresting stuff... Debian unstable-experimental, custom 2.6.17 kernel debian-patched
Any sufficiently advanced bug is indistinguishable from a feature.
debian_penguin is offline   Reply With Quote
Old 01-05-06, 09:24 AM   #4
lagitus
Registered User
 
Join Date: Jan 2006
Posts: 2
Default Re: 8178 doesn't obey xorg.conf refresh settings

Thank you! That did it. I had to set HorizSync explicitly as well now but it worked.

I wonder why they changed it to behave like this though. What was wrong with the old behavior, which I assume was to use EDID values when nothing was explicitly specified?
lagitus is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:40 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.