Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-20-05, 12:35 AM   #13
rbirdman
Registered User
 
Join Date: Sep 2004
Posts: 44
Default Re: DPMS+Go5200 monitor suspend,standby,off not working properly

Quote:
Originally Posted by cyberjun
Hi rbirdman,
Are you using agpgart? I have agpgart compiled as a loadable module and it gets loaded irrespective of the value I pass to NvAGP in xorg.conf. Can you please let us know what are your settings. Please give the output of the following commands:

1. lsmod
2. cat /proc/driver/nvidia/registry
3. cat /proc/driver/nvidia/agp/status
4 cat /proc/driver/nvidia/cards/0

What about others who are facing this problem ? are all of you also using AGP ?
Am just trying to find out the difference between rbirdman's setup and mine.

cheers,
--cyberjun
Here you go. I think I have everything you asked for.

I have agp disabled normally as it causes suspend to fail on resume. Before posting though I enable it in xorg.conf to see what happens. The display still switchs on and off. NVidia's agp doesn't seem to want to load. Might have to have a look at that now I no.
Attached Files
File Type: txt post.txt (2.7 KB, 159 views)
rbirdman is offline   Reply With Quote
Old 12-02-05, 09:01 PM   #14
cyberjun
Registered User
 
Join Date: Mar 2005
Posts: 30
Default Re: DPMS+Go5200 monitor suspend,standby,off not working properly

Hi,
My experience with the vbetool utility is described in post #16:
http://www.linuxquestions.org/questi...65#post1980865

I am now pretty sure that the dpms support is broken in the current nvidia driver. But can't say if it will get fixed in the next release as nobody from Nvidia has confirmed it as a bug yet.

cheers,
--cyberjun
cyberjun is offline   Reply With Quote
Old 12-03-05, 12:18 PM   #15
joaorf
Registered User
 
Join Date: Aug 2003
Location: Portugal
Posts: 12
Send a message via ICQ to joaorf
Question Re: DPMS+Go5200 monitor suspend,standby,off not working properly

Quote:
Originally Posted by cyberjun
I am now pretty sure that the dpms support is broken in the current nvidia driver. But can't say if it will get fixed in the next release as nobody from Nvidia has confirmed it as a bug yet.
Have you reported the bug to NVidia?
joaorf is offline   Reply With Quote
Old 12-06-05, 07:25 AM   #16
cyberjun
Registered User
 
Join Date: Mar 2005
Posts: 30
Default Re: DPMS+Go5200 monitor suspend,standby,off not working properly

Hi,
The latest 8174 driver solves this issue.

cheers,
--cyberjun
cyberjun is offline   Reply With Quote
Old 01-09-06, 05:13 PM   #17
joaorf
Registered User
 
Join Date: Aug 2003
Location: Portugal
Posts: 12
Send a message via ICQ to joaorf
Unhappy Re: DPMS+Go5200 monitor suspend,standby,off not working properly

I was able to confirm that version 8174 solves this issue.
But versions 8174 and 8178 brought new and previously unseen issues on my Toshiba laptop and GeForce 420 Go. When Xorg starts, the whole system freezes (not even a SSH login is possible). I was able to overcome this problem by passing the following parameters to the nvidia module:
NVreg_SoftEDIDs=0 NVreg_Mobile=2
But an annoying side effect appeared: when logging out of X, the console became totally garbled.

With 8178 all got worse. Not even the above parameters prevented a total freeze when X starts... I eventually decided to downgrade to 7676, the last version that behaved in a civilized way on my Toshiba.

What I wanted to know if any of the issues I described affects any other Toshiba users.
joaorf is offline   Reply With Quote
Old 01-09-06, 05:31 PM   #18
bigsur2k4
Registered User
 
Join Date: Nov 2005
Posts: 5
Default Re: DPMS+Go5200 monitor suspend,standby,off not working properly

Hi joaorf,
Quote:
Originally Posted by joaorf
What I wanted to know if any of the issues I described affects any other Toshiba users.
I've an Toshiba M30 running on Debian Etch, Kernel 2.6.15 and NVIDIA 8174 with this patch applied to the Nvidia driver.

Below you can find my xorg.conf and the script I'm using for supsend and resume.

I've also added this line to /etc/modutils/aliases:
options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=1

Everything seems to be ok, excpt the destroyed console after resume... don't no how to fix that

kind regards
bigsur
Attached Files
File Type: txt xorg.conf.txt (5.9 KB, 179 views)
File Type: txt lm_lid.sh.txt (208 Bytes, 148 views)
bigsur2k4 is offline   Reply With Quote
Old 01-10-06, 05:04 AM   #19
joaorf
Registered User
 
Join Date: Aug 2003
Location: Portugal
Posts: 12
Send a message via ICQ to joaorf
Default Re: DPMS+Go5200 monitor suspend,standby,off not working properly

Thanks for replying.

Quote:
Originally Posted by bigsur2k4
I've also added this line to /etc/modutils/aliases:
options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=1
The NVreg_Mobile=1 parameter is for Dell laptops, not for Toshiba. Here's the table in NVidia's README:
Code:
    Value                              Meaning
    -------------------------------    -------------------------------
    0xFFFFFFFF                         let the kernel module auto
                                       detect the correct value
    1                                  Dell laptops
    2                                  non-Compal Toshiba laptops
    3                                  all other laptops
    4                                  Compal Toshiba laptops
    5                                  Gateway laptops
Could you try with NVreg_Mobile=2?
But I have never need NVreg_Mobile in past versions of the NVidia driver. I see no reason why it is needed now...
Also, have you tried 8178?
joaorf is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
302.17 nvidiaXineramaInfoOverride not working properly hlandgar NVIDIA Linux 11 01-21-13 08:53 AM
Tony Hawk devs working on Call of Duty News Gaming Headlines 0 06-15-12 10:30 AM
Nvidia 3123 not working on Mandrake 8.2 UP with Geforce 440 MMX tariqf NVIDIA Linux 1 09-17-02 08:22 AM
TV-out not working nomatter what driver.. Dr_Gigolo NVIDIA Windows Graphics Drivers 11 09-11-02 11:11 AM
DPMS on XFree4.2.0 and NVDriver 1.0-2960 ghost_o NVIDIA Linux 15 08-01-02 10:03 AM

All times are GMT -5. The time now is 08:12 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.