Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-27-03, 12:42 PM   #1
ale
Registered User
 
Join Date: Jan 2003
Location: spain
Posts: 14
Angry scrollbars and drag'n'drop problem with nvidia

I'm experimenting strange behaviours with nvidia driver 1.0-3123.
it happens randomly and i can't reproduce it:

the screen flicks for a short while, then everything still run as usual except that I can't use drag'n'drop and scrollbars anymore.Neither I can't select text with mouse, dragging the pointer over it.
Scrollbars only works pointing at the arrows but if i push without releasing the mouse button it doesn't work.
I can't figure out why it is. GL applications like gears works with no problem.
The only way I can fix the problem is rebooting, restarting X server doesn't help.
The problem does not show with th xfree nv driver.
My system:
processor AMD-K7
chipset KT133
kernel 2.4.19
xfree 4.2.1

I've added the option mem="nopentium" to my lilo.conf

Does anyone experimenting the same?
ale is offline   Reply With Quote
Old 01-27-03, 12:56 PM   #2
kappax
Registered User
 
Join Date: Oct 2002
Posts: 56
Default

Umm, I could be wrong, but this does not sound like a Nvidia driver problem, try updating X.
kappax is offline   Reply With Quote
Old 02-27-03, 01:27 PM   #3
ale
Registered User
 
Join Date: Jan 2003
Location: spain
Posts: 14
Unhappy

Hi kappax,

sorry for replying so late but i've been away from home..
I didn't update Xfree, anyway I don't think it is an xfree related problem. The problem keeps showing and i think it is related with apm.
The screen goes black and if i move the mouse or press some key I get it back but with the problems I've written in my previous message. It seems like it blanks the screen like the screen saver does. I've no idea on how to solce the problem because I can't reproduce it and I get nothing in the logs. It happens mostly when I use mozilla.
Any idea?
Ale.
ale is offline   Reply With Quote
Old 02-27-03, 01:28 PM   #4
ale
Registered User
 
Join Date: Jan 2003
Location: spain
Posts: 14
Default

I forget to specify my graphic card. It's a
TNT2 M64
ale is offline   Reply With Quote
Old 02-27-03, 02:35 PM   #5
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

You can always try passing apm=off to your kernel at boot, like you're already passing mem=nopentium.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-27-03, 07:06 PM   #6
ale
Registered User
 
Join Date: Jan 2003
Location: spain
Posts: 14
Default

I've put the option apm=off in my lilo.conf but the problem hasn't disappeared. It's like the screen saver turns on when he likes...
I'll try to disable the screen saver feature, I'm using KDE 3.0.3.
Any idea on what this problem is ?
Ale.
ale is offline   Reply With Quote
Old 02-27-03, 07:50 PM   #7
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Did you run lilo after changing lilo.conf? Put another way, does /proc/cmdline have the apm=off line in it?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-27-03, 09:36 PM   #8
ale
Registered User
 
Join Date: Jan 2003
Location: spain
Posts: 14
Default

Yes, i have apm=off if i issue cat /proc/cmdline. As i said it happens mostly when i browse the internet with mozilla and no glx application seems to be affected: I've runned mesa 'reflect' before and after the problem occours and I always get 241fps in 5 secs with the window maximized. Is there any way as I can get something in my logs files? I would like to reproduce the problem but I can't do it in any way. I tried to scroll up and down for about one minute in a mozilla window but nothing happens ... anyway the screen always blanked when I was doing something with the mouse or the keyboard, exactly when the screensaver shouldn't turn on. With the nv xfree driver I don't have this problem so it's almost certanly a nvidia driver issue.
Thanks for the help.
Ale.
ale is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:28 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.