Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-06-06, 09:18 AM   #1
and_jel
Registered User
 
Join Date: Jul 2005
Posts: 4
Default Glx crashes x just after nvidia logo, works fine withouth glx enabled

I installed the x86_64-1.0-8178 driver on a debian sid system using the nvidia installer. Unfortunately, X only starts properly with glx disabled. Everything else works at it should, 2d acceleration works fine.
I attached the Xorg logfile. I would greatly appreciate any kind of help and suggestions.
Btw the system is pentium D with 64 bit debian sid and a 6600 nvidia card. A build in video card is also present on the motherboard (intel).
Attached Files
File Type: txt Xorg.0.log.txt (33.3 KB, 128 views)
and_jel is offline   Reply With Quote
Old 02-06-06, 10:38 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Glx crashes x just after nvidia logo, works fine withouth glx enabled

Please generate and provide a full bug report.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-06-06, 01:12 PM   #3
kcary
Registered User
 
Join Date: Feb 2006
Posts: 30
Default Re: Glx crashes x just after nvidia logo, works fine withouth glx enabled

I am having this exact same problem. I am using a 6800 GT PCI-Express card and my full log file is as follows:

XFree86.0.log

When I run it without glx enabled everything seems to work fine. The only thing I really noticed in the log was one place it says "nVidia Corporation unknown chipset ..."
Let me know if you need any other information.
kcary is offline   Reply With Quote
Old 02-06-06, 05:22 PM   #4
and_jel
Registered User
 
Join Date: Jul 2005
Posts: 4
Default Re: Glx crashes x just after nvidia logo, works fine withouth glx enabled

I'm not exactly sure what constitutes a full bug report. Do i send one to somewhere else than this forum?
I attached more information about my systems configuration, both software and hardware. If you need any more just ask. I can easily recreate the problem just by uncommenting
#Load "glx"
so if you need some extra information about the crash it wont be a problem, i just don't know anything about debugging this kind of thing.

dpk list.txt.zip is a list of all the packages installed on my pc and their version.
lspci vv.txt is the output from running lspci -vv.
config.txt is my kernel configuration.

Thank you for your interest
Attached Files
File Type: txt config.txt (40.1 KB, 114 views)
File Type: txt lspci vv.txt (11.5 KB, 121 views)
File Type: txt nvidia-installer.log.txt (32.9 KB, 112 views)
File Type: txt xorg.conf.txt (4.0 KB, 122 views)
File Type: zip dpkg list.txt.zip (26.2 KB, 113 views)
and_jel is offline   Reply With Quote
Old 02-06-06, 05:48 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Glx crashes x just after nvidia logo, works fine withouth glx enabled

nvidia-bug-report.log is a full bug report. Please see the README if you're not sure how to generate one.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-07-06, 07:54 AM   #6
and_jel
Registered User
 
Join Date: Jul 2005
Posts: 4
Default Re: Glx crashes x just after nvidia logo, works fine withouth glx enabled

Alright, so here are to full bug reports as generated by nvidia-bug-report.sh.
nv-report.noglx.txt was generated with the xserver running.
nv-report.glx.txt was generated just after causing the xserver to missfire by enabling glx in xorg.conf.

Thank you for your help.
Attached Files
File Type: zip nv-report.glx.txt.ZIP (26.2 KB, 118 views)
File Type: zip nv-report.noglx.txt.ZIP (26.4 KB, 101 views)
and_jel is offline   Reply With Quote
Old 02-07-06, 12:35 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Glx crashes x just after nvidia logo, works fine withouth glx enabled

To confirm, you are seeing this issue immediately after installing the driver?

If so, can you try using the --force-tls installation option, first with 'classic', and if the problem persists, install again with 'new'.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-07-06, 03:21 PM   #8
and_jel
Registered User
 
Join Date: Jul 2005
Posts: 4
Default Re: Glx crashes x just after nvidia logo, works fine withouth glx enabled

Yes immediately after.
I tried reinstalling the driver with the options you suggested, but the problem persisted.

Best regards
Anders
and_jel is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Nvidia agp8x works fine while Ati not!!! Fotis Other Desktop Graphics Cards 43 11-01-02 10:54 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM

All times are GMT -5. The time now is 11:43 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.