Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-07-06, 11:22 AM   #1
seanm
Registered User
 
Join Date: Feb 2006
Posts: 2
Exclamation Slow Polygon Rendering on AMD64 (1.0-8178)

Hi All,

I am experiencing surprisingly slow frame rates when rendering large numbers of polygons (250K - 2M) on an AMD64 system using the 1.0-8178 driver. Volume rendering (3D texture mapping) and image rendering speeds seem fine (fast). Interestingly, 32-bit binaries compiled on a Pentium4 machine are a bit faster than the natively compiled 64-bit versions. This seems to point to the compatibility library used by the current driver. When will a full 64-bit version be released? Are there optimal X config file options that one might suggest that differ from the defaults generated by xconfig?

When I say slow ... I mean almost an order of magnitude too slow!!!

System configuration:
Debian 3.1 with 2.6.15.1 kernel
2 x AMD Opteron 275
1 x NVIDIA 7800 GTX (256MB)
4GB RAM
1920 x 1200 display @ 60Hz

Thanks,
Sean
seanm is offline   Reply With Quote
Old 02-07-06, 02:28 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Slow Polygon Rendering on AMD64 (1.0-8178)

Its not clear which application you're running where you're seeing this problem?

Also, please generate and provide a bug report from the system where you're experiencing this problem.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-08-06, 09:19 AM   #3
seanm
Registered User
 
Join Date: Feb 2006
Posts: 2
Default Re: Slow Polygon Rendering on AMD64 (1.0-8178)

Hi Lonni,

The applications exhibiting slow polygon rendering rates are benchmarking programs developed by myself and others. Some use GLUT and call OpenGL directly while others use VTK (which ultimately is calling OpenGL itself). My polygon rendering benchmarks are running about as fast as they do on a Pentium4 machine with a low-end ATI card (not good).

I am attaching the requested nvidia-bug-report.log ... I hope it helps.

-Sean
Attached Files
File Type: zip nvidia-bug-report.log.zip (23.2 KB, 129 views)

Last edited by seanm; 02-08-06 at 09:23 AM. Reason: Addition of nvidia-bug-report.log file
seanm is offline   Reply With Quote
Old 02-08-06, 11:35 AM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Slow Polygon Rendering on AMD64 (1.0-8178)

Is there a reason why you are setting NvAGP=2? Do your benchmark results change if you remove NvAGP from your X configuration?

Is this the VTK that you are referring to?
http://public.kitware.com/VTK/get-software.php

If so please provide the following:
0) the benchmark results you are experiencing in both 32 and 64 bit environments
1) the dataset that you're using which reproduces those benchmark results
2) instructions how to obtain those results

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:03 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.