Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-17-06, 02:11 PM   #13
120
Registered User
 
Join Date: Dec 2005
Posts: 14
Default Re: X locks up with nvidia-kernel-1.0.8178-r3 and 2.6.15-r1 kernel

Quote:
Originally Posted by netllama
ewiget,
If this is a Toshiba laptop, others have run into this problem back in December. You'll need to set the NVreg_Mobile nvidia kernel module perameter to a specific value. You should search for the old threads that have discussed this for the potential workarounds.

Thanks,
Lonni
indeed
options nvidia NVreg_Mobile=1
does the trick. I didn't notice that in modprobe.conf it was misspelled so my mistake (weird that it didn't react actually).
There's still the wrong dot clock problem but as long as I do have a properly sized display I'm happy.
120 is offline   Reply With Quote
Old 02-17-06, 04:43 PM   #14
ewiget
Registered User
 
Join Date: Feb 2006
Location: maysville, ky
Posts: 21
Send a message via ICQ to ewiget Send a message via AIM to ewiget Send a message via MSN to ewiget Send a message via Yahoo to ewiget
Default Re: X locks up with nvidia-kernel-1.0.8178-r3 and 2.6.15-r1 kernel

Quote:
Originally Posted by netllama
ewiget,
If this is a Toshiba laptop, others have run into this problem back in December. You'll need to set the NVreg_Mobile nvidia kernel module perameter to a specific value. You should search for the old threads that have discussed this for the potential workarounds.

Thanks,
Lonni
I am not sure of the exact value, but I simply searched for Toshiba, and per two different threads, I added this to my xorg.conf - commenting one line out and then finally trying both without any changes:

Option "NVreg_Mobile" "1"
Option "IgnoreEDID" "1"

Here is my last Xorg.log ending, but again hard locked:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "true"
(**) NVIDIA(0): Option "IgnoreEDID" "1"
(**) NVIDIA(0): Option "ddc" "off"
(**) NVIDIA(0): Option "RenderAccel" "true"
(**) NVIDIA(0): Enabling experimental RENDER acceleration
(**) NVIDIA(0): Ignoring EDIDs
(--) NVIDIA(0): Linear framebuffer at 0xDC000000
(--) NVIDIA(0): MMIO registers at 0xFD000000

Shouldn't it also show the NVreg_Mobile value in there too???
ewiget is offline   Reply With Quote
Old 02-17-06, 05:10 PM   #15
120
Registered User
 
Join Date: Dec 2005
Posts: 14
Default Re: X locks up with nvidia-kernel-1.0.8178-r3 and 2.6.15-r1 kernel

Quote:
Originally Posted by ewiget
I am not sure of the exact value, but I simply searched for Toshiba, and per two different threads, I added this to my xorg.conf - commenting one line out and then finally trying both without any changes:

Option "NVreg_Mobile" "1"
Option "IgnoreEDID" "1"
you should add this:
options nvidia NVreg_Mobile=1
to /etc/modprobe.conf or /etc/modules.d/nvidia I think. I don't think it has any effect to add Option "NVreg_Mobile" "1" to your xorg.conf.
120 is offline   Reply With Quote
Old 02-17-06, 05:25 PM   #16
ewiget
Registered User
 
Join Date: Feb 2006
Location: maysville, ky
Posts: 21
Send a message via ICQ to ewiget Send a message via AIM to ewiget Send a message via MSN to ewiget Send a message via Yahoo to ewiget
Default Re: X locks up with nvidia-kernel-1.0.8178-r3 and 2.6.15-r1 kernel

Quote:
Originally Posted by 120
you should add this:
options nvidia NVreg_Mobile=1
to /etc/modprobe.conf or /etc/modules.d/nvidia I think. I don't think it has any effect to add Option "NVreg_Mobile" "1" to your xorg.conf.
I found that after I posted the above, and tried 1, 2, 3, 4, 5 for the value, with a hard lock each time.

Now, I think I might be on to something and I will feel absolutely stupid if this fixes it....but I just realized I don't have any /dev/nvidia and this is a udev system.

From the Gentoo Udev Guide is this:
udev and nvidia

If you use the proprietary driver from nVidia and the X server fails to start on a udev-only system, then make sure you have:

* the nvidia module listed in /etc/modules.autoload.d/kernel-2.6
* a version of nvidia-kernel equal to or greater than media-video/nvidia-kernel-1.0.5336-r2
* a version of baselayout equal to or greater than sys-apps/baselayout-1.8.12

If xorg-x11 refuses to start, it might be because the /dev/nvidia device file is missing. If that is the case, run /sbin/NVmakedevices.sh to (re)create it.

My question is, why don't I have the /sbin/NVmakedevices.sh file and why udev isn't adding the correct /dev/ entry for nvidia?? Anyone know what the correct major and minor numbers are and what is supposed to be there?
ewiget is offline   Reply With Quote
Old 02-17-06, 09:32 PM   #17
ewiget
Registered User
 
Join Date: Feb 2006
Location: maysville, ky
Posts: 21
Send a message via ICQ to ewiget Send a message via AIM to ewiget Send a message via MSN to ewiget Send a message via Yahoo to ewiget
Default Re: X locks up with nvidia-kernel-1.0.8178-r3 and 2.6.15-r1 kernel

I think I am at least on the right track, udev didn't create the /dev entries for nvidia and nvidiactl so I created them myself:

rmmod nvidia
mknod /dev/nvidia c 195 0
mknod /dev/nvidiactl c 195 255
modprobe nvidia

verified dev entries were there, and that nvidia appears in lsmod and again - hard locks just as soon as I attempt to startx

So, looking around in udev related stuff, it should create the entries....my /etc/modules.conf has these entries:
# Old nvidia support ...
alias /dev/nvidiactl char-major-195
alias char-major-10-144 nvram
### modules-update: start processing /etc/modules.d/nvidia
alias char-major-195 nvidia
alias /dev/nvidiactl char-major-195
# option see /usr/share/doc/nvidia-kernel-1.0.8178-r3/README.gz
#options nvidia NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1
options nvidia NVreg_Mobile=1
### modules-update: end processing /etc/modules.d/nvidia

and /etc/udev/rules.d/50-udev.rules has:
KERNEL=="nvidia*", NAME="%k", GROUP="video"
KERNEL="nvidia*", NAME="%k", GROUP="video"

Are those correct?

coldplug is set to start at bootup, hotplug is not

Double checked for udev configured correctly in the kernel - at this point, I will assume its a system config issue until I get udev working correctly. In the meantime, I did a complete backup and am re-emerging system and world again.....3rd time is a charm right?
ewiget is offline   Reply With Quote
Old 02-17-06, 10:33 PM   #18
ewiget
Registered User
 
Join Date: Feb 2006
Location: maysville, ky
Posts: 21
Send a message via ICQ to ewiget Send a message via AIM to ewiget Send a message via MSN to ewiget Send a message via Yahoo to ewiget
Default Re: X locks up with nvidia-kernel-1.0.8178-r3 and 2.6.15-r1 kernel

somewhat good news....one problem solved but another one surfaced:

I am not sure which one solved the problem....cause I did two things before checking startx.

First, I added the masked udev to my /etc/portage/package.keywords and emerged it.

Second, hearing a lot of people talk about a gentoo specific file /sbin/NVmakedevices.sh but it didn't exist on my system, I searched for it on google and found it. It seems in was included in 1.0-6629 but must not have been in later versions.

Anyways, I ran this file, and checked device entries....now there was:
crw-rw-rw- 1 root root 195, 0 Feb 17 23:16 /dev/nvidia0
crw-rw-rw- 1 root video 195, 1 Feb 17 23:16 /dev/nvidia1
crw-rw-rw- 1 root video 195, 2 Feb 17 23:16 /dev/nvidia2
crw-rw-rw- 1 root video 195, 3 Feb 17 23:16 /dev/nvidia3
crw-rw-rw- 1 root video 195, 4 Feb 17 23:16 /dev/nvidia4
crw-rw-rw- 1 root video 195, 5 Feb 17 23:16 /dev/nvidia5
crw-rw-rw- 1 root video 195, 6 Feb 17 23:16 /dev/nvidia6
crw-rw-rw- 1 root video 195, 7 Feb 17 23:16 /dev/nvidia7
crw-rw-rw- 1 root root 195, 255 Feb 17 23:16 /dev/nvidiactl

Initially all files were owned by root:root but I noticed the udev rules wanted root:video so I modified the script above....I don't know why it didn't make nvidiactl root:video...and I just now realized it so it may fix my next problem.

New Problem - after I startx, I lose all F1 - F6 consoles and am unable to ctrl + alt + F1 - F6 to get to a shell.

I appreciate everyones help and suggestions and now I really feel bad that at least the first problem was caused by a misconfigured system and not anything related to nvidia modules.

I keep updating this thread to help others who may search, so as soon as I figure out the 2nd problem, I will make a new post for it too. If anyone has any suggestions concerning the 2nd problem, would love to save some time if you could post them.
ewiget is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:59 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.