Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-05-03, 09:59 PM   #1
DiggyDogZiggy
Registered User
 
Join Date: Mar 2003
Location: Chattanooga Tn
Posts: 9
Default Anybody have a clue?

Hi there I have followed the instruction as per the "steel" method to the T. I downloaded the kernelsrc.rpm and did a rpmbuild --rebuild. It installed great Then i switched to runlevel 3, killed the xserver and installed the GLX rpm. I removed the load "dri" line from my XF86config and changed the driver from "vesa" to "nvidia" . when i restart my xserver the screen blinks for about 1/2 second then large cyrillic-like fants appear and everything locks and locks hard.

MY system specs are as follows:
AMD 2400+ processor
MSI K7 mainboard
around 700megs ddr RAM
NVIDIA GeForce 4 Ti 4200 with 64mb ddr ram.
Proview monitor. etc etc etc.

Here is my XF86config file from when she locks down hard.

# File generated by anaconda.

Section "ServerLayout"
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Mouse1" "SendCoreEvents"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "dri"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Option "AutoRepeat" "500 5"
# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
#Option "XkbOptions" ""
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us" #Option "XkbVariant" ""
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Proview 770"
HorizSync 30.0 - 76.0
VertRefresh 50.0 - 150.0
Option "dpms"
EndSection

Section "Device"
# no known options
#BusID
Identifier "NVIDIA GeForce 4 (generic)"
Driver "vesa"
VendorName "NVIDIA GeForce 4 (generic)"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 4 (generic)"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

If anyone can help me please feel free to post info. I remove the load "dri" and change "vesa" to "nvidia". Should i remove the whole

Section "DRI"
Mode 0666
Endsection


there at the end?
DiggyDogZiggy is offline   Reply With Quote
Old 03-06-03, 12:33 AM   #2
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default

Looking at your XF86Config listing. The 'Load DRI' has NOT been removed and the driver still points to 'vesa'. I'd guess this maybe the reason it locks hard. Also you can put the '#' symbol in front of the DRI stuff (I personally remove it entirely, but that's my way)

SO, just change the driver line and remove the load DRI stuff and try it again.
Wolfman [TWP] is offline   Reply With Quote
Old 03-06-03, 04:03 AM   #3
DiggyDogZiggy
Registered User
 
Join Date: Mar 2003
Location: Chattanooga Tn
Posts: 9
Default well i do

i do edit that stuff out. I had to put it back in to get xserver working again. Thanks though.
DiggyDogZiggy is offline   Reply With Quote
Old 03-06-03, 06:44 AM   #4
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default

Which MSI K7 board is it??? And What distro of Linux are you running??

I run two (2) MSI K7T266 Pro 2's and I don't have a problem with them.

One runs Redhat 7.3 & a GF3 Ti200 and the other Redhat 8.0 with a GF3 Ti500. With all the latest drivers, NVIDIA 41.91. No problems
Wolfman [TWP] is offline   Reply With Quote
Old 03-06-03, 11:24 AM   #5
merlin42
Registered User
 
Join Date: Sep 2002
Posts: 52
Default need more info

Your problem sounds a bit odd. Please post your /var/log/XFree86.0.log that is created after the lock up. Just reboot into runlevel 3 after the lockup and copy the file before restarting the Xserver w/ the vesa driver.

Also check your /var/log/messages for anything pertinent.

Also check the simple stuff first:

do
/sbin/lsmod
and check wether nvidia.o gets loaded
if it does then cat all the files under
/proc/driver/nvidia
and look for anything amis.

If the module is not getting loaded then try reinstalling using the tarball.
merlin42 is offline   Reply With Quote
Old 03-06-03, 01:33 PM   #6
DiggyDogZiggy
Registered User
 
Join Date: Mar 2003
Location: Chattanooga Tn
Posts: 9
Default

Well thankx guys for the help i really do appreciate it! I am running Redhat 8.0. Updated the kernel after a new install yesterday and then installed the src.rpm and GLX rpm. this is my /sbin/lsmod file:

[dusty@localhost dusty]$ su
Password:
[root@localhost dusty]# exit
exit
[dusty@localhost dusty]$ /sbin/lsmod
Module Size Used by Tainted: P
sr_mod 18168 0 (autoclean)
emu10k1 68840 0 (autoclean)
ac97_codec 13416 0 (autoclean) [emu10k1]
sound 74228 0 (autoclean) [emu10k1]
soundcore 6500 7 (autoclean) [emu10k1 sound]
nvidia 1592128 1 (autoclean)
autofs 13348 0 (autoclean) (unused)
ppp_synctty 7936 0 (unused)
ppp_async 9440 1
ppp_generic 24380 3 [ppp_synctty ppp_async]
slhc 6756 0 [ppp_generic]
via-rhine 15660 1
mii 2156 0 [via-rhine]
ipt_REJECT 3736 6 (autoclean)
iptable_filter 2412 1 (autoclean)
ip_tables 14840 2 [ipt_REJECT iptable_filter]
ide-scsi 10512 0
scsi_mod 107240 2 [sr_mod ide-scsi]
ide-cd 33608 0
cdrom 33696 0 [sr_mod ide-cd]
mousedev 5524 1
keybdev 2976 0 (unused)
hid 22244 0 (unused)
input 5920 0 [mousedev keybdev hid]
usb-uhci 26188 0 (unused)
ehci-hcd 17448 0 (unused)
usbcore 77056 1 [hid usb-uhci ehci-hcd]
ext3 70336 2
jbd 52212 2 [ext3]
[dusty@localhost dusty]$

i am not sure on how to cat and nvidia.o isnt there just nvidia! Thanks
DiggyDogZiggy is offline   Reply With Quote
Old 03-06-03, 01:54 PM   #7
merlin42
Registered User
 
Join Date: Sep 2002
Posts: 52
Default

ok so the nvidia module is getting loaded. Good.

type:
cat /proc/driver/nvidia/version
cat /proc/driver/nvidia/cards/0
cat /proc/driver/nvidia/agp/card
cat /proc/driver/nvidia/agp/host-bridge
cat /proc/driver/nvidia/agp/status

This should give you lots of probably useless information.

We would still like to see your /var/log/XFree86.0.log
and anything in
/var/log/messages
that might be related to X or nvidia or agp
merlin42 is offline   Reply With Quote
Old 03-06-03, 03:35 PM   #8
DiggyDogZiggy
Registered User
 
Join Date: Mar 2003
Location: Chattanooga Tn
Posts: 9
Default

read down just a little and theres nvidia. I am very appreciative of your help.

Mar 5 22:15:38 localhost rhnsd: rhnsd startup succeeded
Mar 5 22:15:38 localhost rhnsd[904]: Red Hat Network Services Daemon starting up.
Mar 5 22:15:46 localhost login(pam_unix)[909]: session opened for user dusty by LOGIN(uid=0)
Mar 5 22:15:46 localhost -- dusty[909]: LOGIN ON tty1 BY dusty
Mar 5 22:15:52 localhost insmod: Warning: loading /lib/modules/2.4.18-26.8.0/kernel/drivers/video/nvidia.o will taint the kernel: non-GPL license - NVIDIA
Mar 5 22:15:52 localhost insmod: See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Mar 5 22:15:52 localhost insmod: Module nvidia loaded, with warnings
Mar 5 22:15:53 localhost kernel: 0: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4191 Mon Dec 9 11:49:01 PST 2002
Mar 5 22:15:54 localhost insmod: /lib/modules/2.4.18-26.8.0/kernel/drivers/char/agp/agpgart.o: init_module: No such device
Mar 5 22:15:54 localhost insmod: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg
Mar 5 22:15:54 localhost insmod: /lib/modules/2.4.18-26.8.0/kernel/drivers/char/agp/agpgart.o: insmod agpgart failed
Mar 5 22:15:54 localhost kernel: Linux agpgart interface v0.99 (c) Jeff Hartmann
Mar 5 22:15:54 localhost kernel: agpgart: Maximum main memory to use for agp memory: 690M
Mar 5 22:15:54 localhost kernel: agpgart: Unsupported Via chipset (device id: 3189), you might want to try agp_try_unsupported=1.
Mar 5 22:15:54 localhost kernel: 0: NVRM: AGPGART: unable to retrieve symbol table
Mar 5 22:15:59 localhost shutdown: shutting down for system reboot
Mar 5 22:16:01 localhost init: Switching to runlevel: 6
Mar 5 22:16:01 localhost login(pam_unix)[909]: session closed for user dusty
Mar 5 22:16:02 localhost shutdown: shutting down for system reboot
DiggyDogZiggy is offline   Reply With Quote

Old 03-06-03, 05:54 PM   #9
DiggyDogZiggy
Registered User
 
Join Date: Mar 2003
Location: Chattanooga Tn
Posts: 9
Default /var/log/XFree86.0.log



(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4191
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX


and


(VGA_EN is set)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI:*(1:0:0) NVidia unknown chipset (0x0281) rev 161, Mem @ 0xde000000/24, 0xd0000000/27, BIOS @ 0xdfee0000/17
(II) Addressable bus resource ranges are
[0] -1 0x00000000 - 0xffffffff (0x0) MX[b]
[1] -1 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) OS-reported resource ranges:
[0] -1 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0x0000ffff - 0x0000ffff (0x1) IX[b]
[6] -1 0x00000000 - 0x000000ff (0x100) IX[b]

and theres more
DiggyDogZiggy is offline   Reply With Quote
Old 03-07-03, 10:32 PM   #10
Delleon
Geforce4
 
Delleon's Avatar
 
Join Date: Feb 2003
Location: Winnipeg, Canada
Posts: 20
Default

That's kinda weird. It looks like you're using agpgart, but your lsmod doesn't list an agpgart module. You can try forcing the nvidia AGP support instead by adding this line under your "Device" section in XF86Config.

Option "NvAGP" "1"
Delleon is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:14 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.