Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-11-03, 04:27 AM   #1
capoeirista
Registered User
 
Join Date: Mar 2003
Location: Hamvegas, New Zealand
Posts: 8
Unhappy Please Help Me Before I Go Insane

I'm trying to get the 4191 driver working on my slackware 8.1 distrubition of linux, but with no luck. I get the classic

(EE) NVIDIA(0): Failed to initialize the NVdriver kernel module!

error, followed by a

(EE) Screen(s) found but none have a useable configuration

message.

The modules I have loaded (in startup script) are as follows :

Module Size Used by Tainted: P
soundcore 3236 0 (autoclean)
nvidia 1467488 1
agpgart 29824 0 (unused)
pcmcia_core 40896 0
ide-scsi 7456 0
via-rhine 12452 1
mii 1008 0 [via-rhine]

And the following is a copy of my XF86Config file :

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
Load "dri"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/X11R6/lib/X11/fonts/local/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "ServerFlags"
# Option "NoTrapSignals"
# Option "DontZap"
# Option "Dont Zoom"
# Option "DisableVidModeExtension"
# Option "AllowNonLocalXvidtune"
# Option "DisableModInDev"
# Option "AllowNonLocalModInDev"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/mouse"
EndSection

Section "Monitor"
Identifier "Philips Brilliance"
HorizSync 30-69
VertRefresh 50-120
EndSection

Section "Device"
Identifier "nvidia0"
Driver "nvidia"
#VideoRam 4096
# Insert Clocks lines here if appropriate
EndSection

Section "Screen"
Identifier "Screen 1"
Device "nvidia0"
Monitor "Philips Brilliance"
DefaultDepth 16
Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection

Section "ServerLayout"
Identifier "Simple Layout"
Screen "Screen 1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection

I'm running a Celron 450 with 320Mb RAM and GForce 440 MX graphics card.

I can replace the device driver with "vesa", and X loads, but it isn't pretty. Oh yeah, and I've tried the 3123 drivers, but with the same results.

If you can see something that I haven't in all that, or have any ideas, you may yet save what hair I haven't pulled out already

Cheers,
Olly
capoeirista is offline   Reply With Quote
Old 03-11-03, 09:11 AM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

First of all, get rid of Load "dri". I don't think that'll solve the problem, but it's definitely not needed.

Second, you appear to have NVIDIA_kernel-1.0-4191 installed, along with NVIDIA_GLX-1.0-3123 or older -- the 4191 GLX package's nvidia_drv.o driver no longer reports "failed to initialize NVdriver kernel module", but rather "failed to initialize nvidia kernel module". You may want to reinstall the 4191 GLX or the 3123 kernel.

If you still get that error after making sure the versions match, then check the kernel message log -- the nvidia.o module should have logged the reason it couldn't initialize itself. Oftentimes this is due to "PnP OS" being set to Yes in your BIOS, or it's due to "Assign IRQ to VGA" being set to No. These should be set to No and Yes, respectively.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 03-11-03, 02:30 PM   #3
capoeirista
Registered User
 
Join Date: Mar 2003
Location: Hamvegas, New Zealand
Posts: 8
Default

Thank you soooooo much!!!!
I don't no what it was that did it, but I changed the bios stuff that you suggested, and then recompiled the 4191 drivers, and was presented with the nvidia logo.
Cheers!

Olly
capoeirista is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Make Insane, Procedural Platformer Levels (Gamasutra) News Archived News Items 0 05-10-12 09:52 AM
BAH! I'm being driven insane by Java Virtual Machine Kruno General Software 9 09-01-02 10:59 PM

All times are GMT -5. The time now is 10:33 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.