Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-09-06, 05:01 PM   #1
bugger
Registered User
 
Join Date: Apr 2006
Posts: 22
Default AGP does’t work with PCI Express?

I’m experiencing some problems to enable AGP (whether in the BIOS or graphic card).

Here are the facts:
Hardware: mainboard (Asus A8N-SLI) with a nvidia 6200 TurboCache card
Nvidia driver: 1.0-8756 for Linux x86-64 on kernel 2.6.16.1-SMP
Configuration: Twinview, default depth: 24, RenderAccel is enabled, GLX is enabled.
Kernel compiled with agpgart as a module. nvidia.ko loads the agpgart.ko automatically.
Xorg.conf configured with nvAGP = 3
nNvidia-settings says Bus Type: PCI Express 16x


And here is the problem: the BIOS does not recognize AGP at boot time. The agp directory in /proc/drivers/nvidia/ does not exist. I cannot enable “Fast Write” even if I force it with the module parameter.

Glxgears (I know it’s not a real performance tool) shows 700 fps with composite and 1400 without composite. 2D and 3D applications are slow and it seems that they confirm the results of glxgears.

Can someone explain how PCI Express works? Is it a replacement for AGP? If not, how can I enable it?

Apart from the performance the system runs rock solid stable.

Cheers
Bugger
bugger is offline   Reply With Quote
Old 04-09-06, 05:09 PM   #2
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: AGP does’t work with PCI Express?

Would be easier if you just posted the nvidia bugreport as detailed in one of the stickies..
Lithorus is offline   Reply With Quote
Old 04-09-06, 05:23 PM   #3
bugger
Registered User
 
Join Date: Apr 2006
Posts: 22
Default Re: AGP does’t work with PCI Express?

I'm not certain whether this is a bug or just a feature. How is PCI-Express linked to AGP? How to handle AGP in the BIOS and in X? Need to understand it from the technical point of view.
bugger is offline   Reply With Quote
Old 04-09-06, 08:53 PM   #4
Spyke
Foxie
 
Spyke's Avatar
 
Join Date: Aug 2004
Location: Canada
Posts: 618
Send a message via AIM to Spyke Send a message via MSN to Spyke Send a message via Yahoo to Spyke
Default Re: AGP does’t work with PCI Express?

Think of PCI-Express as a souped up PCI bus, it just works, the AGP crap doesn't apply to you.
__________________
Gaming:
Intel i7 980X @ 4GHz | ASUS Rampage III Extreme | GTX 480 3Way SLI @ 900Mhz | Koolance VID-NX480 | Corsair Obsidian 700D
Corsair H70 CPU Cooler | EK-FB RE3 | Corsair AX1200 | Black Ice SR1 360 | 240GB OCZ Revodrive X2 SSD | Windows 7 Ultimate
12GB Corsair Dominator GT @ 8-8-8-24-1T DDR3-1600 | Onkyo TX SR-707 | 70" Sharp Aquos LCD | KEF Audio 5.1 C3/C6LCR/C7
Workstation:
Intel i7 920 D0 @ 4GHz | ASUS Rampage II Extreme | GTX 480 @ 800Mhz | Koolance VID-NX480 | Lian-Li V1200B | Corsair HX1000
EK NB ASUS HP | Watercool HeatKiller 3.0 | Feser Extreme X-360 | 2x160GB Intel X25-M SSD RAID0 | 4x2TB WD20EARS RAID10
12GB Corsair Dominator @ 8-8-8-24-1T DDR3-1600 | Creative X-Fi Titanium | Pioneer DVR-212D | Gentoo Linux
Dell 3008WFP | JohnBlue JB3 | CityPulse DA2.03e II DAC | KingRex T20U w/ Modded Auricaps & PSU | Glow Audio Sub One
Server:
Quad Socket Opteron 8356 (16 cores) @ 2.3GHz | Supermicro H8QMi-2 | Supermicro 2U Chassis | Redundant 1200W PSU
32GB 2GBx16 DDR2-667 ECC | 4x 300GB Cheetah SAS RAID10 | Adaptec 5805 512MB w/BBU | Colocated | Gentoo Linux
Spyke is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM

All times are GMT -5. The time now is 04:59 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.