Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-08-06, 04:46 PM   #13
Roklobsta
Registered User
 
Join Date: Apr 2006
Posts: 8
Default Re: Problems loading 1.0-8756 Driver

Quote:
Originally Posted by netllama
Not having pkg-config would explain why you needed to create the symlinks manually. Did you have pkgconfig installed before installing the nvidia driver?
No, I just installed pkgconfig to be able to run your first command. (my above post was edited.)

This explains why some and not others with FC5 have had trouble. Obviously by default FC5 doesn't install the required xorg package and pkgconfig. I don't know what you'd have to select at installation time to make that happen.

Thanks very much for your help! I'll leave the symlinks in for now as I have the driver working. Hopefully you won't hear from me when the next Linux driver is released.
Roklobsta is offline   Reply With Quote
Old 04-11-06, 12:29 AM   #14
RottenMutt
Registered User
 
Join Date: Apr 2004
Posts: 3
Default Re: Problems loading 1.0-8756 Driver

same problem with kernel 2.6.16-1.2080_FC5smp

xserver output:
dlopen: /usr/lib/libnvidia-tls.so.1: cannot restore segment prot after reloc: Permission denied
(EE) Failed to load module /usr/lib/xorg/modules/extensions/libglx.so
(EE) Failed to load module "glx" (loader failed, 7)
dlopen: /usr/lib/xorg/modules/drivers/nvidia_drv.so: cannot restore segment prot after reloc: Permission denied
(EE) Failed to load module /usr/lib/xorg/modules/drivers/nvidia_drv.so
(EE) Failed to load module "nvidia" (loader failed, 7)
(EE) No drivers available

What does the output from these commands show?
pkg-config --variable=moduledir xorg-server
/usr/lib/xorg/modules

rpm -qa | grep sdk
xorg-x11-server-sdk-1.0.1-8
kdesdk...

Last edited by RottenMutt; 04-11-06 at 09:00 AM.
RottenMutt is offline   Reply With Quote
Old 04-11-06, 06:01 AM   #15
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Problems loading 1.0-8756 Driver

@RottenMutt: that's a different problem that's caused by an incompatibility with Fedora Core 5's SELinux.
zander is offline   Reply With Quote
Old 04-11-06, 09:01 AM   #16
RottenMutt
Registered User
 
Join Date: Apr 2004
Posts: 3
Default Re: Problems loading 1.0-8756 Driver

so do i disable SElinux?
RottenMutt is offline   Reply With Quote
Old 04-11-06, 09:16 AM   #17
RottenMutt
Registered User
 
Join Date: Apr 2004
Posts: 3
Default Re: Problems loading 1.0-8756 Driver

got it, i added to the grub boot loader "selinux=0 3" and uninstalled and reinstalled the nvidia driver and it works. rebooted and rebuilt the selinux table and everything is working.
RottenMutt is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM
RH7.3 and nForce - can't find the module dmw400 NVIDIA Linux 4 08-05-02 12:14 PM

All times are GMT -5. The time now is 04:11 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.