Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-10-06, 01:21 PM   #1
RussellEast
Registered User
 
Join Date: Apr 2005
Posts: 7
Default 8756 choosing laptop screen over external monitor at boot

Fedora 5, xorg 7.0,
Quadro FX Go1400, Dell laptop and external monitor connected via port extender and DVI port.

With previous driver (8178) if I place the laptop on the port extender, with lid closed, then boot up, X starts fine on the external monitor.

With 8756, all the normal boot messages are shown on the external monitor, but when X starts, the monitor LEDs indicate there is no data coming from X. If I open the laptop lid, sure enough, X has started fine, but is showing on the laptop screen.

In /var/log/Xorg.0.log, I see the following which confirms that X is selecting the laptop screen.

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "true"
(**) NVIDIA(0): Option "UseEDID" "true"
(**) NVIDIA(0): Option "RenderAccel" "true"
(**) NVIDIA(0): Option "CursorShadow" "true"
(**) NVIDIA(0): Option "UseEdidFreqs" "true"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): Enabling cursor shadow
(**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID has been
(**) NVIDIA(0): enabled on all display devices.
(II) NVIDIA(0): NVIDIA GPU Quadro FX Go1400 at PCI:1:0:0
(--) NVIDIA(0): VideoRAM: 262144 kBytes
(--) NVIDIA(0): VideoBIOS: 05.41.02.29.a3
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on Quadro FX Go1400 at PCI:1:0:0:
(--) NVIDIA(0): Sharp (DFP-0)
(--) NVIDIA(0): Dell 2405FPW (DFP-1)
(--) NVIDIA(0): Sharp (DFP-0): 310 MHz maximum pixel clock
(--) NVIDIA(0): Sharp (DFP-0): Internal Dual Link LVDS
(--) NVIDIA(0): Dell 2405FPW (DFP-1): 165 MHz maximum pixel clock
(--) NVIDIA(0): Dell 2405FPW (DFP-1): External Single Link TMDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
Attached Files
File Type: log Xorg.0.log (23.9 KB, 115 views)
File Type: txt xorg.conf.txt (5.2 KB, 147 views)
RussellEast is offline   Reply With Quote
Old 04-10-06, 01:32 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 8756 choosing laptop screen over external monitor at boot

Have you tried using the UseDisplayDevice X option? If that fails to help, please generate and post an nvidia-bug-report.log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-10-06, 04:37 PM   #3
RussellEast
Registered User
 
Join Date: Apr 2005
Posts: 7
Default Re: 8756 choosing laptop screen over external monitor at boot

" .... the UseDisplayDevice X option?"

So I've been googling a bit to figure out what this means, but failed miserably. Could you give me a hint or two - this is something in xorg.conf, or a switch for the X server?

-- Russell
RussellEast is offline   Reply With Quote
Old 04-10-06, 04:44 PM   #4
joffe
Registered User
 
joffe's Avatar
 
Join Date: Nov 2004
Posts: 171
Default Re: 8756 choosing laptop screen over external monitor at boot

Quote:
Originally Posted by RussellEast
" .... the UseDisplayDevice X option?"

So I've been googling a bit to figure out what this means, but failed miserably. Could you give me a hint or two - this is something in xorg.conf, or a switch for the X server?

-- Russell
Take a look at the README for the driver:
http://download.nvidia.com/XFree86/L...DME/index.html

or more specifically the X options to go in the xorg.conf:
http://download.nvidia.com/XFree86/L...ppendix-d.html
__________________
GA-MA790GP-DS4H, ATI Radeon HD3300, AMD Phenom X4 9850, 4GB PC8500 [Ubuntu 8.10]
Toshiba 2450-201, GeForce4 420 Go 32MB, Pentium4 2.4GHz, 512 MB PC2700 [Ubuntu 8.10]
joffe is offline   Reply With Quote
Old 04-10-06, 05:30 PM   #5
RussellEast
Registered User
 
Join Date: Apr 2005
Posts: 7
Default Re: 8756 choosing laptop screen over external monitor at boot

Ah right, didn't notice it was an nvidia option, sorry.

But, it looks like UseDisplayDevice can only over-ride the nvidia's choice of a generic CRT vs DFP vs TV. Notice that my problem is, both monitors are DFP, DFP-0 and DFP-1.

I never had this problem before - the 8178 nvidia driver always chose the external monitor, attached to a port replicator, before it chose the laptop's monitor - I've re-installed 8178 to confirm it works fine. Maybe 8756 is having trouble differentiating which one is the external monitor?

I will install the 8756 driver once more and attach a nvidia-bug-report.log.
RussellEast is offline   Reply With Quote
Old 04-10-06, 05:50 PM   #6
RussellEast
Registered User
 
Join Date: Apr 2005
Posts: 7
Default Re: 8756 choosing laptop screen over external monitor at boot

here's the log file - had to zip it, 139Kb greater than 100Kb limit.

Note also, this machine has 2.6.16-1.2080_FC5 kernel. With 8178 driver, I had to use the patch described in another thread, in order to get past problem where the installer could not build the kernel module. 8756 driver does not seem to need that patch - it installs by executing the '.run' file without modification.
Attached Files
File Type: zip nvidia-bug-report.zip (30.4 KB, 127 views)
RussellEast is offline   Reply With Quote
Old 04-10-06, 06:29 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 8756 choosing laptop screen over external monitor at boot

I don't see that you've tried to use the UseDisplayDevice option that I recommended. Please add the following to your X configuration:
Option "UseDisplayDevice" "DFP-1"

and if the problem persists, generate a new bug report for review.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-11-06, 01:03 PM   #8
RussellEast
Registered User
 
Join Date: Apr 2005
Posts: 7
Default Re: 8756 choosing laptop screen over external monitor at boot

Ok, I added the xorg.conf option as described, and it works for both cases where the laptop is or is not connected to the port replicator+external monitor. So that's good. Thanks for the tip.

But, I was curious to see what the 8178 driver was doing "right", so I removed the "UseDisplayDevice" option once more, then reverted to 8178 driver and generated another nvidia-bug-report.log - it is attached.

Seems to me the following might be important - 8178 reports this in the /var/log/Xorg.0.log :

(II) NVIDIA(0): Supported display device(s): CRT-0, DFP-0, DFP-1, TV-0
(II) NVIDIA(0): Boot display device(s): DFP-1

so it has made the decision to go with the external monitor. There is no similar message in the nvidia-bug-report.log for 8756 driver. Seems like a regression to me.
Attached Files
File Type: zip 8178-nvidia-bug-report.zip (27.8 KB, 124 views)
RussellEast is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
295.x drivers cause start X to crash when Dell M4600 laptop is docked, 290.10 ok pbc2520 NVIDIA Linux 7 10-01-12 02:32 PM

All times are GMT -5. The time now is 03:22 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.