Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-15-06, 11:47 PM   #1
exile29
Registered User
 
Join Date: Apr 2006
Posts: 5
Default X won't start. 7300 GS with 8756 driver.

I am pretty much a Linux n00b.
I finally got the installer to run on Ubuntu Breezy 2.6.12-10. After I loaded the driver, I rebooted and got the Nvidia splash. Cool! I messed around a bit (trying to get my resolution to 1280x1024) and restarted X.
No good.
Since then, I have had to run with the default driver which doesn't support the 7300. I can live with it, but I really hate all the scrolling I have to do with my screen at 1024x768. I've attached a copy of my log (which I most likely did not generate properly). If anybody can help me, I would be really grateful.
Thanks in advance!
Attached Files
File Type: log nvidia-bug-report.log (98.5 KB, 136 views)
exile29 is offline   Reply With Quote
Old 04-16-06, 04:41 AM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: X won't start. 7300 GS with 8756 driver.

Remove GLcore and dri from your X config and try again.

Code:
Section "Module"
	Load	"GLcore"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"
EndSection
whig is offline   Reply With Quote
Old 04-16-06, 10:25 AM   #3
exile29
Registered User
 
Join Date: Apr 2006
Posts: 5
Default Re: X won't start. 7300 GS with 8756 driver.

Well, I reinstalled 8756 right over the existing copy then ran the config tool. Started gdm and it's running like a charm now.

I wonder if it will continue to run this way AFTER I reboot?
exile29 is offline   Reply With Quote
Old 04-16-06, 12:35 PM   #4
exile29
Registered User
 
Join Date: Apr 2006
Posts: 5
Default Re: X won't start. 7300 GS with 8756 driver.

Okay.
After I rebooted, X failed to start.
Crap.

One thing I have noticed, when I ran the bug report after sucessfully reinstalling 1.0-8756 I got this:

Quote:
/proc/driver/nvidia/version
NVRM version: NVIDIA Linux x86 Kernel Module 1.0-8756 Wed Mar 29 14:26:26 PST 2006
GCC version: gcc version 3.4.5 20050809 (prerelease) (Ubuntu 3.4.4-6ubuntu8.1)
When I ran the bug report after the reboot (and subsequent X failure) I came up with this:
Quote:
/proc/driver/nvidia/version
NVRM version: NVIDIA Linux x86 NVIDIA Kernel Module 1.0-7667 Fri Jun 17 07:01:04 PDT 2005
GCC version: gcc version 3.4.5 20050809 (prerelease) (Ubuntu 3.4.4-6ubuntu8)
How can I have 2 different versions of the same driver in the same version file? I tried to edit the version file (as root), but it wouldn't let me save (I/O Error).
Do I need to remove 1.0-7667?
[n00b question] How do I go about removing 1.0-7667?
Will that help?
exile29 is offline   Reply With Quote
Old 04-16-06, 12:39 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: X won't start. 7300 GS with 8756 driver.

This looks like a known (and very frequently discussed) Ubuntu issue. Ubuntu ships with 1.0-7667. You'll need to remove it, then (re)install 1.0-8756. Please search this forum for the many other times that this has been discussed (and solved).

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-16-06, 12:43 PM   #6
exile29
Registered User
 
Join Date: Apr 2006
Posts: 5
Default Re: X won't start. 7300 GS with 8756 driver.

Thanks netllama.
I've been searching the forum, but apparently for the wrong thing issue.
Now I know.
exile29 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Base mosaic and rotation? happyfunbot NVIDIA Linux 5 07-13-12 12:23 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
NVIDIA 3123 driver on SuSE 8.0 Ok , but slow to start X Gabolander NVIDIA Linux 3 09-27-02 07:41 AM
failing to initialize NV driver PsyShook NVIDIA Linux 10 09-19-02 12:41 PM

All times are GMT -5. The time now is 06:24 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.