Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-17-06, 11:52 AM   #1
misterflibble
Registered User
 
Join Date: Jun 2004
Posts: 23
Default Can't Disable AGP

I'm trying to disable AGP support in X to improve my system's stability. However I can't set Nvagp to anything but 2 or 3 (agpgart) or I end up with kind of a white staticy screen AFTER the nvidia splash screen comes up. The only changes in the Xorg log is these WAIT messages:

Code:
(II) Loading extension NV-CONTROL
(WW) NVIDIA(0): WAIT (0, 6, 0x8000, 0x00000db8, 0x00000db8, 0)
(==) RandR enabled
(II) Setting vga for screen 0.
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
(**) Option "CoreKeyboard"
(**) Keyboard0: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xfree86"
(**) Keyboard0: XkbRules: "xfree86"
(**) Option "XkbModel" "pc105"
(**) Keyboard0: XkbModel: "pc105"
(WW) Option "XkbLayout" requires an string value
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(**) Option "Protocol" "IMPS/2"
(**) USB Mouse: Device: "/dev/input/mice"
(**) USB Mouse: Protocol: "IMPS/2"
(**) Option "SendCoreEvents" "true"
(**) USB Mouse: always reports core events
(**) Option "CorePointer"
(**) USB Mouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(**) Option "Buttons" "5"
(==) USB Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) USB Mouse: ZAxisMapping: buttons 4 and 5
(**) USB Mouse: Buttons: 9
(II) XINPUT: Adding extended input device "USB Mouse" (type: MOUSE)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(II) USB Mouse: ps2EnableDataReporting: succeeded
Warning: font renderer for ".pcf" already registered at priority 0
Warning: font renderer for ".pcf.Z" already registered at priority 0
Warning: font renderer for ".pcf.gz" already registered at priority 0
Warning: font renderer for ".snf" already registered at priority 0
Warning: font renderer for ".snf.Z" already registered at priority 0
Warning: font renderer for ".snf.gz" already registered at priority 0
Warning: font renderer for ".bdf" already registered at priority 0
Warning: font renderer for ".bdf.Z" already registered at priority 0
Warning: font renderer for ".bdf.gz" already registered at priority 0
Warning: font renderer for ".pmf" already registered at priority 0
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo, removing from list!
(WW) NVIDIA(0): WAIT (2, 6, 0x8000, 0x00000e0c, 0x00000f7c, 0)
(WW) NVIDIA(0): WAIT (1, 6, 0x8000, 0x00000e0c, 0x00000f7c, 0)
Any ideas?
misterflibble is offline   Reply With Quote
Old 04-17-06, 11:37 PM   #2
pauljohn
Registered User
 
Join Date: Jul 2005
Posts: 28
Default Re: Can't Disable AGP

add

agp=off

in the end of the "kernel" line that starts your system. I added it in /etc/grub.conf.

If you don't do that, you need to rebuild the entire kernel after reconfiguring to remove all the AGP components. Hassle
pauljohn is offline   Reply With Quote
Old 04-18-06, 03:33 AM   #3
Nailor
Registered User
 
Join Date: Apr 2006
Posts: 10
Default Re: Can't Disable AGP

Seems like a same kind of problem I have. Gotta try that agp-thing, if it helps.

- Jyrki
Nailor is offline   Reply With Quote
Old 04-18-06, 10:54 AM   #4
misterflibble
Registered User
 
Join Date: Jun 2004
Posts: 23
Default Re: Can't Disable AGP

The agp=off option changed nothing, and according to my kernel-parameters file in the source documentation (2.6.15), its not even a listed option.
I tried removing my agp modules (agpgart and via-agp) from loading at bootup, and I succeeded...partially. The nvidia driver seems to depend on the agpgart driver and loads it again anyways!
misterflibble is offline   Reply With Quote
Old 04-18-06, 11:03 AM   #5
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Can't Disable AGP

@misterflibble: so X doesn't work correctly if you start it with Option "NvAGP" "0"? The NVIDIA kernel module depends on agpgart.ko, the Linux AGPGART frontend, in order to determine if a backend driver (in your case, via-agp.ko) is present.
zander is offline   Reply With Quote
Old 04-18-06, 11:13 AM   #6
misterflibble
Registered User
 
Join Date: Jun 2004
Posts: 23
Default Re: Can't Disable AGP

That's correct, Zander: Starting X with NvAGP 0 either gives me a messed up screen after the excellent-looking splash screen or sometimes just a competely black screen with no splash. X itself seems to be running fine, all the programs started up.

I just 2 minutes ago found a previous post of yours explaining why agpgart is required. Sorry.
misterflibble is offline   Reply With Quote
Old 04-18-06, 11:16 AM   #7
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Can't Disable AGP

@misterflibble: does the X startup problem with Option "NvAGP" "0" also reproduce if you comment out the Load "glx" line in the modules section?
zander is offline   Reply With Quote
Old 04-18-06, 11:25 AM   #8
misterflibble
Registered User
 
Join Date: Jun 2004
Posts: 23
Default Re: Can't Disable AGP

Yes, it does
misterflibble is offline   Reply With Quote

Old 04-18-06, 11:28 AM   #9
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Can't Disable AGP

@misterflibble: which driver(s) does this reproduce with? Is this a recent regression or does it reproduce with earlier drivers? Please generate and attach an nvidia-bug-report.log file, preferably after attempting to start X with Option "NvAGP" "0" (please also see http://www.nvnews.net/vbulletin/showthread.php?t=46678).
zander is offline   Reply With Quote
Old 04-18-06, 12:41 PM   #10
misterflibble
Registered User
 
Join Date: Jun 2004
Posts: 23
Default Re: Can't Disable AGP

I've encountered the problem with 8178, 8756, and 7676, which is all I've tested. I've noticed that Xorg also shoots up to 100% cpu usage when this problem happens and has to be killed. Attached is my log generated with 7676.
Attached Files
File Type: zip nvidia-bug-report.log.zip (26.4 KB, 125 views)
misterflibble is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
POSSIBLE AGP TROUBLE (mandrake 9.0) chrono86 NVIDIA Linux 4 10-12-02 12:09 PM
Gentoo and agp trouble john36 NVIDIA Linux 2 09-12-02 10:36 PM
agp 440bx/zx tntultar32 t00bad NVIDIA Linux 1 09-11-02 02:46 PM
How much heat can a GeForce4 Ti 4600 handle? Velkator NVIDIA GeForce 7, 8, And 9 Series 4 09-03-02 04:41 PM
X freezes when agp 4x is enabled jinksed NVIDIA Linux 1 08-07-02 04:56 PM

All times are GMT -5. The time now is 09:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.