Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-21-06, 07:51 PM   #13
mrmailer
Registered User
 
Join Date: Dec 2005
Posts: 37
Default Re: even with 8756, minimal multitasking slows down glxgears performance

who said i was not using xv? It happens with xv or xvmc, and the video app itself is not using much CPU at all.

i was just watching a video from mythtv and ran yum update, and during the initial stage, even that was slowing down the video tremendously. and i agree about performance issue, as my laptop, which is slower, does not have this problem.

help? i can't even do any video stuff and multitask.
mrmailer is offline   Reply With Quote
Old 04-21-06, 07:55 PM   #14
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: even with 8756, minimal multitasking slows down glxgears performance

Hi,

did you watch a video with mythtv or made by mythtv?
energyman76b is offline   Reply With Quote
Old 04-21-06, 08:32 PM   #15
mrmailer
Registered User
 
Join Date: Dec 2005
Posts: 37
Default Re: even with 8756, minimal multitasking slows down glxgears performance

it does it with livetv and recorded tvshows i am watching a recorded show right now with xvmc and cpu usage for mythfrontend is 23%
if i even SWITCH tabs in firefox, it chunks the video

is it me or do you not get notified of replies if you use quick reply?
mrmailer is offline   Reply With Quote
Old 04-22-06, 07:03 AM   #16
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: even with 8756, minimal multitasking slows down glxgears performance

Hi,

could you please try a different tv application - like xdtv?

xdtv can record shows too, even schedule it, and it needs much, much less CPU. mythtv is a real CPU hog.

If your problem still exists with a different app, than we have to look elsewhere - but I don't have very fond memories about mythtv....
energyman76b is offline   Reply With Quote
Old 04-22-06, 01:53 PM   #17
mrmailer
Registered User
 
Join Date: Dec 2005
Posts: 37
Default Re: even with 8756, minimal multitasking slows down glxgears performance

sorry, i thought i explained that it's other apps too, like xine, mplayer, etc.

i notice, for instance, it doesn't happen when i start firefox, but as soon as firefox loads graphics, if that makes sense.

if i reload a page it does it too. both apps seem to slow down(Video and firefox)

it seems cpu usage reaches 90% when i load a page in firefox. here's top results as i just loaded a page.

Xorg seems to remain around 50%


top - 03:49:17 up 3 days, 4:14, 3 users, load average: 2.62, 2.54, 2.44
Tasks: 119 total, 3 running, 116 sleeping, 0 stopped, 0 zombie
Cpu(s): 81.8% us, 15.2% sy, 0.0% ni, 0.0% id, 0.0% wa, 1.3% hi, 1.7% si, 0Mem: 776868k total, 764324k used, 12544k free, 6872k buffers
Swap: 264560k total, 39776k used, 224784k free, 409424k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
29155 user 16 0 114m 40m 15m R 47.1 5.4 0:20.77 firefox-bin
24862 root 17 0 73304 48m 26m R 31.6 6.4 147:16.12 Xorg
25955 user 15 0 151m 51m 33m S 18.8 6.8 65:10.75 mythtv



The thing is, all the cpu usage does seem to go down when using xine instead of mythtv. but then i see it's mplayer as well.
so maybe it's mplayer period? i just refreshed a page while playing something with mplayer, and the cpu usage went to 90+%




top - 03:54:25 up 3 days, 4:20, 4 users, load average: 2.02, 2.12, 2.27
Tasks: 119 total, 2 running, 117 sleeping, 0 stopped, 0 zombie
Cpu(s): 76.7% us, 19.6% sy, 0.0% ni, 0.0% id, 0.0% wa, 2.7% hi, 1.0% si, 0Mem: 776868k total, 764284k used, 12584k free, 7124k buffers
Swap: 264560k total, 39776k used, 224784k free, 417744k cached


But even with xine, it does this, going to 90% total on refresh of page while watching video

top - 03:55:28 up 3 days, 4:21, 4 users, load average: 2.38, 2.20, 2.29
Tasks: 120 total, 1 running, 119 sleeping, 0 stopped, 0 zombie
Cpu(s): 86.4% us, 5.0% sy, 0.0% ni, 6.3% id, 0.0% wa, 1.0% hi, 1.3% si, 0Mem: 776868k total, 764944k used, 11924k free, 6864k buffers
Swap: 264560k total, 39776k used, 224784k free, 405684k cached



but when i refresh a page with firefox with nothing else being done at all, top still reports Cpu(s) up to 90%

it seems anything to do with video/graphics????
PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
29155 user 16 0 118m 45m 16m S 65.7 6.1 1:07.74 firefox-bin
24862 root 15 0 64572 37m 10m S 14.9 4.9 148:57.41 Xorg
29296 user 15 0 198m 24m 6784 S 6.6 3.2 0:01.84 xine
25576 user 15 0 27136 13m 7900 S 3.6 1.8 0:32.68 metacity


PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
24862 root 18 0 58352 36m 11m R 44.5



but it does it with openoffice and other such apps as well.
basically, i end up not being able to do any worthwhile multitasking while watching video


it is athlon 2ghz cpu
??

Last edited by mrmailer; 04-23-06 at 05:02 AM.
mrmailer is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-31-02 12:59 AM

All times are GMT -5. The time now is 10:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.