Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-18-06, 10:33 AM   #1
foxy123
Registered User
 
Join Date: Mar 2005
Posts: 14
Default Random freeze with 6200A

I have traded my Radeon 9550 for Inno3D nVidia 6200 card. The main reason was an allegedly better Linux support from nVidia. Unfortunately I feel a great disappointment from my purchase. As a matter of fact I do not blame nVidia for that. I have this notorious random freeze bug when X freezes but everything including mouse pointer continue working. I can connect over ssh from my laptop and kill X.

However the freeze does not happen at once or just when I run OpenGL app. I tried glxgears and it is running fine. However after a while (sometimes a couple of minutes, sometimes 10-15 minutes) it freezes.

I tried to put in my xorg.conf the following:
Code:
Option "NvAGP" "0" (and "1" as well)
Option "RenderAccel" "Off"
Option "IgnoreDisplayDevices" "DFP,TV"
Option "NoRenderExtension" "Off"
Option "Accel" "Off"
Option "AllowGLXWithComposite" “Off”
But it did not help.

The most interesting thing for me is that I had exactly the same problem with Radeon 9550. So I've got a feeling that it maybe something wrong with my motherboard and its AGP slot in particular. I have MSI KT6V-LSR (VIA® KT600 Chipset) with Athlon XP 2200+ and 768 MB DDR memory.

To get rid of this problem with ATI card I did the following:
- disable fast-write (both in BIOS and just in case in xorg.conf)
- downgraded APG from x8 to x4 (in xorg.conf as my BIOS does not have such an option)
- and increased the APG voltage.

I wonder if I can do the same thing with nVidia in xorg.conf. Does anyone know the options for that? The only thing I am not sure with is AGP as it says in the spec that my card supports only x8, not x4. So I am not sure if I can try to downgrade it from x8 to x4.

Any comments and help will be highly appreciated.

BTW, I am running Ubuntu Breezy.
foxy123 is offline   Reply With Quote
Old 04-18-06, 10:46 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Random freeze with 6200A

Yes, you can adjust these AGP settings with the NVIDIA Linux graphics driver; please see http://download.nvidia.com/XFree86/L...ppendix-f.html for details.
zander is offline   Reply With Quote
Old 04-18-06, 06:57 PM   #3
foxy123
Registered User
 
Join Date: Mar 2005
Posts: 14
Default Re: Random freeze with 6200A

Quote:
Originally Posted by zander
Yes, you can adjust these AGP settings with the NVIDIA Linux graphics driver; please see http://download.nvidia.com/XFree86/L...ppendix-f.html for details.
Thanks a lot. I tried
Code:
Option "NVreg_EnableVia4x"  "1"
but dmesg still says that AGP is X8

Another thing. I thought that if I disable glx the freeze should disappear, but it did not, I even have this problem if use "nv" driver instead of "nvidia". How can it be? Is not it a 3D aacceleration problem?
__________________
Desktop: Ubuntu 7.10 Gutsy, XFCE 4.4, kernel 2.6.22. Dual Core AMD 2800+, Nforce4 motherboard, 2MB, nVidia GeForce 7600 GT.
foxy123 is offline   Reply With Quote
Old 04-20-06, 04:04 AM   #4
beww
Registered User
 
Join Date: Apr 2006
Location: Cheyenne, Wyoming, USA
Posts: 1
Default Re: Random freeze with 6200A

I had the exact same problem. The problem went away using a 5700 or a 6800 card. As with you, even the "nv" driver failed, so it seems to ba a problem with the card and not the driver.

My 6200 card has 256MB RAM on it, and both the "working" cards have 128, I don't know if that had anything to do with the problem or not.

Wish I had a better solution for you, but that's what worked for me.
beww is offline   Reply With Quote
Old 04-20-06, 04:08 AM   #5
foxy123
Registered User
 
Join Date: Mar 2005
Posts: 14
Default Re: Random freeze with 6200A

What does mean something like that in dmesg:
Code:
agpgart aperture 128M
?
__________________
Desktop: Ubuntu 7.10 Gutsy, XFCE 4.4, kernel 2.6.22. Dual Core AMD 2800+, Nforce4 motherboard, 2MB, nVidia GeForce 7600 GT.
foxy123 is offline   Reply With Quote
Old 04-20-06, 05:44 AM   #6
JTY
Registered User
 
Join Date: Sep 2005
Posts: 12
Default Re: Random freeze with 6200A

Perhaps you've got a problem that isn't driver/software related? For what it's worth, I've got an Inno3d 6200A, and it works very well. (I'm running CentOS 4.3)

Also hardware wise, i've got an ASRock K7VT4A+ motherboard (KT400A), Sempron 2600+, and 1GB RAM.
JTY is offline   Reply With Quote
Old 04-20-06, 05:57 AM   #7
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Random freeze with 6200A

@foxy123: NVreg_EnableVia4x is a kernel module parameter, not an NVIDIA X driver option; it enables AGP 4x on Via chipsets that are forced to AGP 2x by default due to stability problems at higher rates. Since you wish to throttle the AGP rate on your system, you will need to enable and use the NVreg_ReqAGPRate kernel module parameter (see the instructions in the README appendix I posted a link to earlier). AGP fast-writes are disabled by default.
zander is offline   Reply With Quote
Old 04-20-06, 06:25 AM   #8
foxy123
Registered User
 
Join Date: Mar 2005
Posts: 14
Default Re: Random freeze with 6200A

Quote:
Originally Posted by zander
@foxy123: NVreg_EnableVia4x is a kernel module parameter, not an NVIDIA X driver option; it enables AGP 4x on Via chipsets that are forced to AGP 2x by default due to stability problems at higher rates. Since you wish to throttle the AGP rate on your system, you will need to enable and use the NVreg_ReqAGPRate kernel module parameter (see the instructions in the README appendix I posted a link to earlier). AGP fast-writes are disabled by default.
yes, I have recompiled the driver with
Code:
+ static int NVreg_ReqAGPRate = 4;   /* force AGP Rate to 4x */
and got x4, but still it does lock X up after 10-15 minutes. I have disabled xscreensaver to make sure it is not a problem....
__________________
Desktop: Ubuntu 7.10 Gutsy, XFCE 4.4, kernel 2.6.22. Dual Core AMD 2800+, Nforce4 motherboard, 2MB, nVidia GeForce 7600 GT.
foxy123 is offline   Reply With Quote

Old 04-20-06, 02:14 PM   #9
foxy123
Registered User
 
Join Date: Mar 2005
Posts: 14
Default Re: Random freeze with 6200A

well, it is not a screensaver... I generated a bug report and sent it to nVidia. Do they reply in anyway or just collect thise reports?
__________________
Desktop: Ubuntu 7.10 Gutsy, XFCE 4.4, kernel 2.6.22. Dual Core AMD 2800+, Nforce4 motherboard, 2MB, nVidia GeForce 7600 GT.
foxy123 is offline   Reply With Quote
Old 04-21-06, 04:48 PM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Random freeze with 6200A

Yes, NVIDIA received your bug report, and we do respond to all emails. Had you posted it here, we could have responded here as well.

I have a few questions:
0) Does your BIOS have a means of reducing the AGP rate? If so, can you try reducing it?
1) If you boot with the noapic and/or acpi=off kernel parameters, does that have any impact?
2) Have you tried using a much more recent kernel (such as 2.6.16.x)?
3) Have you verified that you're using the latest BIOS for the motherboard?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-22-06, 12:45 PM   #11
foxy123
Registered User
 
Join Date: Mar 2005
Posts: 14
Default Re: Random freeze with 6200A

Quote:
Originally Posted by netllama
Yes, NVIDIA received your bug report, and we do respond to all emails. Had you posted it here, we could have responded here as well.

I have a few questions:
0) Does your BIOS have a means of reducing the AGP rate? If so, can you try reducing it?
1) If you boot with the noapic and/or acpi=off kernel parameters, does that have any impact?
2) Have you tried using a much more recent kernel (such as 2.6.16.x)?
3) Have you verified that you're using the latest BIOS for the motherboard?

Thanks,
Lonni
thanks a lot for your reply. Here are the answers:

0) no it does not.
1) yes I tried but I still had the freeze
2) I tried to boot with Ubuntu Dapper live CD which uses 2.6.16.x kernel and had the same freeze.
3) I am using the latest BIOS.

I have attached the bug report here as well.

cheers...
Attached Files
File Type: log nvidia-bug-report.log (86.3 KB, 136 views)
__________________
Desktop: Ubuntu 7.10 Gutsy, XFCE 4.4, kernel 2.6.22. Dual Core AMD 2800+, Nforce4 motherboard, 2MB, nVidia GeForce 7600 GT.
foxy123 is offline   Reply With Quote
Old 04-23-06, 02:37 AM   #12
deadman_kein
Registered User
 
Join Date: Apr 2006
Posts: 1
Default Re: Random freeze with 6200A

I have the same problem on my box. I tried many distributions with variety of kernels ranging from 2.4.28 to newer 2.6 (can't remember exacly) both on 32 and 64 bit distributions, with different X servers. Recently changed video card from GF 6600 to GF 6800GS. The problem is still here. Used many BIOS versions for my motherboard. No matter what I tried, the problem did not vanish. I only had it reduced by using nv driver, but now it's not an option, as my new card is not supported.

I'll try to produce detailed bug report later.
deadman_kein is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
302.17 and total PC freeze on 7600GT Milos_SD NVIDIA Linux 8 07-14-12 01:56 PM
Fedora 16, GTX 550Ti, random X hangs, "Attempted to yield the CPU..." MquwIBUO NVIDIA Linux 7 06-12-12 03:39 PM
random X crash with 295.53 on debian testing kde4 kernel 3.3.1 JenK NVIDIA Linux 0 06-03-12 07:24 AM
Random loot packs are the best-selling item in free-to-play City of Heroes News Latest Tech And Game Headlines 0 05-06-12 11:00 AM
Why in Spider-Man The Movie PC Game only some levels i go to will freeze? imtim83 Gaming Central 5 10-03-02 09:21 PM

All times are GMT -5. The time now is 11:37 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.