Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-24-06, 04:16 PM   #1
ckrueger
Registered User
 
Join Date: Apr 2006
Posts: 2
Default [SOLVED] Multihead problems since update to 1.0-8756

In earlier driver versions (1.0-8174 and prior), I was able to configure each output on a dual-head card as its own individual device. This was useful because the two displays on this card are totally different (one DVI, 1280x1024, the other standard D-sub, 1024x768 ). Also, this is a tri-head setup, so not having to mess with TwinView made the setup unbelievably easy. Below are the device sections in my xorg.conf as they were before the driver update (which was included in the update to 6.04):

Code:
Section "Device"
        Identifier      "NVIDIA GeForceFX 5600 Center"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
        Option          "ConnectedMonitor"      "dfp"
        Screen          0
        Option          "RenderAccel"   "true"
EndSection

Section "Device"
        Identifier      "NVIDIA GeForceFX 5600 Left"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
        Option          "ConnectedMonitor"      "crt"
        Screen          1
        Option          "RenderAccel"   "true"
EndSection
Since the update, I have rewritten both device statements from scratch screwing with the presence (and settings) of the "Screen" and "ConnectedMonitor" arguments, but nothing has yielded the correct effect. Whenever starting X now, it says that the device PCI:1:0:0 is already in use, and removing that statement keeps the device from even being acknowledged.

Also, I tried changing the "ConnectedMonitor" statements to what I was told replaced that flag - "UseDisplayDevice":

Code:
Section "Device"
        Identifier      "Center"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
        Option          "RenderAccel"   "true"
        Option          "UseDisplayDevice"      "DFP-0"
EndSection

Section "Device"
        Identifier      "Left"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
        Option          "RenderAccel"   "true"
        Option          "UseDisplayDevice"      "CRT-0"
EndSection
Has anyone successfully configured their nVidia setup with the new 8756 driver *WITHOUT* using TwinView? I'd appreciate any help I can get. Thanks!

Regards,
Campbell Krueger

Last edited by ckrueger; 04-24-06 at 04:34 PM.
ckrueger is offline   Reply With Quote
Old 04-24-06, 04:32 PM   #2
ckrueger
Registered User
 
Join Date: Apr 2006
Posts: 2
Default Re: Multihead problems since update to 1.0-8756

It looks like I answered my own questions after another ~10 minutes of dickin around with it. Hopefully my X config will help answer other peoples' questions in the future:

Code:
Section "Device"
        Identifier      "Center"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
        Option          "RenderAccel"   "true"
        Option          "UseDisplayDevice"      "DFP-0"
        Screen  0
EndSection

Section "Device"
        Identifier      "Left"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
        Option          "RenderAccel"   "true"
        Option          "UseDisplayDevice"      "CRT-0"
        Screen  1
EndSection

Section "Device"
        Identifier      "Right"
        Driver          "nvidia"
        BusID           "PCI:2:1:0"
        Option          "RenderAccel"   "true"
EndSection

Section "Monitor"
        Identifier      "Monitor"
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Center Screen"
        Device          "Center"
        Monitor         "Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth           24
        EndSubSection
EndSection

Section "Screen"
        Identifier      "Left Screen"
        Device          "Left"
        Monitor         "Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth           24
        EndSubSection
EndSection

Section "Screen"
        Identifier      "Right Screen"
        Device          "Right"
        Monitor         "Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth           24
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Center Screen"
        Screen          "Left Screen" LeftOf "Center Screen"
        Screen          "Right Screen" RightOf "Center Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

Section "ServerFlags"
        Option          "Xinerama"      "on"
EndSection
Regards,
Campbell Krueger
ckrueger is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:40 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.