Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-23-06, 07:32 PM   #1
arokh
Registered User
 
arokh's Avatar
 
Join Date: Jun 2004
Posts: 287
Default Fonts does not show in Cedega

Like the subject says, fonts are not visible in Windows applications run by Cedega. Same thing with Wine.

The problem does not appear with the "nv" driver. Anybody having the same issue?

Screenshot of the problem:
http://chaos.troll.no/~trondare/Scre...stryEditor.png

Distribution is Fedora Core 5.
Attached Files
File Type: zip nvidia-bug-report.zip (23.4 KB, 121 views)
__________________
Asus A8N32-SLI : AMD64 3700+ @ 2.85GHz : 2GB PC4000 OCZ Platinum EB : 2x 7800GT SLI
arokh is offline   Reply With Quote
Old 04-24-06, 02:27 AM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Fonts does not show in Cedega

Try to disable RenderAccel by adding the line: Option "RenderAccel" "0" to your X config file.
Thunderbird is offline   Reply With Quote
Old 04-24-06, 03:18 AM   #3
arokh
Registered User
 
arokh's Avatar
 
Join Date: Jun 2004
Posts: 287
Default Re: Fonts does not show in Cedega

Quote:
Originally Posted by Thunderbird
Try to disable RenderAccel by adding the line: Option "RenderAccel" "0" to your X config file.
Actually, I already tried that Makes sense, since Render is now accelerated by default, and the only setting that seems like it could cause this. But, it doesn't seem to be it.

Could somebody with FC5 post here if they have this problem or not? Installing wine is just a 'yum install wine' away, then you can run regedit from applications -> system tools.
__________________
Asus A8N32-SLI : AMD64 3700+ @ 2.85GHz : 2GB PC4000 OCZ Platinum EB : 2x 7800GT SLI
arokh is offline   Reply With Quote
Old 04-25-06, 04:06 AM   #4
arokh
Registered User
 
arokh's Avatar
 
Join Date: Jun 2004
Posts: 287
Default Re: Fonts does not show in Cedega

Bump!
__________________
Asus A8N32-SLI : AMD64 3700+ @ 2.85GHz : 2GB PC4000 OCZ Platinum EB : 2x 7800GT SLI
arokh is offline   Reply With Quote
Old 04-25-06, 04:21 AM   #5
gbil
Registered User
 
Join Date: Mar 2006
Posts: 272
Default Re: Fonts does not show in Cedega

I don't have this problem with FC5, RenderAccel set to 1 BUT I have compiled wine myself so it could also be a problem with the wine fc5 rpms .
gbil is offline   Reply With Quote
Old 04-25-06, 06:25 AM   #6
arokh
Registered User
 
arokh's Avatar
 
Join Date: Jun 2004
Posts: 287
Default Re: Fonts does not show in Cedega

Quote:
Originally Posted by gbil
I don't have this problem with FC5, RenderAccel set to 1 BUT I have compiled wine myself so it could also be a problem with the wine fc5 rpms .
Hm, good point. Could be a problem with Transgaming's compile options as well. How did you configure Wine?
__________________
Asus A8N32-SLI : AMD64 3700+ @ 2.85GHz : 2GB PC4000 OCZ Platinum EB : 2x 7800GT SLI
arokh is offline   Reply With Quote
Old 04-25-06, 06:46 AM   #7
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Fonts does not show in Cedega

Wine and Cedega are completely different beasts these days. Wine's font rendering code which uses Xrender aswell is completely different from the old code which is still in Cedega. So comparing wine and cedega is comparing apples with oranges.
Thunderbird is offline   Reply With Quote
Old 04-25-06, 06:52 AM   #8
arokh
Registered User
 
arokh's Avatar
 
Join Date: Jun 2004
Posts: 287
Default Re: Fonts does not show in Cedega

The same problem occurs with both, so I'd say it still has some common code.
__________________
Asus A8N32-SLI : AMD64 3700+ @ 2.85GHz : 2GB PC4000 OCZ Platinum EB : 2x 7800GT SLI
arokh is offline   Reply With Quote

Old 04-25-06, 10:37 AM   #9
gbil
Registered User
 
Join Date: Mar 2006
Posts: 272
Default Re: Fonts does not show in Cedega

I just did a normal configure - make after applying patches from here:
http://appdb.winehq.org/appview.php?...TestingId=2493

but these were just for WoW to work correctly so I don't think that has anything to do with this issue.
gbil is offline   Reply With Quote
Old 04-25-06, 12:43 PM   #10
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Fonts does not show in Cedega

Which version of X are you using? If it's newer than X.org 7.0, then fonts are not expected to work due to an ABI change in the server.
AaronP is offline   Reply With Quote
Old 04-25-06, 03:13 PM   #11
arokh
Registered User
 
arokh's Avatar
 
Join Date: Jun 2004
Posts: 287
Default Re: Fonts does not show in Cedega

Quote:
Originally Posted by AaronP
Which version of X are you using? If it's newer than X.org 7.0, then fonts are not expected to work due to an ABI change in the server.
Aaaah!!

xorg-x11-server-Xorg-1.0.99.1-2

I upgraded for no reason a while back, didn't pay no more thought to it... Will try a downgrade now, suspect that it very well might be the problem

Thanks AaronP!
__________________
Asus A8N32-SLI : AMD64 3700+ @ 2.85GHz : 2GB PC4000 OCZ Platinum EB : 2x 7800GT SLI
arokh is offline   Reply With Quote
Old 04-25-06, 04:08 PM   #12
arokh
Registered User
 
arokh's Avatar
 
Join Date: Jun 2004
Posts: 287
Default Re: Fonts does not show in Cedega

That was it! This issue is officially resolved
__________________
Asus A8N32-SLI : AMD64 3700+ @ 2.85GHz : 2GB PC4000 OCZ Platinum EB : 2x 7800GT SLI
arokh is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Computex 2012 Show Floor: Ultrabooks with Discrete GPUs News Archived News Items 0 06-06-12 03:30 AM
Company of Heroes 2 screenshots show a snowy town, tank columns and pyromania News Archived News Items 0 06-05-12 08:00 PM
Pre-emptive trailers show off some of E3's biggest titles News Archived News Items 0 06-01-12 11:50 AM
Someone please show me the difference in image quality on a ATI 9700 pro vs a GF4 ti? imtim83 Other Desktop Graphics Cards 70 10-22-02 01:25 AM
fonts were nicer with VESA driver, any hints? wim NVIDIA Linux 1 08-27-02 12:03 PM

All times are GMT -5. The time now is 04:45 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.