Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-24-06, 09:49 AM   #1
JaXXoN
Registered User
 
Join Date: Jul 2005
Location: Munich
Posts: 910
Default nv-1.0-8756 in xenU somewhat working, problems with USB

Hi!

First of all, please let me explain what i'd like to achive:

I'd like to create a multi-seat environment with two 7800GTX PCIe
cards, two PCI sound cards, two mice and two keyboards, so that
two people can work simultaneously on the same computer using
different operating systems (i.e. Linux, BSD, Solaris or potentially
even some flaviour of Windows - this is not yet possible as of xen-3.0
without virtualization support by CPU, so my current experiments
are Linux-only).

What i did:
1. Installed Fedora Core 5 on physical computer
2. Installed Fedora Core 5 on virtual computer (using qemu).
3. Installed Xen-3.0.2 from source on the physical computer
(as described in a previous post in this forum).
4. Installed the unified xen0/xenU kernel on the virtual computer
5. Configured gdm on the virtual computer to use "-shartvt vt1"
6. Installed an second PCI USB controller card, isolated it from
the xen0 domain and dedicated it to the xenU domain.

This basically works, means: the physical computer boots linux
and the X-server comes up on the first 7800GTX. Then i log in and
start then virtual computer (xm create ...) and another X-server
comes up on the second 7800GTX showing the gdm login window.

Now here's the problem: The second USB mouse works great, but for the
second USB keyboard it is only possible to do one ore two key strokes,
then the keyboard is dead. When rebooting the virtual machine, then i can
again type one or two letters before the keyboard stops operations.

Another observation is that the physical computer got pretty unstable
after adding the PCI USB controller - so i guess that hardware is broken?

Any ideas?

regards

Bernhard
JaXXoN is offline   Reply With Quote
Old 04-27-06, 07:14 AM   #2
JaXXoN
Registered User
 
Join Date: Jul 2005
Location: Munich
Posts: 910
Default Re: nv-1.0-8756 in xenU domain working!

Hi!

just to keep you in the loop (if interessted): instead of using a
second USB controller, i added a PS2 mouse and a PS2 keyboard
for the xen0 domain and used the the onboard USB controller
for the xenU domain exclusively.

It's now possible to play UT2004 at the same time at both
consoles (xen0 and xenu) with decent frame rates (30-50 fps)
.

However, there are two issues left:

* i can't get german keyboard layout working (i guess it has something
to do with the mandatory "evdev" driver).

* When shutting down the xenU domain, then the system gets stuck
(mouse pointer on the X-Server in xen0 still moves) with a spinlock bug
(i'll try to capture the kernel log and post it at a later time).

regards

Bernhard
JaXXoN is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:40 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.