Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-28-06, 03:09 AM   #1
kimxk
Registered User
 
kimxk's Avatar
 
Join Date: Apr 2006
Posts: 18
Default "Compiz: No RandR Extension" and no DBE

Hi,

I just jumped ship from the ATI camp and am having a small problem.

Whenever I try to run Compiz it throws the above error.

The wierd thing is that xdpyinfo says no randr extemsion is loaded, but the xorg log (from startx -- -logverbose 5) says it is.

Any ideas?
Attached Files
File Type: txt xdpyinfo.txt (21.4 KB, 166 views)
File Type: zip nvidia-bug-report.zip (27.4 KB, 159 views)

Last edited by kimxk; 04-28-06 at 10:38 PM.
kimxk is offline   Reply With Quote
Old 04-28-06, 06:13 AM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Compiz: No RandR Extension

XGL is an Xserver running on top of another Xserver. The 'first' Xserver uses the nvidia drivers for 2d rendering and supports lots of extensions like GLX, Xv, RandR and so on. The XGL server only uses the 'first' server for rendering and input. If you want to use an extension like RandR the XGL server must implement this extension. Right now XGL only implements a few extensions like Xv and GLX. (The GLX is not the GLX from the 'first' Xserver)

So the problem you are seeing is normal and is not related to the nvidia drivers but to the working of XGL. If you need RandR, disable XGL.

I would just wait till the nvidia drivers support AIGLX (compiz is ported to it) and then you will have RandR support. (AIGLX doesn't suffer from the extension issue as you only use one Xserver which is directly rendered using the nvidia drivers)
Thunderbird is offline   Reply With Quote
Old 04-28-06, 10:36 PM   #3
kimxk
Registered User
 
kimxk's Avatar
 
Join Date: Apr 2006
Posts: 18
Default Re: Compiz: No RandR Extension

OK,

Thanks for that, but I think I have another problem along the same lines.

I run conky and it's telling me that it can't find the double buffer extension. The Xorg log shows that it has loaded, but again xdpyinfo doesnt.
kimxk is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM
RH7.3 and nForce - can't find the module dmw400 NVIDIA Linux 4 08-05-02 12:14 PM

All times are GMT -5. The time now is 12:11 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.