Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-29-06, 08:57 PM   #1
jaaason
Registered User
 
Join Date: Sep 2004
Location: USA
Posts: 8
Question no X on XFX GeForce 6600 PCIe second DVI jack

My XFX GeForce 6600 has two DVI jacks and an S-Video jack. Using the nvidia driver, I can't get X working on the DVI jack on the right (as seen on the back of my tower case). The left one works fine. This is a big issue for me, because this system is both my workstation and my home theater box. My previous VGA/DVI AGP card worked great for it, but I don't want to go back to that Pentium 4 now.

"X not working" in this post means I'm in runlevel 3, I run 'startx', the screen says "No Signal", but X keeps running happily until I do Ctrl-Alt-Backspace. X believes it started correctly, but neither the monitor or projector think there is a signal.

I hope all the relevant details are below. The bug reports are attached, one from the working left jack and one from the non-working right jack.

XFX GeForce 6600 256MB Extreme Edition PCIe
Dell 1905FP flat panel monitor 1280x1024max, usually on a VGA cable
Canon LV-7350 lcd projector 1024x768max, usually on a DVI cable
Gigabyte GA-K8N Pro-SLI motherboard, latest bios (F8)
Athlon64 X2 4200
nvidia-1.0-8756
Custom kernel 2.6.16.7
All 32-bit FC4 software
No overclocking of anything

Works
1. Console mode (runlevel 3) on either jack, with either cable, with either monitor or projector
2. The nvidia driver on the left DVI jack with either cable with either monitor or projector
3. The nv driver allows me to use either jack with either cable with either monitor or projector. The projector doesn't work unless the computer is booted without the monitor connected.
4. Both DVI jacks work with the monitor and projector in Windows XP.

Doesn't Work
1Bad. X on right DVI jack with DVI cable or VGA cable, monitor or projector
2Bad. The same problem occurs with kernel 2.6.15.6 and nvidia-1.0-8178 or 7676.
3Bad. Taking out all other cards didn't help.
4Bad. Disabling EDID with "Option "UseEDID" "false"" shows "(**) NVIDIA(0): Ignoring EDIDs (II) NVIDIA(0): Not probing EDID on DFP-0.", but still won't validate any modes.
5Bad. Disabling EDID and adding "Option "ExactModeTimingsDVI" "true"" doesn't check modes at all, and there are no errors in the log, but my projector still says No Signal.
6Bad. Rebooting with the monitor and projector both turned on and connected, only one connected, using different cables in every configuration, doesn't help.
7Bad. I started X on the projector with the left jack and ran xvidtune -show to get the modeline. I set that up in the Monitor section of xorg.conf. I tried to start X on the projector on the right jack, but it didn't work. No signal.
8Bad. Setting HorizSync and VertRefresh to the proper values for the monitor or projector didn't help.
9Bad. BIOS VGA settings: Auto, Fast, and Turbo

Theories
-Configuration problem: Of course, this is always the most likely case. Please, someone give me the magic configuration keyword to fix it.
-Video card problem: No one else has reported this problem, so maybe it's a card problem.
-nvidia driver problem: EDID doesn't seem to work on the right DVI jack with the nvidia driver, but it does with the nv driver.
Attached Files
File Type: zip logs.zip (51.0 KB, 118 views)
jaaason is offline   Reply With Quote
Old 04-29-06, 09:13 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: no X on XFX GeForce 6600 PCIe second DVI jack

I have a few questions:
0) Is there a reason why you're using the ConnectedMonitor option (and setting it to a CRT, which you've stated you aren't using)?
1) I'm confused why you have two bug reports. Are you running two instances of X? If so, are you opposed to running one X server with either two separate X screens or TwinView and/or Xinerama ?
2) Does this problem reproduce with an official FC4 kernel?

Please start X (for whatever configuration has been failing), without the ConnectedMonitor option, with the following command:
startx -- -logverbose 6

and then generate and post an updated bug report for review.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 04-30-06, 12:44 PM   #3
jaaason
Registered User
 
Join Date: Sep 2004
Location: USA
Posts: 8
Smile Re: no X on XFX GeForce 6600 PCIe second DVI jack

That's it! Removing the ConnectedMonitor option allows the Dell monitor to work on the right DVI jack. TwinView works as well, when I plug in the projector to the left jack.

There is still a hardware/software problem, because starting X with the projector connected to the right DVI jack causes a kernel oops. It isn't a problem for me, though, since the monitor works.

That option forced it to use the desired device when I had both connected. The Dell flat panel was seen as a CRT by the driver, because I used a VGA cable (I guess).

Thanks, Lonni! Thanks for helping everyone else on this forum, too, because I see you've answered a lot of questions at all hours. This is the responsive support the community needs. I hope it will lead to better software and documentation.
jaaason is offline   Reply With Quote
Old 04-30-06, 01:55 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: no X on XFX GeForce 6600 PCIe second DVI jack

There is currently a known bug with 1.0-8756, where starting X in TwinView with two DFPs (both DVI) will trigger a kernel Oops.

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
What You Can Expect From GeForce GRID News Archived News Items 0 06-04-12 04:20 PM
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 11:40 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.