Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-13-06, 11:39 AM   #1
linuxham
Registered User
 
Join Date: May 2006
Posts: 3
Default Debian Sid and Nvidia drivers not working

I tried d/l the latest 8756, and the nvidia debs, nothing will get GLX working. Using kernel 2.6.16-1-k7 and xorg. When I install the Nvidia driver, it completes without any error messages, but does not update my xorg.conf file. I have tried nvidia-xconfig from Debian, and it does create an Nvidia xorg.conf, but X won't boot. Video card is a PCI GeForce 5200. What can I do now?

Thanks!
linuxham is offline   Reply With Quote
Old 05-13-06, 01:32 PM   #2
juergen8
Registered User
 
Join Date: May 2006
Posts: 1
Default Re: Debian Sid and Nvidia drivers not working

you'll have to configure your xorg.conf manually. anyway, more details would be useful. you should provide your Xorg.log which is /var/log/Xorg.0.log here (also debian sid).
juergen8 is offline   Reply With Quote
Old 05-13-06, 04:53 PM   #3
fs3rp4
Registered User
 
Join Date: May 2006
Location: Latvéria
Posts: 1
Default Re: Debian Sid and Nvidia drivers not working

Quote:
Originally Posted by juergen8
you'll have to configure your xorg.conf manually. anyway, more details would be useful. you should provide your Xorg.log which is /var/log/Xorg.0.log here (also debian sid).
Look this.

http://wiki.debian.org/Xorg69To7?highlight=%28nvidia%29


If installing the original nvidia drivers from the nvidia.com drivers download page with the official driver script, use --x-module-path=/usr/lib/xorg/modules/. Otherwise not only the driver itself will be installed in /usr/X11R6/lib64/modules/drivers or /usr/X11R6/lib/modules/drivers, but also the OpenGL
libraries might not work.
fs3rp4 is offline   Reply With Quote
Old 05-13-06, 10:43 PM   #4
linuxham
Registered User
 
Join Date: May 2006
Posts: 3
Default Re: Debian Sid and Nvidia drivers not working

I installed the 8756 drivers with the --x-module-path=/usr/lib/xorg/modules/, and used nvidia-xconfig from Debian to create the xorg.conf, and have attached the nvidia install log, and the Xorg.0.log. It seems that glcore is at fault. I installed x11proto-gl-dev to get glcore.h, but no good. Xwindows works, but module glx doesn't get loaded. Any pointers?

Thanks again for the help.
linuxham is offline   Reply With Quote
Old 05-13-06, 11:19 PM   #5
linuxham
Registered User
 
Join Date: May 2006
Posts: 3
Default Re: Debian Sid and Nvidia drivers not working

The internet at my home is really really slow. I Googled on GLcore, found that it was libGLcore, and that it came from nvidia-glx-dev, so I installed it. Wine won't play any games, but native games like bzflag work, so I think my driver problems are over, and now onto wine upgrading.
linuxham is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian sid w/ nForce - X won't start questioncolon NVIDIA Linux 16 08-05-02 11:35 AM

All times are GMT -5. The time now is 11:12 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.