Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-02-06, 07:53 AM   #1
rafter
Registered User
 
Join Date: Mar 2006
Posts: 6
Default blank glxgears windown on GeForce 6150

I have an A8N-VM CSM motherboard with a builtin GeForce 6150 chip and an AMD X2 3800+ cpu. I have the latest nvidia drivers installed and X is running fine.

When I run glxgears I get a blank (black) window and one of my CPUs running full tilt. I get no spinning gears and no framerate reports from glxgears. Has anyone seen this or know how to deal with it?

bug-report attached (in 2 parts).
Attached Files
File Type: log nvidia-bug-report.1.log (43.7 KB, 153 views)
File Type: log nvidia-bug-report.2.log (75.6 KB, 126 views)
rafter is offline   Reply With Quote
Old 03-02-06, 08:52 AM   #2
gerick
Registered User
 
gerick's Avatar
 
Join Date: Oct 2005
Location: San Antonio, TX
Posts: 40
Default Re: blank glxgears windown on GeForce 6150

Do you have Load "glx" in your Section "Module" of xorg.conf?
gerick is offline   Reply With Quote
Old 03-02-06, 04:42 PM   #3
rafter
Registered User
 
Join Date: Mar 2006
Posts: 6
Default Re: blank glxgears windown on GeForce 6150

Yep.

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection
rafter is offline   Reply With Quote
Old 03-02-06, 06:19 PM   #4
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: blank glxgears windown on GeForce 6150

I have A8N-VM CSM mainboard and glxgears works well.
Make sure you use Nvidia OpenGL libs:
glxinfo | grep vendor

If you are using composite extension, enabling AllowGLXWithComposite option can help.
zbiggy is offline   Reply With Quote
Old 03-02-06, 08:14 PM   #5
rafter
Registered User
 
Join Date: Mar 2006
Posts: 6
Default Re: blank glxgears windown on GeForce 6150

I don't have X access to the machine right now but I know for a fact that glxgears | grep vendor lists the nvidia drivers (I did this last night for someone on IRC).

timl@penrose:~$ grep vendor nvidia-bug-report.log
...
(II) Module glx: vendor="NVIDIA Corporation"
...
(II) Module nvidia: vendor="NVIDIA Corporation"
...
rafter is offline   Reply With Quote
Old 03-03-06, 05:29 AM   #6
rafter
Registered User
 
Join Date: Mar 2006
Posts: 6
Default Re: blank glxgears windown on GeForce 6150

timl@penrose:~$ glxinfo | grep vendor
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation
rafter is offline   Reply With Quote
Old 05-12-06, 03:20 AM   #7
rafter
Registered User
 
Join Date: Mar 2006
Posts: 6
Default Re: blank glxgears windown on GeForce 6150

I've upgraded to the latest drivers (1.0-8756) and I am still having the same problem. Can anyone offer any advice?

timl@penrose:~% glxgears -printfps
1378 frames in 5.0 seconds = 275.464 FPS
1343 frames in 5.0 seconds = 268.441 FPS
1360 frames in 5.0 seconds = 271.945 FPS
1345 frames in 5.0 seconds = 268.838 FPS


Cheers.
Attached Files
File Type: log nvidia-bug-report.log (96.8 KB, 121 views)
rafter is offline   Reply With Quote
Old 05-12-06, 11:34 AM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: blank glxgears windown on GeForce 6150

Are you experiencing problems with anything other than glxgears?

You may want to try updating your BIOS. The motherboard that you're using has been discussed quite extensively in other threads on this forum, and has some known problems in older BIOS versions.

Thanks,
Lonni
netllama is offline   Reply With Quote

Old 05-14-06, 12:12 AM   #9
rafter
Registered User
 
Join Date: Mar 2006
Posts: 6
Default Re: blank glxgears windown on GeForce 6150

I have just installed the latest BIOS but it hasn't changed anything.

I experience the same problem when using mplayer. If I use the default video output all I get is a black window (sound, etc continues to play as expected) but if I use the -vo x11 option (which does not use hardware acceleration) it plays fine.

Are there any other programs which make use of the card which I could test with?

I've read a stack of the other threads on this motherboard but noone else seems to have this particular problem and none of the advice provided has done the job.
rafter is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 11:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.