Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-01-06, 08:35 AM   #1
sime2
Registered User
 
Join Date: Jun 2006
Posts: 4
Default 1.0-8762 reboots my laptop

I have Toshiba Qosmio F10-101. It's an Intel Centrino laptop with GeForce Go5700 graphics card.
I'm using nvidia driver version 1.0-7676 and it works great.
Unfortunatelly driver versions 1.0-8xxx don't work.
1.0-8762 reboots my laptop. When I start X, screen goes blank, stays that way for a couple of seconds, and then it reboots. FreeBSD has to fsck after that. I'm using NVidia's builtin AGP driver (nvAGP). agp.ko is not loaded.
There is nothing in the logs: nothing in /var/log/messages, nothing in /var/log/Xorg.0.log
I'm using latest FreeBSD/i386 6.1-STABLE and latest version of ports (Xorg 6.9.0).
sime2 is offline   Reply With Quote
Old 06-01-06, 11:33 AM   #2
Harvey Pooka
Registered User
 
Join Date: Jan 2004
Posts: 53
Default Re: 1.0-8762 reboots my laptop

Please post your xorg.conf and whatever changes you made to loader.conf and device.hints.
Harvey Pooka is offline   Reply With Quote
Old 06-04-06, 01:23 PM   #3
sime2
Registered User
 
Join Date: Jun 2006
Posts: 4
Default Re: 1.0-8762 reboots my laptop

I am using default device.hints.
Here is my /boot/loader.conf:
linux_load="YES"
nvidia_load="YES"
linprocfs_load="YES"
geom_label_load="YES"

I have tried both custom kernel and GENERIC kernel from 6.1-RELEASE with same results.
sime2 is offline   Reply With Quote
Old 06-04-06, 01:32 PM   #4
sime2
Registered User
 
Join Date: Jun 2006
Posts: 4
Default Re: 1.0-8762 reboots my laptop

These are "Module" and "Device" sections of my xorg.conf:
Section "Module"
Load "extmod"
Load "glx"
Load "dbe"
Load "xtrap"
Load "type1"
Load "freetype"
EndSection
Section "Device"
Option "NoLogo" "True"
Option "FlatPanelProperties" "Scaling=aspect-scaled,Dithering=enabled"
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "Unknown Board"
BusID "PCI:1:0:0"
EndSection
sime2 is offline   Reply With Quote
Old 06-05-06, 11:40 AM   #5
Harvey Pooka
Registered User
 
Join Date: Jan 2004
Posts: 53
Default Re: 1.0-8762 reboots my laptop

Do you have AGP compiled in your custom kernel, or are you disabling FreeBSD's AGP driver in /boot/device.hints? I just want to make certain it is really disabled.

Other things to try:
Comment out the FlatPanelProperties option to see if it gets further. Maybe EDID is not correctly evaluating your monitor.

What does pciconf -lv show you for your graphics card? This should at least show if the driver is attaching to your card. Also, check the output of /var/run/dmesg.boot for nvidia0 lines.
Harvey Pooka is offline   Reply With Quote
Old 06-06-06, 11:55 AM   #6
sime2
Registered User
 
Join Date: Jun 2006
Posts: 4
Default Re: 1.0-8762 reboots my laptop

agp is not compiled in the custom kernel, and agp.ko module is not loaded.
Removing FlatPanelProperties didn't change anything.
Running 'pciconf -vl' shows that nvidia driver is attached to the graphics card.
sime2 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
302.11 driver only allows native resolution settings of laptop DFP darinmiller NVIDIA Linux 2 05-30-12 03:45 PM

All times are GMT -5. The time now is 01:00 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.