Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-16-06, 01:28 PM   #1
ZicoTheTux
Registered User
 
Join Date: May 2004
Posts: 182
Default SuSE10.1/kernel-2.6.16.13 performance drop

Referring to my last thread I now start a new because of the different problem I have now.

As you read in the topic the problem occurs in SuSE 10.1 with kernel 2.6.16.13(-4-default). It affects the 32Bit as well as the 64Bit version.
Since I updated to this system I have a slightly performance drop on all applications.
Before I had SuSE 10.0. My CPU is an AMD 3500+ and my GPU is a GeForce 6800Ultra.
Glxgears dropped from 16000 to 13800. Games like Doom3 or Quake4 lost approx 10 FPS.
I tested with a patched 8174 and the newest 8756 driver. And of course I do NOT have XGL activated.

Ok, I don't want to blame NVidia for this problem but as you probably know SuSE 10.1 has many new changes and a newer kernel. And since I don't find any help in SuSE specific forums I try to find help here.

Does anybody know about a bottleneck in this new SuSE version? Any processes, modules or daemons to switch off? Or is probably the kernel the bottlenack here? Anybody knows some kernel options to try out or something else?
I would try everything to get this working again.

Some more information:
XGL: NO
NvAGP: tried out every option (of course disabled agpgart when using NvAGP)
FSAA and FSAF: Off
top doesn't show any apps eating CPU.

I'm running out of ideas.
But I always found help here and I know someone is able to help me out of my misery.

Thank you
ZicoTheTux is offline   Reply With Quote
Old 05-16-06, 04:59 PM   #2
gnutux
Linux User: 362616
 
Join Date: Oct 2005
Location: Toronto, Canada
Posts: 108
Default Re: SuSE10.1/kernel-2.6.16.13 performance drop

yup, I can confirm that as well. On 10.1 I have FPS only up to 1500 (via glxgears). On 10.0 I use to get like 2000+ FPS.

gnutux
__________________
Specs: AsusTek P4B533-VM, Intel Pentium 4 2533MHz, 120 GB HDD Maxtor, 80 GB HDD WD, 1GB PC3200 RAM, NVIDIA GeForce 6600, openSUSE 10.2 (Main), MacOS X 10.4.5 (leisure use, backup)
gnutux is offline   Reply With Quote
Old 06-14-06, 12:35 PM   #3
relativity
Registered User
 
Join Date: Nov 2004
Location: Amsterdam
Posts: 4
Default Re: SuSE10.1/kernel-2.6.16.13 performance drop

Thsi will not really help you, but it gives support to the problem of performance drop under SUSE 10.1
Running Dell desktop (intel 32bits 2.4 Ghz Xeon, TI4600). I kept track of the glxgears fps rate over the last year for various releases of Nvidia drivers running suse 9.1. The fps rate was always at the 7400+ level.
Following my upgrade to suse 10.1 it dropped by almost 40% from ~7400 to ~4600 fps. I tried with the same Nvidia driver as used previously under Suse 9.1 - same drop.
I had used kernel 2.6.16 under suse 9.1 and rebuild/ran that again under 10.1 - same drop as with regular kernel.

I know glxgears is a lousy graphics benchmark as it is CPU bound, and one must be cautious not to have cpu hungry processes in the background.For that I use gkrellm (and top) to monitor CPU activity.

My first thought was Xorg (which is new for me in this Suse release ) to be guilty of this. But reading above comments I fear something else is going on.

Regards
relativity is offline   Reply With Quote
Old 06-14-06, 02:08 PM   #4
cdrw
Registered User
 
Join Date: Mar 2006
Posts: 59
Default Re: SuSE10.1/kernel-2.6.16.13 performance drop

Are you running glxgears with closed window?

Anyway, since suse 10.0 64-bit and the same video card (6600GT) I have not noticed any performance drop (9.x had different video card).
cdrw is offline   Reply With Quote
Old 06-14-06, 04:54 PM   #5
marchetto
Registered User
 
Join Date: Mar 2005
Posts: 205
Default Re: SuSE10.1/kernel-2.6.16.13 performance drop

It's clear that nVidia driver is not working properly on SuSE 10.1
marchetto is offline   Reply With Quote
Old 06-24-06, 10:10 AM   #6
relativity
Registered User
 
Join Date: Nov 2004
Location: Amsterdam
Posts: 4
Default Re: SuSE10.1/kernel-2.6.16.13 performance drop

Good news!

I found the reason for the performance drop ! (at least in my case).

It appears that during installation of SUSE 10.1, the deault color depth had been automatically chosen as 24, as opposed to the 16 in my previous installation (suse 9.1, XFree86).
Once i set the DefaultDepth in /etc/X11/xorg.conf back from 24 to 16, I found similar glxgears FPS values as in the past!

In fact I observed a slight performance INCREASE of some 1.5 %.

Regards,
R.
relativity is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video: Xyratex ' The Next Gen in Storage Performance and Efficiency News Archived News Items 0 06-17-12 09:50 AM
Boost Your Performance Goals 10x ' This Week on inside* Publications News Archived News Items 0 05-13-12 05:20 PM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
so let's try this again in the new forum - bad performance with correctly inst.driver neutrino NVIDIA Linux 11 08-01-02 04:19 PM

All times are GMT -5. The time now is 09:20 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.