Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-12-06, 05:08 PM   #1
coec
Registered User
 
Join Date: Jul 2006
Posts: 34
Default Disappearing mouse pointer

Hi all

Apologies if this has been asked and answered before as I've googled but not found an answer.

My problem is that I'm using a dual video card setup (two Nvidia Quadro 4500) and three CRT monitors. I've setup stereo at 1280x1024@110Hz and all looks fine until you move the mouse pointer onto the third monitor as it disappears. Moving the mouse back to either of the first two monitors and the mouse point re-appears. In the third window when I click and drag the left mouse button I can see a rectanglar selection, so the mouse is there I just can't see it.

This is a HP xw9300, 32GB RAM, two Quadro FX 4500 with a GSync card using version 1.8672 of the Nvidia Linux driver and RHEL 3u7 Workstation.

XFree86 -version
XFree86 Version 4.3.0 (Red Hat Enterprise Linux 3 release: 4.3.0-98.EL)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.9-22.18.bz155725.ELsmp x86_64 [ELF]
Build Date: 28 November 2005
Build Host: hs20-bc1-3.build.redhat.com

My XF86Config file is:
---
Section "ServerLayout"
Identifier "3_screen_stereo"
Screen "Screen TwinView-1" 0 0
Screen 1 "Screen Display-2" RightOf "Screen TwinView-1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
Option "Stereo" "3"
Option "Xinerama" "1"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/X11R6/lib/X11/fonts/local/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "unix/:-1"
EndSection

Section "Module"
Load "dbe"
Load "glx"
Load "extmod"
Load "type1"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "AutoRepeat" "250 30"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "yes"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Sun21"
VendorName "Sun"
ModelName "Sun 21-inch N3"
HorizSync 30.0 - 96.0
VertRefresh 48.0 - 160.0
Option "dpms"
Modeline "1280x1024" 211.22 1280 1376 1520 1760 1024 1025 028
1091 -HSync +Vsync
EndSection

Section "Device"

# Primary PCI-express slot
Identifier "NV_PCI_Express1"
Driver "nvidia"
VendorName "nvidia"
BoardName "Unknown video card"
BusID "PCI:10:0:0"
Option "ModeValidation" "NoMaxPClkCheck, NoEdidMaxPClkCheck"
EndSection

Section "Device"

# 2nd PCI-express slot
Identifier "NV_PCI_Express2"
Driver "nvidia"
VendorName "nvidia"
BusID "PCI:129:0:0"
Option "ModeValidation" "NoMaxPClkCheck, NoEdidMaxPClkCheck"
EndSection

Section "Screen"
Identifier "Screen TwinView-1"
Device "NV_PCI_Express1"
Monitor "Sun21"
DefaultDepth 24
Option "Stereo" "3"
Option "ForceStereoFlipping" "1"
Option "TwinView"
Option "TwinViewOrientation" "RightOf"
Option "MetaModes" "1280x1024 +0+0, 1280x1024 +1160+0"
SubSection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen Display-2"
Device "NV_PCI_Express2"
Monitor "Sun21"
DefaultDepth 24
Option "Stereo" "3"
Option "ForceStereoFlipping" "1"
Option "MetaModes" "1280x1024 +0+1160"
SubSection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
EndSection
---

Any ideas?

CC
coec is offline   Reply With Quote
Old 07-12-06, 05:19 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Disappearing mouse pointer

Please generate and post an nvidia-bug-report.log while this problem is present.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 07-12-06, 06:43 PM   #3
coec
Registered User
 
Join Date: Jul 2006
Posts: 34
Default Re: Disappearing mouse pointer

I've generated the bug report but had to split it so it is under the maximum upload size.

Thanks

CC
Attached Files
File Type: log nvidia-bug-report.log (62.5 KB, 117 views)
File Type: log nvidia-bug-report2.log (49.4 KB, 108 views)
coec is offline   Reply With Quote
Old 07-12-06, 07:12 PM   #4
coec
Registered User
 
Join Date: Jul 2006
Posts: 34
Default Re: Disappearing mouse pointer

Apologies, I generated the previous bug report remotely (via ssh). The attached files should be better...
Attached Files
File Type: log nvidia-bug-report.log (73.9 KB, 116 views)
File Type: log nvidia-bug-report2.log (57.6 KB, 111 views)
coec is offline   Reply With Quote
Old 07-13-06, 06:30 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Disappearing mouse pointer

The only thing that I see that looks a bit odd is you're requesting a MetaMode on the 2nd videocard, without using TwinView:
(**) NVIDIA(1): Option "MetaModes" "1280x1024 +0+1160"

Does this problem persist if you comment out that MetaMode?
Have you tried specifying the offset for the 3rd display in the ServerLayout section?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 07-13-06, 07:37 PM   #6
coec
Registered User
 
Join Date: Jul 2006
Posts: 34
Default Re: Disappearing mouse pointer

Many thanks Lonni, that did the trick.
coec is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
5 button mouse drivers for Win9x Pafet General Hardware 6 10-07-02 10:46 AM
Doh, M$ Optical Intellimouse Explorer not good for games Creole General Hardware 18 09-28-02 09:55 PM
Microsoft Mouse NeoGeo General Hardware 13 09-16-02 01:47 PM
windows 98/xp mouse screw'up's ThoriN General Software 3 08-24-02 09:45 PM
The case of the disappearing shadows legion88 NVIDIA GeForce 7, 8, And 9 Series 19 08-23-02 07:13 PM

All times are GMT -5. The time now is 03:38 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.