Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-24-06, 04:00 PM   #1
kaihp
Registered User
 
Join Date: Jul 2006
Posts: 4
Default Installation woes with FC5_x86_64 & Asus A8N-VM CSM board

I'm having problems with installing both the 1.0-8762 Graphics driver (patched according to http://www.nvnews.net/vbulletin/showthread.php?t=72488) as well the 1.0-5336 nFORCE driver on my new ASUS A8N-VM CSM based system.

Hardware: AMD64 3500+ CPU, ASUS A8N-VM CSM mobo, 2x512MB DRAM, 4x250G Seagate NL35 discs, DVD-RW drive, floppy drive. System is fairly cool (CPU never above 40 degrees C with Zalman CNPS-7700Cu fan)

The system has been freshly installed from the official FC5 x86_64 DVD image. In it's virgin state, the forcedeth network driver didn't work, and the USB mouse stop working as soon as the X login screen appears

The nFORCE driver package correctly installed the network driver, but both the audio and the graphics drivers failed. After getting a network connection, the kernel-devel, pkgconfig, and xorg-x11-server-sdk packages were installed and the system rebooted.

From the log files (attached inside the .zip file due to size), it appears that both drivers are looking for the kernel symbol print_tainted() which doesn't exist. The nvidia-bug-submit.log is from the Graphics driver distro.

I've tried installing against both the plain 2.6.15 kernel from the DVD as well as the latest 2.6.17.1 kernel from the FC5 sites (yum update kernel kernel-devel)

(and yes, I've read http://www.nvnews.net/vbulletin/showthread.php?t=46678 )

Any ideas are most welcome,

Kai
Attached Files
File Type: zip nvidia-bug-report.zip (37.6 KB, 124 views)
kaihp is offline   Reply With Quote
Old 07-24-06, 04:03 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installation woes with FC5_x86_64 & Asus A8N-VM CSM board

See: http://www.nvnews.net/vbulletin/showthread.php?t=72490
netllama is offline   Reply With Quote
Old 07-24-06, 04:24 PM   #3
kaihp
Registered User
 
Join Date: Jul 2006
Posts: 4
Default Re: Installation woes with FC5_x86_64 & Asus A8N-VM CSM board

Quote:
Originally Posted by netllama
Thanks Lonnie, but I already did that. SElinux is disabled.

Kai
kaihp is offline   Reply With Quote
Old 07-24-06, 04:27 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installation woes with FC5_x86_64 & Asus A8N-VM CSM board

According to your bug report, you're still running a kernel which doesn't support non-GPL'd drivers. This means that you didn't follow all the instructions in the post I referenced.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 07-24-06, 05:07 PM   #5
kaihp
Registered User
 
Join Date: Jul 2006
Posts: 4
Default Re: Installation woes with FC5_x86_64 & Asus A8N-VM CSM board

Quote:
Originally Posted by netllama
According to your bug report, you're still running a kernel which doesn't support non-GPL'd drivers. This means that you didn't follow all the instructions in the post I referenced.
Could you speak a little plainer? - are you refering here to the specific kernel version here, or the fact that "yum update" will update all packages on the system?

If it's the kernel version you are refering to, could to recommend a "known-good" version - the driver compiles barfed on missing the MODULES_PARM macro on 2.6.17_1 :-/

Anyhoo, I'm downloading and installing 319 packages (~˝GB) at the moment. I'll get back with an update in the morning (time for bed here in .dk).
kaihp is offline   Reply With Quote
Old 07-24-06, 05:09 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installation woes with FC5_x86_64 & Asus A8N-VM CSM board

I'm referring to the 'yum update' step which provides a kernel which will work with non-GPL'd drivers.

The nvidia X driver works fine on a kernel.org 2.6.17 kernel.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 07-25-06, 12:38 AM   #7
kaihp
Registered User
 
Join Date: Jul 2006
Posts: 4
Default Re: Installation woes with FC5_x86_64 & Asus A8N-VM CSM board

Quote:
Originally Posted by netllama
I'm referring to the 'yum update' step which provides a kernel which will work with non-GPL'd drivers.
The nvidia X driver works fine on a kernel.org 2.6.17 kernel.
Great! - After doing the full "yum update" and a reboot into the 2.6.17_1.2157_FC5 kernel, I was able to install the nvidia graphics driver correctly. I let nvdiia-xconfig do it's magic. I tried to just do an "init 5" to get back to X, but that still left my mouse non-functional. A full reboot solved the issue, and I'm now typing this from the Linux system rather than my XP boxen.

But the nForce drivers still won't install.
Lonnie, do I need to compile a fresh kernel from kernel.org to get nvnet and nvaudio running? I've attached the log files from the install and bug-report scripts.

Thanks for your help,

Kai
Attached Files
File Type: zip nforce-bug-report.zip (21.2 KB, 104 views)
kaihp is offline   Reply With Quote
Old 07-25-06, 10:44 AM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installation woes with FC5_x86_64 & Asus A8N-VM CSM board

The NFORCE driver package is unsupported in FC5. See:
http://www.nvnews.net/vbulletin/showthread.php?t=73925
netllama is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:27 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.