Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-28-06, 12:34 PM   #1
sonicx
Registered User
 
Join Date: Jul 2006
Posts: 18
Default crashes over and over: Centos 4 amd64 smp with 7800GS + 8762

hy,
i just got my 7800gs and tried to install it. before a 4200Ti using same driver version ran fine. i put in the new card, connected its power cable, deinstalled the drivers, installed em again, system boots and loads nvidia module, and even runs glxgears and glxinfo quite nicely. but, as soon as i start something bigger using opengl, the system hangs and then immediatly reboots. i searched around on this forum, but none of the solutions i found did it. what i did:
installed drivers over and over again,
tried disabling acpid and selinux,
tried different games, settings and driver settings,
deactivated advanced bios features,
quake 4 wont run at all, it gives me this output:
--------------- R_InitOpenGL ----------------
Initializing SDL subsystem
Loading GL driver 'libGL.so.1' through SDL
SDL_ListModes:
1280 x 1024
800 x 600
640 x 480
SDL_ListModes are currently ignored for resolution filtering. Set r_useSDLModes to 1 if you want it
WARNING: SDL_SetVideoMode failed: Couldn't find matching GLX visual
Initializing SDL subsystem
Loading GL driver 'libGL.so.1' through SDL
SDL_ListModes:
1280 x 1024
800 x 600
640 x 480
SDL_ListModes are currently ignored for resolution filtering. Set r_useSDLModes to 1 if you want it
WARNING: SDL_SetVideoMode failed: Couldn't find matching GLX visual
--------------- BSE Shutdown ----------------
---------------------------------------------
WARNING: rvServerScanGUI::Clear() - invalid scanGUI

idRenderSystem::Shutdown()
Sys_Error: Unable to initialize OpenGL

===========

my xorg log contains no EEs but the following warnings:

(WW) Open ACPI failed (/proc/acpi/event) (Device or resource busy)
(WW) NVIDIA(0): No valid modes for "1024xx768"; removing.
(WW) NVIDIA(0): No size information available in DFP-0's EDID; cannot compute
(WW) NVIDIA(0): DPI from EDID.


i am totally stuck here. my system:

dual opteron 246 on tiger k8w
gainward 7800GS+
Centos 4,Xorg 6.9.?, nvdrv 1.0-8762
2.6.16-ck3.amd64smp (custom,worked with nvdrivers before)


if needed i can post more logs, this is what seemed usefull to me. hm, ill put a part of my glxinfo output at the end. hope someone has a solution before i lost all my hair over this. before the system ran fine...
mfg
sonicx



glxinfo says:
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 7800 GS/AGP/SSE2
OpenGL version string: 2.0.2 NVIDIA 87.62
glu version: 1.3
sonicx is offline   Reply With Quote
Old 07-28-06, 05:02 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: crashes over and over: Centos 4 amd64 smp with 7800GS + 8762

Please generate and post an nvidia-bug-report.log.

Also, other than quake4, what else have you tried to run that is crashed the system?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 07-28-06, 05:31 PM   #3
sonicx
Registered User
 
Join Date: Jul 2006
Posts: 18
Default Re: crashes over and over: Centos 4 amd64 smp with 7800GS + 8762

hy,
thank you for your quick reply. games ive tried besides q4:
quake3 - hangs, reboots
quake 2 - crashes, or gives out errors similar to q4
quake 2 - with glx driver - runs like a charm!
doom3 - same as q3

glxgears - runs smoothly
SPECview8.1 - same as d3
gl screensavers - same as d3
xine, xv driver - nice

if first excpected a hw error, but seeing glxgears and q2 in glx mode run so smoothly makes me think this will be problem with my systems config. i am downloading a version of kubuntu for the case this just doesnt work, although id really like not to reinstall as this is a server system, which also makes the crashes quite inconvenient. ill try some more opengl stuff maybe i can produce something usefull. a bugreport is attached. thanks for your attention.
tata
sonicx
Attached Files
File Type: zip nvidia-bug-report.log.ZIP (21.0 KB, 117 views)
sonicx is offline   Reply With Quote
Old 07-28-06, 06:17 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: crashes over and over: Centos 4 amd64 smp with 7800GS + 8762

I'm not able to reproduce this problem on the Tyan S2885 motherboard that I have here when running SPEC Viewperf-8.1.

I have a few questions:
0) Does this also reproduce with an official RHEL4 kernel?
1) Why are you disabling acpi on this system?
2) It looks like you've upgraded X to 6.9, rather than using what ships with Centos4. I'd be curious whether this crash reproduces with the Xorg that ships with Centos4.
3) Does this reproduce if you update to the latest BIOS for the motherboard?
4) Are you able to setup a serial console to capture the crash output?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 07-29-06, 09:01 AM   #5
sonicx
Registered User
 
Join Date: Jul 2006
Posts: 18
Default Re: crashes over and over: Centos 4 amd64 smp with 7800GS + 8762

thanks for your reply lonni. i wrote last night,but i took to long and it ate my message, well, i made a partial progress, i reinstalled SDL, SDL_net, SDL_image, SDL_mixer and now q4,planeshift,d3 and some more start, but crash during play, but not randomly. d3 for example runs all testmaps, but crashes directly when entering a real map. quake4 always crashes when for example hitting a certain area in the second level. planeshift crashes the sys when just joined the server and first game frames are visible, but the menu viewed correctly before is also made in gl. confusing.
your questions:
0) I dont know, and am currently not able to test this as this system is configured to the custom kernel and will not boot with the stock kernel. the custom kernel is a newer kernel then stock with applied ck kernel patches and preemp conf. it is needed for a solid realtime jack audio server. which is not running when testing =).
1) just to check if it helps.
2) yes, i upgraded to latest 6.9 a while ago, it ran nicely with 8762 and a geforce4ti, as the kernel did. like with the kernel, it would seriously hurt the system if id go and install the old xserver again.
3) i upgraded the bios a while ago in false hope of getting dual core supp.
4) No, but i will try to at least read some last outputs with a terminal client, but i guess there wont be much, the system freezes completely nearly instantly when hitting something bad.

gl-117, tuxracer, and foobillard seem to run without crashes. q4 runs nice even in highquality mode, even for a long time, but like i said, crashes at fixed points when reached. SPECview freezes the system after like 8 seconds.
i expect some old library to be the problem, but i have no idea which one it may be. i checked libSDL* but those seem ok now. the libGL,so s are from nvidias installer, like they should, i could find any other than those, so that should be ok also.

ideas? the system is stuffed with handinstalled services, i begin to fear that i really might have to reinstall. if i get the chance ill try to boot a livecd and see if it runs. wouldnt be good if i started the trouble of a reinstall just to end up with the same problems after days of installing.
thanks again for your attention.
tata
sonicx
sonicx is offline   Reply With Quote
Old 07-29-06, 09:54 AM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: crashes over and over: Centos 4 amd64 smp with 7800GS + 8762

The BIOS that you're using is not the latest for the motherboard (or at least not as recent as I have here).

I was able to reproduce a hang (not a reboot) with a machine check exception when running ViewPerf with a G73 GPU based card in the same motherboard. I've opened a bug for that problem. However, I'm not sure if its the same problem as you're experiencing since your system & environment differs from mine in several notable ways.

Its unlikely that you're going to be able to capture any crash output via anything other than a serial console.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 07-29-06, 02:38 PM   #7
sonicx
Registered User
 
Join Date: Jul 2006
Posts: 18
Default Re: crashes over and over: Centos 4 amd64 smp with 7800GS + 8762

hy.
you are absolutely right, that isnt the newest bios. must have confused it. i wrote the latest bios (3.03) to flash,but besides some new bios features not much has changed. quake3 still freezes the whole system. and as expected i wasnt able to capture any sensefull output with clients.

i tried ut2k4, which wouldnt crash even after 2hours of gaming/spectating.
i attached a fresh bugreport.

thanks so far,
sonicx
Attached Files
File Type: zip nvidia-bug-report.log.zip (23.0 KB, 116 views)
sonicx is offline   Reply With Quote
Old 07-29-06, 02:41 PM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: crashes over and over: Centos 4 amd64 smp with 7800GS + 8762

The system is now hanging, instead of spontaneously rebooting?

-Lonni
netllama is offline   Reply With Quote

Old 07-29-06, 03:09 PM   #9
sonicx
Registered User
 
Join Date: Jul 2006
Posts: 18
Default Re: crashes over and over: Centos 4 amd64 smp with 7800GS + 8762

mhhh yes. just locks.
sonicx is offline   Reply With Quote
Old 07-29-06, 03:18 PM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: crashes over and over: Centos 4 amd64 smp with 7800GS + 8762

Then it sounds like I may have reproduced that problem, and I opened a bug yesterday. In my case, I was seeing an MCE.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 07-29-06, 03:47 PM   #11
sonicx
Registered User
 
Join Date: Jul 2006
Posts: 18
Default Re: crashes over and over: Centos 4 amd64 smp with 7800GS + 8762

so you assume this is an incompability problem between the tyan 8111 boards and the gpu? because then it wouldnt use much to reinstall this system, and i guess ill just have to wait for a new driver release that fixes that bug. thanks for your help so far.
sonicx
sonicx is offline   Reply With Quote
Old 07-29-06, 04:10 PM   #12
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: crashes over and over: Centos 4 amd64 smp with 7800GS + 8762

Until development investigates further, it looks like an incompatibility between G7x GPUs and this motherboard.
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:03 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.