Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-04-06, 01:17 PM   #1
tinynome
Registered User
 
Join Date: Aug 2006
Posts: 4
Default OpenGL fullscreen resize problem

I have looked through many threads so far and have not run into one which matches this, so I have opted to post.

My machine: (decided to give the LINUX Journal Ultimate LINUX box a go)
MB: ABIT AN8 32x 939
CPU: AMD64 4200+ Athlon X2
RAM: Corsair 1Gx2 (4G total)
Monitor: Samsung SyncMaster 204B
Card: eVGA e-Gforce 7900GT


The problem is this, when I run cedega/WoW or UT2004 the game switches to fullscreen. However, only a fraction of the screen is used. My desktop is running at 1600x1200 and this is the "aparent" resolution of the fullscreen as well. Though, UT2004 starts at 600x800 and my WoW setup is 1024x1280. When this mode is entrered, you can hear the fan on the GPU spin up. It will spin down when the card exits this mode.

This would not be too bad but... in the WoW game I can only see the upper left part of the login screen (maybe 600x800) and can not do anything about it (save ctrl-c the game). In UT2004 I can try to alter the screen size un the setup menu. When I try to access the menu, the system locks up hard (i.e. no logs not to /var/log/messages nada.


What have I tried:
===========

1) Thought the video card might be bad, so I went outr and bough a PNY Geforce 6600 PCI-E card. Tried the same setup. Same results

2) Though I might have a driver version issue. I have installed (from .run files) the last two drivers I could get from nvida. I have also tried the binary RPMs for the distros I have tried.

3) Though it could not hurt to try a few distros to see if a compiler, library, etc could be an issue (love rebuilding kernels on this system darn fast). Nope, same results. Tried RedHat fedora 5, Mandriva 2006, ubuntu.

4) Thought there might be issues with onboard I/O. I have tried disabling the audio, ethernet, 1394, and USB. Same results.

So, I am at a loss. As per your instructions I am ataching the requested log file

P.S.
I have tried the Mesa demos to see if that might trigger anything. glxgears works fine.
Attached Files
File Type: zip nvidia-bug-report.zip (19.9 KB, 135 views)
tinynome is offline   Reply With Quote
Old 08-04-06, 01:27 PM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: OpenGL fullscreen resize problem

To me it sounds like the display section of your videocard isn't properly configured. In case of X all resolutions which you want to use need to be in this section. Right now the one for 24bit (your default depth) looks like:
Subsection "Display"
Depth 24
Virtual 1600 1200
EndSubsection

Change it to:
Subsection "Display"
Depth 24
Modes "1600x1200" "1024x768" "800x600"
EndSubsection

Further you can add any other resolutions you want to it aswell.
Thunderbird is offline   Reply With Quote
Old 08-04-06, 02:18 PM   #3
tinynome
Registered User
 
Join Date: Aug 2006
Posts: 4
Default Re: OpenGL fullscreen resize problem

Thunderbird, Thanks for your observation. Seems to be right on for cedega/WoW. I am reinstalling UT2004 again and will post results on this. Thanks again.
tinynome is offline   Reply With Quote
Old 08-04-06, 03:40 PM   #4
tinynome
Registered User
 
Join Date: Aug 2006
Posts: 4
Default Re: OpenGL fullscreen resize problem


Reinstalled UT2004, the alteration to the xorg.conf file did fix the window scaling issue .
However, the system still locks up when you select the settings menu.

What have I tried:
------------------

Though this might be related to the issue (From the README)

Chapter 5. Common Problems
OpenGL applications crash and print out the following warning:

So I did set the enviroment var

export __GL_SINGLE_THREADED=1

Results were the same. The problem is, the crash halts the system so I can collect no real diagnostic information. Bummer. However, when I rebooted the system (init 3) I collected the Xorg log file from /var/log before restarting X. I have included it in the zip file. As you can see, it only recorded the change of resolution to 800x600 before the halt.

Any thoughts?
tia
Attached Files
File Type: zip nvidia-bug-report2.zip (25.4 KB, 136 views)
tinynome is offline   Reply With Quote
Old 08-04-06, 04:07 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: OpenGL fullscreen resize problem

I have a few questions about the hang:
0) How are you determining that the system is hanging? Have you tried to ping/ssh/telnet the system?
1) Does this crash reproduce with 1.0-8762 as well?
2) Why are you booting with the noapic parameter? Does the crash reproduce if you boot with pci=noacpi instead?
3) Does the crash reproduce with a more recent (2.6.17.x) kernel?
4) Have you verified that you're using the latest BIOS for the motherboard?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 08-04-06, 07:24 PM   #6
tinynome
Registered User
 
Join Date: Aug 2006
Posts: 4
Default Re: OpenGL fullscreen resize problem

0) How are you determining that the system is hanging? Have you tried to ping/ssh/telnet the system?

The system does not respond to keystrokes (including ctrl-alt-backspace and ctrl-del)
You can not ssh into the machine
In fact, if will not respond to ARP requests.
The kernel has stopped, as far as I can tell

1) Does this crash reproduce with 1.0-8762 as well?

I did test this on the Mandriva 2006 setup yes. It failed as well in the same way.
However, I was not able to test this in the Fedora Core 5 enviroment. (gave up, kernel panic on boot issues).

2) Why are you booting with the noapic parameter? Does the crash reproduce if you boot with pci=noacpi instead?

I have had stability problems on the AMD platform with apic, disabling it makes the problem go away. I will test the pci=noacpi and report the results.

3) Does the crash reproduce with a more recent (2.6.17.x) kernel?

I did try to get this running on the Fedora Core 5 setup, but as stated gave up. I can give this a go on the Mandriva platform to see what results.

4) Have you verified that you're using the latest BIOS for the motherboard?

I belive I have. This I will check as well.


Thanks for the input. I will get back on experiment #2, then 3 and I will verify 4.
tinynome is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Major WineX prob... I think it has to do with the vidcard... Linewbie NVIDIA Linux 20 10-09-02 09:58 PM
Problem when compiling with SDL on Nvidia/Nforce... superconti NVIDIA Linux 3 09-13-02 12:25 AM
Multiple OpenGL applications and NVidia gbrauer NVIDIA Linux 7 09-01-02 04:47 PM
SMP system hangs with OpenGL chazmati NVIDIA Linux 9 08-26-02 09:28 AM
Slow OpenGL on 7.3 kl899 NVIDIA Linux 1 08-04-02 07:58 PM

All times are GMT -5. The time now is 01:21 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.