Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-25-06, 06:28 AM   #1
elanthis
Always Annoyed
 
Join Date: Oct 2002
Posts: 71
Default slow 2D rendering

I've been having trouble with really slow 2D acceleration since upgrading to Ubuntu Edgy.

Using X.org 7.1 and both the NVIDIA 1.0-8774 and 1.0-8762, all 2D rendering is really slow. By that I mean that I can watch windows repaint, and in some instances I can type faster than a program can keep up with me.

I also notice a big CPU spike both in the X process itself and the app doing the rendering in this scenario. For example, if I alt-tab between two windows, X and metacity will spike their CPU usage out, and it'll take almost 2 seconds before the window borders are redrawn.

I'm not using any sort of compositing, nor am I using Xglx. Just straight X.org 7.1 and vanilla Metacity.

However, when I use the nv driver, everything is as snappy as can be. No noticable lag or anything.

I've tried enabling and disabling RenderAccel with the nvidia driver to no effect. I'm not sure what else to try. I did check that the right driver modules (both the X module and the kernel module) are being loaded, and there's no problem there.

Suggestions?
__________________
What?
elanthis is offline   Reply With Quote
Old 08-25-06, 08:09 AM   #2
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: slow 2D rendering

Quote:
Originally Posted by elanthis
Suggestions?
First, provide the nvidia bugreport files..
Lithorus is offline   Reply With Quote
Old 08-25-06, 03:38 PM   #3
elanthis
Always Annoyed
 
Join Date: Oct 2002
Posts: 71
Default Re: slow 2D rendering

here it is.
Attached Files
File Type: zip nvidia-bug-report.log.zip (25.2 KB, 121 views)
__________________
What?
elanthis is offline   Reply With Quote
Old 08-25-06, 03:48 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: slow 2D rendering

I don't see anything suspicious in your bug report. Are you seeing this behavior in more than one window manager and/or more than one terminal app?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 08-25-06, 04:05 PM   #5
elanthis
Always Annoyed
 
Join Date: Oct 2002
Posts: 71
Default Re: slow 2D rendering

Yes, I am. Everything runs slow. Even with no window manager running, menus in applications are slow, among other things. Every time anything large changes in an application's appearance, X CPU usage and the application's CPU usage spike. X will hit around 50-80% and the application usually hits somewhere about 30-40%.

I've so far been completely unable to find any combination of software or settings which changes this behavior.

I'm going to try running things under Xgl, as it bypasses all the 2D rendering, and see if that improves anything.
__________________
What?
elanthis is offline   Reply With Quote
Old 08-25-06, 04:26 PM   #6
elanthis
Always Annoyed
 
Join Date: Oct 2002
Posts: 71
Default Re: slow 2D rendering

Hmm, looks like I was wrong. I tried again with no WM, and now it seems to make things run fast as expected. I switched to kwin, and things are remaining fast. Could've sworn I tried that before; guess that's what I get for debugging systems at 5am.

I'll re-report this as a Metacity problem with Ubuntu.
__________________
What?
elanthis is offline   Reply With Quote
Old 08-30-06, 12:13 PM   #7
elanthis
Always Annoyed
 
Join Date: Oct 2002
Posts: 71
Default Re: slow 2D rendering

I've been running this setup for a few days now, and it appears that it isn't the WM at fault. Metacity makes things a lot slower, but I've compared running things under kwin on both the nvidia and the nv driver, and there is a very noticable difference in general application performance.

Things like popup menus or tab switching are much slower when I use the nvidia driver. I can watch the updates as they happen. Under the nv driver, everything is snappy as can be.

Is there any other information I can provide to help track this problem down?
__________________
What?
elanthis is offline   Reply With Quote
Old 08-30-06, 01:22 PM   #8
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Re: slow 2D rendering

if you have subpixel antialiasing enabled, you could try to switch back to grayscale-AA.
maybe it helps a bit ... and maybe not

lg Clemens
Linuxhippy is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia 173.14.35: Fedora 17 x86 terribly slow Mr Wolf NVIDIA Linux 25 07-02-12 02:44 AM
[GeForce 8800 GTS] 2D rendering regression (extreme slowdown) introduced with 295.49 Seb L. NVIDIA Linux 0 06-22-12 07:48 AM
Gnome3 with composite is very slow on Geforce FX 5200 with 173.14.31 driver Artox NVIDIA Linux 0 05-26-12 11:33 AM
Very slow X startup Jeremy NVIDIA Linux 96 05-23-03 11:11 AM
Remote rendering???? nVIDIOT@NASA NVIDIA Linux 1 08-16-02 02:00 PM

All times are GMT -5. The time now is 06:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.