Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-09-06, 03:35 AM   #1
Linc
Linc
 
Join Date: Sep 2006
Posts: 5
Unhappy Help

I have Suse Linux 10.1 kernal 2.6.16.13-4-default, and I have written here before. I tried installing the nvidia drivers using the YAST/Zen graphical installer, "ignoring tons of missing dependancies", and have gotten nothing exept a slower screen on web pages, and when one goes through sax to configure, no graphics accelerator is found, neither are any of the graphics settings. I also went and downloaded the drivers from the nvidia site and tried the sh. .... stuff and got this:
reation time: Sat Sep 2 12:42:16 2006

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : true
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
compat32 install chroot : (not specified)
compat32 install prefix : (not specified)
compat32 install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
ERROR: The kernel header file
'/lib/modules/2.6.16.13-4-default/build/include/linux/kernel.h' does not
exist. The most likely reason for this is that the kernel source path
'/lib/modules/2.6.16.13-4-default/build' is incorrect. Please make sure
you have installed the kernel source files for your kernel and that they
are properly configured; on Red Hat Linux systems, for example, be sure
you have the 'kernel-source' RPM installed. If you know the correct
kernel source files are installed, you may specify the kernel source
path with the '--kernel-source-path' command line option.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

I also can't get the online update to even register. Why? Need help to figure this out, I am new to this stuff. But I do know I did do all the stuff that was suggested.
Linc is offline   Reply With Quote
Old 09-09-06, 07:09 AM   #2
prh
Registered User
 
Join Date: May 2005
Posts: 6
Default Re: Help

I think for a start you will need to install the kernel sources - you can do that from YOU.

The driver installation has to build a kernel module to act as the interface between the kernel and the proprietory nvidia driver. This has to be done against the correct kernel headers.

Paul
prh is offline   Reply With Quote
Old 09-10-06, 04:45 PM   #3
Linc
Linc
 
Join Date: Sep 2006
Posts: 5
Default Re: Help

How do you get the YOU to work? I just get a blank screen when I click on the Online Update.
Linc is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:56 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.