Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-15-06, 06:33 AM   #1
CRCinAU
Registered User
 
Join Date: Sep 2006
Posts: 3
Default 'invalid module format' when building module

Hi all,

I'm trying to install the nvidia drivers (1.0.8774) an on x86 P4 running Fedora core rawhide. During the kernel compilation, it fails with a warning saying:

Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko': -1 Invalid module format

I'm running fedora rawhide kernel version 2.6.17-1.2630.fc6.PAE built with gcc version 4.1.1.

Has anyone come across this and managed to fix it?
CRCinAU is offline   Reply With Quote
Old 09-15-06, 06:40 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 'invalid module format' when building module

Please attach the complete /var/log/nvidia-installer.log file, it captured some of the output of `dmesg`, which ought to provide more information about the problem (likely a compiler or configuration mismatch, etc.).
zander is offline   Reply With Quote
Old 09-15-06, 06:41 AM   #3
CRCinAU
Registered User
 
Join Date: Sep 2006
Posts: 3
Default Re: 'invalid module format' when building module

Just got a little futher after finding a post that states I must have "xorg-x11-server-sdk" installed. I have now done this, however I get an error now stating:

nvidia: disagrees about version of symbol struct_module.

the kernel source is the same version as the running kernel...

# rpm -qa | grep kernel
kernel-devel-2.6.17-1.2630.fc6
kernel-PAE-2.6.17-1.2630.fc6
kernel-headers-2.6.17-1.2630.fc6

edit: attached nvidia-installer.log
Attached Files
File Type: zip nvidia-installer.log.zip (5.0 KB, 184 views)

Last edited by CRCinAU; 09-15-06 at 06:52 AM.
CRCinAU is offline   Reply With Quote
Old 09-15-06, 06:56 AM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 'invalid module format' when building module

nvidia: disagrees about version of symbol struct_module
Judging from this error message, the kernel development files installed on your system do not match the running kernel exactly. My guess is you'll need to install the correct kernel-PAE-devel package.
zander is offline   Reply With Quote
Old 09-15-06, 07:03 AM   #5
CRCinAU
Registered User
 
Join Date: Sep 2006
Posts: 3
Default Re: 'invalid module format' when building module

Quote:
Originally Posted by zander
nvidia: disagrees about version of symbol struct_module
Judging from this error message, the kernel development files installed on your system do not match the running kernel exactly. My guess is you'll need to install the correct kernel-PAE-devel package.
Ahhhh - thanks... this was indeed the issue... I didn't realise that it was a seperate devel package. Makes sense though now that I think about it...

Now it's time to try and break it using a dual head 6800GT
CRCinAU is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 02:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 11:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 09:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM

All times are GMT -5. The time now is 04:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.