Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Closed Thread
 
Thread Tools
Old 09-22-06, 07:02 PM   #49
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Nvidia Beta driver 1.0-9625

na, I won't add any DPI options. The new driver is correct - and when I use the old one the different fonts are a nice reminder
energyman76b is offline  
Old 09-22-06, 07:17 PM   #50
smokalot
Registered User
 
Join Date: Nov 2005
Posts: 8
Default Re: Nvidia Beta driver 1.0-9625

I just installed this driver using portage; I copied the 8774 ebuild and named it 9625, cut out two lines where there were patches, digested and emerged it, which seemed to have went fine.

It does give me two problems which make it unusable for me: no accelerated GLX, and I can't get it to display 1440x900, the native resolution of my TFT.

/var/log/Xorg.0.log says:
(WW) NVIDIA(0): No valid modes for "1440x900"; removing.

I didn't need to specify a modeline using 8774, and it doesn't help if I add one now, tried both
Modeline "1440x900" 97.54 1440 1472 1840 1872 900 919 927 946
Modeline "1440x900" 100.000 1440 1456 1464 1480 900 916 924 940 -hsync -vsync

On the GLX issue it says
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) NVIDIA(0): you continue to encounter problems, Please try
(EE) NVIDIA(0): reinstalling the NVIDIA driver.

Can I do anything to get one of these things working? Or is this a bug only you can solve? Do you need any more info for that?

now that I have everything ready anyway will try compiz now, but since GLX doesn't seem to work OK the performance will likely suck bigtime.
smokalot is offline  
Old 09-22-06, 07:20 PM   #51
Le_Sot_Zi
Registered User
 
Join Date: Sep 2006
Posts: 10
Default Re: Nvidia Beta driver 1.0-9625

try this command in a shell as root :
eselect opengl set nvidia
and restart X
Le_Sot_Zi is offline  
Old 09-22-06, 07:22 PM   #52
ZeroKun
Registered User
 
Join Date: Aug 2005
Posts: 27
Default Re: Nvidia Beta driver 1.0-9625

Quote:
Originally Posted by smokalot
I just installed this driver using portage; I copied the 8774 ebuild and named it 9625, cut out two lines where there were patches, digested and emerged it, which seemed to have went fine.

It does give me two problems which make it unusable for me: no accelerated GLX, and I can't get it to display 1440x900, the native resolution of my TFT.

/var/log/Xorg.0.log says:
(WW) NVIDIA(0): No valid modes for "1440x900"; removing.

I didn't need to specify a modeline using 8774, and it doesn't help if I add one now, tried both
Modeline "1440x900" 97.54 1440 1472 1840 1872 900 919 927 946
Modeline "1440x900" 100.000 1440 1456 1464 1480 900 916 924 940 -hsync -vsync
Are you using DVI? I also have a TFT with a native resolution of 1440x900 and it works fine, but I'm using a vga connector. It's running on this modeline:

"1440x900" 136.75 1440 1536 1688 1936 900 903 909 942 -hsync +vsync
ZeroKun is offline  
Old 09-22-06, 07:24 PM   #53
Le_Sot_Zi
Registered User
 
Join Date: Sep 2006
Posts: 10
Default Re: Nvidia Beta driver 1.0-9625

# ldd `which compiz`
linux-gate.so.1 => (0xffffe000)
libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb7f7c000)
libz.so.1 => /lib/libz.so.1 (0x46cf0000)
libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xb7f79000)
libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb7f76000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb7f71000)
libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb7f6e000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb7f67000)
libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb7f64000)
libXext.so.6 => /usr/lib/libXext.so.6 (0xb7f59000)
libXau.so.6 => /usr/lib/libXau.so.6 (0xb7f56000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb7f50000)
libdl.so.2 => /lib/libdl.so.2 (0xb7f4c000)
libstartup-notification-1.so.0 => /usr/lib/libstartup-notification-1.so.0 (0x46923000)
libSM.so.6 => /usr/lib/libSM.so.6 (0xb7f44000)
libICE.so.6 => /usr/lib/libICE.so.6 (0xb7f31000)
libX11.so.6 => /usr/lib/libX11.so.6 (0xb7e67000)
libm.so.6 => /lib/libm.so.6 (0xb7e41000)
libc.so.6 => /lib/libc.so.6 (0xb7d23000)
/lib/ld-linux.so.2 (0xb7fca000)

no linking with libnvidia-tls.so.1 . This is the error. I've just compiled compiz, so how to have the link with libnvidia-tls ?
Le_Sot_Zi is offline  
Old 09-22-06, 07:28 PM   #54
Le_Sot_Zi
Registered User
 
Join Date: Sep 2006
Posts: 10
Default Re: Nvidia Beta driver 1.0-9625

I'm testing this : http://forums.gentoo.org/viewtopic-p...7.html#3596897
Le_Sot_Zi is offline  
Old 09-22-06, 07:43 PM   #55
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: Nvidia Beta driver 1.0-9625

Thanks for making beta driver.
zbiggy is offline  
Old 09-22-06, 07:47 PM   #56
smokalot
Registered User
 
Join Date: Nov 2005
Posts: 8
Default Re: Nvidia Beta driver 1.0-9625

Quote:
Originally Posted by Le_Sot_Zi
try this command in a shell as root :
eselect opengl set nvidia
and restart X
it works! I thought this wasn't necessary because emerge already did it. Now google earth finally works on my 6150!

Quote:
Are you using DVI? I also have a TFT with a native resolution of 1440x900 and it works fine, but I'm using a vga connector. It's running on this modeline:

"1440x900" 136.75 1440 1536 1688 1936 900 903 909 942 -hsync +vsync
yes, I am using DVI, but this modeline doesn't work. will try VGA.
smokalot is offline  

Old 09-22-06, 07:50 PM   #57
Le_Sot_Zi
Registered User
 
Join Date: Sep 2006
Posts: 10
Default Re: Nvidia Beta driver 1.0-9625

I've tested "official" compiz, not quinnstorm : it doesn't segfault. But I've got a blank screen. So the error is from quinnstorm. Perhaps a mistake in the ebuild ?
Le_Sot_Zi is offline  
Old 09-22-06, 07:52 PM   #58
Le_Sot_Zi
Registered User
 
Join Date: Sep 2006
Posts: 10
Default Re: Nvidia Beta driver 1.0-9625

Tried to replace xorg-x11 by nvidia in /usr/portage/x11-wm/compiz/compiz-0.0.13_pre20060921.ebuild . I've got compiz working fine !!!
Le_Sot_Zi is offline  
Old 09-22-06, 08:02 PM   #59
spudw
Registered User
 
Join Date: Sep 2006
Posts: 1
Default Re: Nvidia Beta driver 1.0-9625

ok im running kubuntu dapper, i got the drivers installed but i have to startup into commandline and run xinit. then i can startkde but i cant run compiz cuz its segfaults. im gonna see if i can get xorg7.1 on here. i think that may be the problem cuz i am trying to run xorg-air but everyone keeps saying u dont need xorg-air with nvidia
spudw is offline  
Old 09-22-06, 08:11 PM   #60
cbaoth
Registered User
 
Join Date: Feb 2004
Posts: 2
Default Re: Nvidia Beta driver 1.0-9625

96.25 gives me a black display, but the system does not crash. I can hear the gdm start up sound and switching to a virtual terminal works. Although the 96.25 driver doesn't detect the native 1400x1050 mode, adding a mode line for it changes nothing. If you change back to the 87.74/nv drivers the display works again. The system is a Dell Inspiron 8100 with a GeForce 4 Go 440 running straight Ubuntu Dapper (xorg 7.0, gnome 2.14 no new fangled compiz stuff).

I've attached nvidia-bug-report.sh output for both 87.74 (working) and 96.25
Attached Files
File Type: log nvidia-bug-report-9625.log (114.6 KB, 216 views)
File Type: log nvidia-bug-report-8774.log (123.9 KB, 202 views)

Last edited by cbaoth; 09-22-06 at 09:49 PM.
cbaoth is offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA R302.80 Beta Driver for Windows 8, New OpenGL Extensions News Archived News Items 0 06-15-12 11:30 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 10:55 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM

All times are GMT -5. The time now is 04:32 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.