Go Back   nV News Forums > Graphics Card Forums > NVIDIA GeForce 7, 8, And 9 Series

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-01-03, 08:19 AM   #1
Clay
Registered User
 
Clay's Avatar
 
Join Date: Oct 2002
Posts: 4,993
Default New BFG Tech 5900U Review

I've put the wraps on my review of the BFG Technologies Asylum™ GeForce™ FX 5900 Ultra here at nV News. Mike will be posting it on the site sometime this coming Sunday (8.3.03) evening.
Clay is offline   Reply With Quote
Old 08-01-03, 10:40 AM   #2
azanon
Registered User
 
Join Date: Mar 2003
Posts: 101
Default misc

So give us a mini-preview. Does it flicker? Sorry i had to ask.

I just cant get over the flicker thing, and I dont think ive seen it mentioned in one GFFX review yet. I'm not sure i can trust reviews anymore at all cause obviously if you review it bad, then you might not get any more samples.
azanon is offline   Reply With Quote
Old 08-01-03, 10:42 AM   #3
digitalwanderer
 
digitalwanderer's Avatar
 
Join Date: Jul 2002
Location: Highland, IN USA
Posts: 4,944
Default Re: misc

Quote:
Originally posted by azanon
I'm not sure i can trust reviews anymore at all cause obviously if you review it bad, then you might not get any more samples.
That should not be an influencing factor in telling the truth when judging hardware, it seriously shouldn't.
__________________
[SIZE=1][I]"It was very important to us that NVIDIA did not know exactly where to aim. As a result they seem to have over-engineered in some aspects creating a power-hungry monster which is going to be very expensive for them to manufacture. We have a beautifully balanced piece of hardware that beats them on pure performance, cost, scalability, future mobile relevance, etc. That's all because they didn't know what to aim at."
-R.Huddy[/I] [/SIZE]
digitalwanderer is offline   Reply With Quote
Old 08-01-03, 12:32 PM   #4
Serious Tom
Come Get Some !
 
Serious Tom's Avatar
 
Join Date: Jun 2003
Location: Illinois, U.S. of A.
Posts: 20
Default

I couldn't wait any longer and went ahead and got a eVGA 5900 Ultra, I flashed the card to the performance bios ( 500/900 ) and I have never had one flicker. It must be something, but I haven't had any with a Epox 8RDA................Tom
Serious Tom is offline   Reply With Quote
Old 08-01-03, 03:31 PM   #5
Clay
Registered User
 
Clay's Avatar
 
Join Date: Oct 2002
Posts: 4,993
Default Re: misc

Quote:
Originally posted by azanon
So give us a mini-preview. Does it flicker? Sorry i had to ask.

I just cant get over the flicker thing, and I dont think ive seen it mentioned in one GFFX review yet. I'm not sure i can trust reviews anymore at all cause obviously if you review it bad, then you might not get any more samples.
No problem. No, I did not experience any flickering. Though I know that Volt's Prolink 5900 non Ultra does. I really had no problems at all with this card from BFG.

Also, I ran the entire review with the card clocked at ...

Core Clock: 500
Memory Clock: 926

...and it was rock solid stable.

Last edited by Clay; 08-01-03 at 03:42 PM.
Clay is offline   Reply With Quote
Old 08-01-03, 05:29 PM   #6
reever2
Registered User
 
reever2's Avatar
 
Join Date: Apr 2003
Posts: 489
Default

I hope this review doesnt spur any "controversial" issues people have been having lately
reever2 is offline   Reply With Quote
Old 08-01-03, 05:35 PM   #7
SH64
MAXIMUM TECH
 
SH64's Avatar
 
Join Date: Jul 2003
Location: Indiana
Posts: 12,202
Default Re: Re: misc

Quote:
Originally posted by maxpower

...and it was rock solid stable.
i'd like to know which detonator drivers where used in the review & if theres any bechmark difference between them & what drivers do you think works best with 5900 Ultra .
SH64 is offline   Reply With Quote
Old 08-01-03, 11:27 PM   #8
Clay
Registered User
 
Clay's Avatar
 
Join Date: Oct 2002
Posts: 4,993
Default Re: Re: Re: misc

Quote:
Originally posted by SH64
i'd like to know which detonator drivers where used in the review & if theres any bechmark difference between them & what drivers do you think works best with 5900 Ultra .
I used the 44.03 drivers. If enough interest I might append review in some select benches with different version(s).
Clay is offline   Reply With Quote

Old 08-01-03, 11:30 PM   #9
SH64
MAXIMUM TECH
 
SH64's Avatar
 
Join Date: Jul 2003
Location: Indiana
Posts: 12,202
Default Re: Re: Re: Re: misc

Quote:
Originally posted by maxpower
If enough interest I might append review in some select benches with different version(s).

Yeah! that would be cool .
SH64 is offline   Reply With Quote
Old 08-02-03, 02:06 AM   #10
macachia
Registered User
 
Join Date: Jul 2003
Posts: 87
Default

hi, does it make a wierd noise when scrolling on ie/mirc, resizing windows, maximizing etc?

it's a faint noise 5900 reported which seems to originate from the card itself (voltage regulation it seems)

thanks
macachia is offline   Reply With Quote
Old 08-02-03, 03:05 AM   #11
ringu61
 
Join Date: Dec 2002
Posts: 103
Default

My Leadtek GeForce FX5900 A350 TDH 128MB MyVivo did core:510MHz memory:985MHz
__________________
My Computer Spec:

*Microsoft WindowsXp Professional Edition + Service Pack 1
*AMD AthlonXP/MP-M +L12 Mod Barton 2500+ FSB 232.7 x Multi 11 = 2559.5MHz @ 4100+ Still Testing
+ThermalTake AqariusII Liquid Cooling Kits (Modified)
*DFI Lanparty NF2 Ultra B Mainboard (Official LP-B BIOS 2004/05/05)
*KingMax 2x 512MB [1GB] DDR433 DDRRAM
*Gigabyte GV-N595U-GT TDH MyVIVO 128MB DDR AGP8X @ 555/1000
+Thermaltake Giant III HeatPipe Cooler
*Creative Sound Blaster Audigy2 ZS
*Thermaltake Purepower ButterFly 480W + Active PFC


PS: Never believe in Reviews until u tried it~
ringu61 is offline   Reply With Quote
Old 08-02-03, 12:54 PM   #12
DaNzA
Registered User
 
Join Date: May 2003
Posts: 17
Default

Quote:
Originally posted by macachia
hi, does it make a wierd noise when scrolling on ie/mirc, resizing windows, maximizing etc?

it's a faint noise 5900 reported which seems to originate from the card itself (voltage regulation it seems)

thanks
Wow! I was just about to return my card after I heard those noise... but it only appear when I use analogue audio output on my audigy 2, when I switch to digital DIN output, the noise disappeared

Thanks for the info
DaNzA is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Age of Empires Online interview: Tech trees and civ customization News Archived News Items 0 05-21-12 05:00 PM
Product Review ' SteelSeries Scope Gaming Eyewear by Gunnar News Archived News Items 0 05-18-12 09:30 PM
Product Spotlight ' EVGA GTX 670 Review Round Up News GeForce GTX 670 Reviews 1 05-11-12 12:15 AM
Coolest jobs in tech: from the pits of Le Mans to the dugouts of Fenway Park News Archived News Items 0 05-10-12 01:50 PM
nV News 9700 Review pelly Other Desktop Graphics Cards 45 10-17-02 12:53 AM

All times are GMT -5. The time now is 03:12 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.