Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-21-02, 01:06 PM   #1
hgfelger
Registered User
 
Join Date: Nov 2002
Posts: 10
Default colour-depth is lower, than it should with 4191

Salut,
I use a GeForce2Go rev 178 in a Acer TM634LC with Linux 2.4.20 and a
display-res. of 1400x1050 @ 24bpp, 59.8 Hz
and a virtual res of 1600x1280

While with version 3123 everything is ok, and with 4191 it says, that it is 24bpp, it shows obviously radically less colour-depth. I used the same XF86config.

What did I do wrong?

----from XF86conf----
Section "Device"
BoardName "GeForce2 Go"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
# Option "FlatPanel"
#Option "CrtcNumber" "0"
Screen 0
VendorName "NVidia"
# Option "UseEdidFreqs"
## Option "RenderAccel"
# Option "NoBandWidthTest" "on"
Option "DAC8bit" "on"
# Option "CIOverlay" "on"
# Option "OverlayDefaultVisual" "on"
EndSection
hgfelger is offline   Reply With Quote
Old 12-21-02, 08:03 PM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Can you post your /var/log/XFree86.0.log?

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 12-22-02, 07:40 AM   #3
hgfelger
Registered User
 
Join Date: Nov 2002
Posts: 10
Default

My XFree86.0.log is attached. I needed to rename it to ending in .txt for this forum to take it uploaded...

When I say, that everything work right with 3123, then this is only right for X. After starting X, when comming back to the console, the vertical refresh seams to be wrong. Although still readable, it is looking very bad. But this is a different topic.
Attached Files
File Type: txt xfree86.0.log.txt (27.1 KB, 165 views)
hgfelger is offline   Reply With Quote
Old 12-22-02, 07:47 PM   #4
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

You're only setting 1280x1024, which means your panel is probably scaling (which would explain the "poor look"). The 1400x1050 mode is being thrown out because your hsync is out of range. Were you ignoring EDID frequencies with 1.0-3123?

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 12-23-02, 06:49 PM   #5
hgfelger
Registered User
 
Join Date: Nov 2002
Posts: 10
Default

Salut Andy,
thank's a lot! The EDID thing brought me to the right track. To make the nvidia-closed-source driver first run on my notebook, I had to add a modeline. This bit me now. My first try today was to use "NoDCC" to override the EDID frequencies, as my modeline was 0.1 kHz higher, than EDID allowed.
This brougth the new driver to work! Now I removed the modeline section to let X recalculate it's modeline, and redraw the "NoDCC" option. Now I have a clean solution.
Thanks!
hgfelger is offline   Reply With Quote
Old 01-17-03, 03:30 PM   #6
onLoad
Registered User
 
Join Date: Jan 2003
Location: Munich
Posts: 2
Default

Hi,

@hgfelger:

I have also a TravelMate 634 LC and the same problems. Can you send me your XF86Config ? So I can compare it with mine. For the moment, I use 1024x768 as display resolution. Switching back to console produces flashing. It is readable but not good.

I use the SuSE 8.1 with nvidia 4191.

Thanks.
onLoad is offline   Reply With Quote
Old 01-20-03, 12:08 PM   #7
hgfelger
Registered User
 
Join Date: Nov 2002
Posts: 10
Default

Salut nameless,
sorry, for answering so late... but I wanted to point you also to the touchpad-driver I use (which is also in the XF86config...). I use the synaptics-driver from http://mobilix.org/software/synaptics/
the file synaptics-0.11.3.tar.gz. If I am right, you just need to copy the synaptics_drv.o into your /usr/X11R6/lib/modules/input directory.
Don't be irritated, that I configured a second mouse...
The problem, that after starting X the virtual consoles are looking strange, still persists for me. I think we should open a new thread for this: "flickering virtual-console, after X was started"
If you have other problems with this notebook. feel free to mail me hgfelger@hgfelger.de

Regards
hartwig felger ;-)
Attached Files
File Type: txt xf86config.txt (5.9 KB, 138 views)
hgfelger is offline   Reply With Quote
Old 01-21-03, 02:29 AM   #8
onLoad
Registered User
 
Join Date: Jan 2003
Location: Munich
Posts: 2
Default

Guten Morgen, Good Morning, etc...

thanks. I'll try it this week and report my results.

Regards.

Gunther Grelczak
Deutsches Museum ;-)
onLoad is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Impressions: Colour Bind News Archived News Items 0 10-04-12 05:30 PM
Now Available - Colour Bind, 20% off! News Archived News Items 0 09-24-12 02:10 PM
Weird colour effects Stefan.W NVIDIA Linux 3 11-24-02 04:56 PM

All times are GMT -5. The time now is 11:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.