Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-09-07, 09:01 PM   #1
wes0472
Registered User
 
Join Date: Oct 2007
Posts: 3
Default XFX 7600GS HDMI won't detect connected display properly

Hi all,

My 7600GS won't detect my LG32LC7D LCD TV when I have it connected using a long HDMI cable. If I use a short HDMI cable, everything works fine. If I start X with the short HDMI cable connected and then swap it with the longer cable while X is still running, the long cable works fine. But if I try to start X with the long cable connected, nothing. The short cable is ~6 feet and the long cable is ~30 feet.

I tried using the ConnectedMonitor option to force the driver to use DFP-1, then I ran into EDID problems. So using the short cable and the nvidia-settings utility, I dumped the edid file and used the CustomEDID option to specify the EDID manually.

At this point, I have an xorg.conf which works fine and reports no errors with either cable, but only works properly when starting X with the short cable connected. It seems to me like the video card just isn't trying to send a signal when the long cable is connected, even though I explicity specified the ConnectedMonitor option. I want to reiterate that the long cable works fine if I start X with the short cable connected, and then swap the cables while X is running. There are no artifacts or snow or any signs of display corruption.

Any suggestions for other things to try? I'm attaching the output of nvidia-bug-report.sh with the short and long cable connected as well as my edid.bin file.

Thanks,
Bill
Attached Files
File Type: gz nvidia-bug-report.log.gz (36.5 KB, 96 views)
File Type: gz nvidia-bug-report.log.longcable.gz (36.5 KB, 99 views)
File Type: gz edid.bin.gz (204 Bytes, 91 views)
wes0472 is offline   Reply With Quote
Old 10-09-07, 09:14 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: XFX 7600GS HDMI won't detect connected display properly

This sounds like a problem with the long cable.
netllama is offline   Reply With Quote
Old 10-09-07, 09:46 PM   #3
wes0472
Registered User
 
Join Date: Oct 2007
Posts: 3
Default Re: XFX 7600GS HDMI won't detect connected display properly

If that was the case, why does the long cable work fine if I start X using the short cable and then swap cables while X is running? The long cable also works perfectly fine with my DVD player, as well.
wes0472 is offline   Reply With Quote
Old 10-09-07, 09:58 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: XFX 7600GS HDMI won't detect connected display properly

The problem is only present with the long cable. I'm not clear why you would think it wasn't the long cable that was faulty?
netllama is offline   Reply With Quote
Old 10-09-07, 10:20 PM   #5
wes0472
Registered User
 
Join Date: Oct 2007
Posts: 3
Default Re: XFX 7600GS HDMI won't detect connected display properly

Quote:
Originally Posted by netllama
The problem is only present with the long cable. I'm not clear why you would think it wasn't the long cable that was faulty?
Like I mentioned, it works fine with other devices and it even works fine with the card if I start X using the short cable and then switch to the long cable. The only time it doesn't work properly is when X starts up while I'm using the long cable.

In general I'm extremely frustrated with HDMI, so I really don't know where to point the finger. I've had nothing but problems since I started trying to use it, even with simple short cables. I still can't get audio to work over the HDMI connection. It just seems so flaky in general, I'm about ready to give up on it entirely and just wire everything with regular component and audio cables.
wes0472 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Glx mrbig1344 NVIDIA Linux 7 09-30-02 07:45 AM

All times are GMT -5. The time now is 03:28 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.