Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-05-07, 09:04 AM   #13
jd3010
Registered User
 
Join Date: Oct 2007
Posts: 15
Default Re: GeForce2 0x01a0 & 96.43.01 works badly

No at all,

I also though that I was the only one experiencing this problem .... As they told me it might be the Bios, but there is no updated version, so I gave up ....

I will read carefully through your thread, but in case you can give me any advise ...

Thanks
jd3010 is offline   Reply With Quote
Old 11-05-07, 11:24 AM   #14
rahuljawale
Registered User
 
Join Date: Nov 2004
Posts: 27
Default Re: GeForce2 0x01a0 & 96.43.01 works badly

Licaon has posted a reply to my thread which in turn refers to another thread in the forums. He has suggested me to install last working stable release 8776 and patch to make it work on newer kernels.

I am going to try it and post the results here. I have kept my fingers crossed.
rahuljawale is offline   Reply With Quote
Old 11-05-07, 11:27 AM   #15
rahuljawale
Registered User
 
Join Date: Nov 2004
Posts: 27
Default Re: GeForce2 0x01a0 & 96.43.01 works badly

What I mean here by last working stable release is "Last working stable release for Us having problems with Geforce 2MX boards".
rahuljawale is offline   Reply With Quote
Old 11-06-07, 12:10 PM   #16
rahuljawale
Registered User
 
Join Date: Nov 2004
Posts: 27
Default Re: GeForce2 0x01a0 & 96.43.01 works badly

Do try NVIDIA 8776+patch. It works for me.

Follow this link.

Installing patched 8776
rahuljawale is offline   Reply With Quote
Old 12-30-07, 12:11 PM   #17
miraceti
Registered User
 
Join Date: Oct 2007
Posts: 8
Default Re: GeForce2 0x01a0 & 96.43.01 works badly

Quote:
Originally Posted by rahuljawale
Do try NVIDIA 8776+patch. It works for me.

Follow this link.

Installing patched 8776
Hi! Thanks for your help. I tried to do it and I gets following error:
Code:
i686-pc-linux-gnu-gcc -Wp,-MD,/mnt/maxtor120/tmp/portage/x11-drivers/nvidia-drivers-1.0.8776-r2/work/NVIDIA-Linux-x86-1.0-8776-pkg0/usr/src/nv/.nv.o.d  -nostdinc -isystem /usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include -D__KERNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.23-gentoo-r3/include -include include/linux/autoconf.h  -I/mnt/maxtor120/tmp/portage/x11-drivers/nvidia-drivers-1.0.8776-r2/work/NVIDIA-Linux-x86-1.0-8776-pkg0/usr/src/nv -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Os -pipe -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=athlon -ffreestanding -maccumulate-outgoing-args -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -I/usr/src/linux-2.6.23-gentoo-r3/include/asm-i386/mach-default -Iinclude/asm-i386/mach-default -fomit-frame-pointer -fno-stack-protector -Wdeclaration-after-statement -Wno-pointer-sign  -I/mnt/maxtor120/tmp/portage/x11-drivers/nvidia-drivers-1.0.8776-r2/work/NVIDIA-Linux-x86-1.0-8776-pkg0/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wno-multichar -Werror -O -fno-common -MD -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNTRM -DNVRM -DDYNAMIC_SLI -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=8776 -UDEBUG -U_DEBUG -DNDEBUG -DNV_SIGNAL_STRUCT_RLIM -DNV_MULTIPLE_BRIDGE_AGPGART_PRESENT -DNV_PCI_GET_CLASS_PRESENT -DNV_SYSCTL_MAX_MAP_COUNT_PRESENT -DNV_PM_MESSAGE_T_PRESENT -DNV_PCI_CHOOSE_STATE_PRESENT -DNV_VM_INSERT_PAGE_PRESENT -DNV_REMAP_PFN_RANGE_PRESENT -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_VMAP_4_PRESENT -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(nv)"  -D"KBUILD_MODNAME=KBUILD_STR(nvidia)" -c -o /mnt/maxtor120/tmp/portage/x11-drivers/nvidia-drivers-1.0.8776-r2/work/NVIDIA-Linux-x86-1.0-8776-pkg0/usr/src/nv/nv.o /mnt/maxtor120/tmp/portage/x11-drivers/nvidia-drivers-1.0.8776-r2/work/NVIDIA-Linux-x86-1.0-8776-pkg0/usr/src/nv/nv.c
/mnt/maxtor120/tmp/portage/x11-drivers/nvidia-drivers-1.0.8776-r2/work/NVIDIA-Linux-x86-1.0-8776-pkg0/usr/src/nv/nv.c:102: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
I get it always when I try to compile some older nvidia driver. Except this driver, I tried also nvidia-drivers-1.0.9755-r1 , nvidia-drivers-1.0.9746-r1 and nvidia-drivers-1.0.8776-r1 today. I am currently using kernel 2.6.23-gentoo-r3 (xorg-x11 is 7.2 and xorg-server is 1.3.0.0-r2) - all version numbers are comming from Gentoo's Portage. The driver 96.43.01 is compiled successfully and it is possible to modprobe it but the system gets totally frozen when Nvidia logo appears.

Sorry for my slow reactions. I am busy with another things too.
miraceti is offline   Reply With Quote
Old 12-30-07, 12:22 PM   #18
miraceti
Registered User
 
Join Date: Oct 2007
Posts: 8
Default nvidia-bug-report.log for the post #17

I forgot to include the bug report. Here it is (for driver 96.43.01, kernel 2.6.23-gentoo-r3, xorg-x11 7.2 and xorg-server 1.3.0.0-r2).
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (27.1 KB, 108 views)
miraceti is offline   Reply With Quote
Old 12-30-07, 12:35 PM   #19
miraceti
Registered User
 
Join Date: Oct 2007
Posts: 8
Default Re: GeForce2 0x01a0 & 96.43.01 works badly

I tried again 96.43.01 with NvAGP=0. It does not freeze but the problem is still the same as I described in the post #1. Sad...

When glxgears is run, the whole screen goes black. I can switch to a console and back and then I can see glxgears revolving in about 560 fps (+-). But the whole desktop looks very ugly with all the artefacts.
miraceti is offline   Reply With Quote
Old 01-30-09, 12:30 PM   #20
dr_asfak
Registered User
 
Join Date: Jun 2008
Posts: 20
Default Re: GeForce2 0x01a0 & 96.43.01 works badly

Quote:
Originally Posted by rahuljawale View Post
What I mean here by last working stable release is "Last working stable release for Us having problems with Geforce 2MX boards".
I have tried all combination but never succeeded. Nvidia people, please please have a look at this issue.
dr_asfak is offline   Reply With Quote

Old 03-24-09, 01:26 PM   #21
crow
Registered User
 
Join Date: Jan 2004
Posts: 43
Default Re: GeForce2 0x01a0 & 96.43.01 works badly

FYI: I'm running 8776 with kernel 2.6.22.19 using an old Gentoo ebuild, which may be patching things slightly. 8776 is the last driver nVidia ever released that does 1080i correctly, and since I'm using this with MythTV and a native 1080i television, I can't upgrade drivers. I haven't been able to upgrade kernels past 2.6.22.19.

I would love to upgrade to a newer kernel. Does anyone have any pointers on patching the driver to run on 2.6.23 or later?
crow is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:02 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.